Need help with porting ubuntu-touch to my phone



  • I am porting ubuntu-touch for my phone but I do stuck in endless reboots . I want someone to provide me with the patches they used to bring up ubuntu-touch kernel and a working boot image from any device like nexus ..
    thanks



  • Hm I would suggest that what you have asked for is available on GitHub but perhaps start with wiki.ubports.com.



  • @apple.muncy can you upload a prebuilt boot.img from nexus device ? I want to check some thing also what commits are used to bring up kernel for ubuntu-touch ? https://github.com/ubports/android_kernel_lge_hammerhead



  • I'll attempt to tell you how to find the ones built by the Ubports Jenkens server.
    If you execute this

    ubuntu-device-flash -v --server=http://system-image.ubports.com touch --channel=ubuntu-touch/devel_rc-proposed –device=hammerhead --download-only
    

    Then look in

    ~/.cache/ubuntuimages/pool  
    

    You will find among other files, this one

    59147132 Dec 21 18:57 device-1343cffe4d2fe5b529e198a4182e1b20de176d284b1d340f5b44f3ac25896e79.tar.xz
    

    If you then extract you will find two directories labeled partition with boot.img and recovery.img within and another directory labeled system.



  • @apple.muncy , thanks for your reply .
    one more thing , I've studied the scripts in boot.img to try to figure out what is going on in boot precess and I found out that it mounts some partitions then ubuntu.img after that it mounts android ramdisk which should start all important android services so what should after that ? what is the responsible thing to start up ubuntu-touch system ? is that a service , shell script or what ?



  • You are definitely looking in the right place for answers. Have look at this page for an understanding what is happening:
    https://wiki.ubuntu.com/Touch/ContainerArchitecture



  • @apple.muncy first Merry Christmas .. second sorry for annoying you .... after I checked the link you provided ,things started to get more obvious but I have a question ....
    can I flip everything so instead of running android ramdisk into lxc , can I run ubuntu-phone itself into one of those container so what i am going to do .. start booting off android ramdisk then i mount ubuntu.img into its place then i start ubuntu-phone into lxc ....... if that is possible somehow . where is ubuntu-phone init file that starts the system it self ?
    I want to clear something out too ,, the reason why I want to do this , is because when I try to boot the phone it just turns off (I use ubuntu boot image ) .
    Thanks


  • Community

    Hi @LehKeda

    We haven't had anyone try to run the system like that, and it would probably be much harder than you think. See, Ubuntu Touch uses Upstart rather than Android's init.rc. I'm also not sure how you'd get Android to give display control to Mir... I just don't have that in-depth of knowledge of the system.

    You're saying that you're having a boot-loop very early in the system startup? If so, it's very possible that the issue is a kernel panic. What device are you trying to port to, and what Android version and Kernel version did you start with?



  • @UniSuperBox I'm trying to port to samsung galaxy star (GT-S5282) kernel version 3.0.101
    stock android version is 4.1 with openEgles v2 but we run android 7.0 on it .



  • Hi,

    I’m trying to port Ubuntu touch for Moto G 2014 (XT1068)

    I'm in the end step of booting, see this :

    [ 7.433841,1] initrd: mounting /dev/disk/by-partlabel/boot as /root/android//boot
    [ 7.454993,3] initrd: checking mount label recovery
    [ 7.457615,0] initrd: mounting /dev/disk/by-partlabel/recovery as /root/android//recovery
    [ 7.497315,3] initrd: checking mount label mmc_host*
    [ 7.517051,2] initrd: checking mount label usb1
    [ 7.554915,0] initrd: checking mount label zram0
    [ 7.558913,1] initrd: mounting /dev/zram0 as /root/android/none
    [ 7.563701,1] initrd: mounting /root/var/lib/lxc/android/system.img as /root/android/system
    [ 7.631982,1] systemd-udevd[181]: Validate module index

    At this point the system try to mount system.img
    But after that the system crash

    [ 7.998344,1] Crash partition in use!
    [ 8.998513,1] wcnss crash shutdown 0
    [ 8.998592,1] Rebooting in 5 seconds..
    [ 13.998672,1] Going down for restart now
    [ 13.999581,1] failed to disable wdog debug: -4
    [ 13.999672,1] Calling SCM to disable SPMI PMIC arbiter

    PREV
    Linux version 3.4.42-g832c593-dirty (walidham@phablet) (gcc version 4.8 (GCC) ) #5 SMP PREEMPT Thu Feb 2 21:02:43 UTC 2017

    you can find full log her,
    https://drive.google.com/file/d/0B-F-xs4jYP12dWdsWGFXYlpIeEU/view?usp=sharing

    Best regards



  • @walidham I couldn't get ubunu phone run on my phone until now and it seems like I have th same problem as yours , however I can't confirm as my kernel doesn't support last_kmsg ....
    I'm afraid that I can't help you ,but you can mention other members they maybe could help you .



  • @LehKeda thanks, i solved this issue , now phone boot, but no graphic, just moto logo, i have pb in graphics driver



  • @walidham Please , could you give me more information about the issue and how you solved it ?


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.