problems flashing UBports on Meizu PRO 5 (Android international edition)

  • @Stefano : Hello. I try to put my Pro 5 15.04 in 16.04 (formerly Android) but I can't.
    I tried with your method to increase the cache but I have too much error message.
    I wonder if you received an echo with the use of gparted. if it works or not.

    And second query, if I turn everything except TWRP, will it work with "ubports-installer" or I would still have to increase the cache?

    thank you in advance

  • @math if you follow the guide carefully, you should be able to resize the .cache partition. Ignore the error messages and just continue.

    By restoring the Backup 16.04 stable with TWRP, just download it, unpack it and then restore it. Afterwards, you'll only need to flash Ubuntu Recovery with fastboot.
    But, the future updates (OTA-stable, rc, devel ) might fail due the size of the .cache (if you don't resize it before) , otherwise you should be able to use Ubports installer.

  • @stefano Thank you very much. I will try again. But you think OTAs in the future will be bigger and bigger. Or it's only for the passage in 16.04

  • @math Difficult to say, but I've seen a discussion of Ubports devs about shrinking the image size of futures OTA's .

  • @stefano I made the change sda42-43.
    But when I wanted to install the 16.04 with ubsports-installer 0.1.20, it still put me the error "boot.img".
    Whereas with the version 0.1.12, the installation 16.04 did well.
    Hoping that the OTA 5 will be fine.

    thank you for your explanations

  • @math Make sure you have installed latest fastboot and adb on your PC and try again.

  • @math I have got the same problem even after resize the partition, what i have done and worked for me :

    sudo ubuntu-device-flash --server= touch --device=turbo --channel=ubports-touch/16.04/rc --wipe

  • @xray2000 For me as well it was the only option.

  • Noting my success details posted at

  • I have re flashed flyme 6, and downgraded to flyme 5, then flashed the unlocked bootloader,then flashed UB, some times It will not go past the UB,recovery screen, I have then flashed twrp wiped, then flash a twrp made restore of UB,then flashed UB recovery to get a working OTA,and then updated.
    I have done this with ch/en, flyme.

    I quess,adb,is not,recognized sometimes

Log in to reply