What to start from when building together Raspberry Ubuntu Touch?

  • @matteo the group in Telegram is https://t.me/UBports_pi but I don't know if there's another in Matrix too

  • @adams Would not the 4.15 kernel and newer mesa stack provided by Ubuntu 16.04.5 provide the newer graphics drivers you mentioned from 18.04?

  • Also, I think a really good first step here would be to identify which components of the stack rely on using android properties for storing certain option values, and reporting issues for those. This should be one of the easier things to migrate away from, to make things more consistent with the x86 unity8 stack builds.

    Next we should identify components which have a hard dependency on hybris, and document those in issues as well. This will be much harder to fix, as we'd need to re-architect things a bit, so that hybris is not the only method of interacting with the system. Ideally, this would be done by making hybris a runtime loadable dependency, via an abstraction, so we could avoid shipping hybris entirely on device that don't need it. However, it will be much more difficult to do that, rather than to keep shipping it, but fixing code to handle certain failures more gracefully and to access hardware more directly when running on top of more standard Linux devices.

  • @adams Ubuntu Touch is a bit more than just Ubuntu + Unity8. Until now Ubuntu Touch has only be build for Android phones, so the partition layout is different (https://forums.ubports.com/topic/1296/partition-layout). The root file system is read-only, there is app confinement, we access the hardware via libhybris (to be compatible with Android drivers) and so on (there are 400 UBports repos on github https://github.com/ubports).

    In my opinion, as a first step it would already be nice to have raspy images with Ubuntu+Unity8 running for testing. Next step would probably be what Rodney says.

  • Thanks for the replies.

    There is a pi usable 4.15 kernel for arm64, but currently the generic armhf doesn't work on the pi. The only armhf kernel is the Linux-raspi2 kernels https://launchpad.net/ubuntu/+source/linux-raspi2. So if 16.04 is the best for UBports, then arm64 is the easiest to go for without recompiling a kernel.

    I'm not sure what the status is of Android on the pi (when I say pi I really mean the pi 2 or 3B/3B+) or what graphics drivers it uses. I haven't yet tried any of the Android builds. A recent-ish article that mentions the pi is this https://archive.fosdem.org/2018/interviews/robert-foss/ .

    Hardware accelerated video decode will soon be available via v4l2 video codecs.

    Has anybody just tried running the unity 8 installer script https://raw.githubusercontent.com/ubports/unity8-desktop-install-tools/master/install.sh ?

  • I ran the unity install script in 18.04 armhf. Unfortunately, I had the bionic-backports repo enabled and I think something there upset it. Removing the repo and reinstalling mir got me into the desktop, but things were quite broken. Think I'll start a fresh with 16.04 arm64.

  • @adams Can you be more specific about what you mean by "broken" here? The unity8-as-a-traditional-environment setup is not working well, especially on 18.04, in general.

  • I couldn't login to the session. Black screen for a few seconds, then it would kick me back into lightdm. Tried that several times. I removed/reinstalled mir, that seemed to do something. I was able to login, although it seems to always take me two attempts, so not sure if it did anything in the end. No keyboard entry in Unity8 (can't even switch to a tty). Window controls don't work - xwayland problem maybe?

  • @adams OK. Yes, it always takes two attempts to log in to the Unity 8 session on 18.04. This is the same on x86. Xwayland doesn't work, so there are no visible problems directly related to that. Window controls have stopped working for me as well, in my testing VM. I'm not sure why that is yet. Keyboard entry works fine from an external keyboard (but there are some very odd focus issues). The OSK does not work yet though. I've fixed a couple things with it, but I've not been able to get it to appear yet.

  • Apologies for resurecting an old thread, but I was just wondering if anyone had made any headway with getting UT on a Pi?

Log in to reply