Development testers for Anbox

  • Using pawlinskis approach from

    sudo mount -o rw,remount /
    sudo rm -r /var/cache/apt
    sudo tune2fs -m 0 /dev/loop0
    sudo apt update
    sudo apt install android-tools-adb
    sudo mount -o ro,remount /

    The system image has just 2 GB and the commands above free some of that space. The 23 GB free storage you mentioned is the part of the storage reserved for user data.

  • @honigwald I have the same problem. BQ Aquaris FHD (frieza).
    Flashed the the kernel as shown at, but anbox-tool status says:

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

    Prior to installing I grew the ubuntu.img / system.img to have enough space for apt on /.
    Somehow the kernel does not get installed... Anyone has solved this?

    Maybe this is relevant: I bought the Android version of the tablet - then installed UBports UT. Maybe this changes the boot partition / image?

  • @arubislander So did I. Maybe boot is incorrect?

  • I just used ubports-installer to flash 16.04/rc onto the frieza, then resized the partition, then installed anbox using the tutorial. No success 😞
    @mariogrip How did you do it?

  • Hi,
    I've tried it on BQ m10 FHD and it does not seem to work.
    I've flashed the Kernel and installed anbox-tool but i can't install it, because it says the Kernel isn't installed.

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!
    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

    I tried reflashing it a couple of times, without success.

  • Can someone point me to the used kernel source for bacon anbox. The one in github seams not to have the "anbox" changes.

  • Maybe this is useful feedback 😉

    These are the apps that work for me with anbox on Fairphone 2

    • CatLog
    • Onleihe
    • Spotify
    • Threema (Polling instead of Push notifications)
    • WhatsApp (probably also polling)
    • my banking app

    But please take note: I haven't tested those in depth and am not using them on my daily driver, so maybe some problems went unnoticed so far.

    What didn't work

    • AdAway (needs root)
    • Bücherhallen (doesn't run without gapps; managing wish list works)
    • car2go (doesn't run without gapps)
    • DB Navigator (crashes immediately on start)
    • Drive Now (doesn't run without gapps)
    • Firefox (looks as if it works, but web pages are rendered entirely black)
    • iButtons (simply doesn't start)
    • Real Drum (simply doesn't start)
    • Stadtrad (doesn't run without gapps)
    • vlc (upper third of screen remains black, the app window seems shifted down and lower part is not visible)

  • @ingo also Telegram works

  • @ingo Thanks for your recommendation. The installation did work, but then a system update of UBports has detroyed my Fairphone. No, problem, it is a developer device. I was able to recover my Fairphone and install Anbox abein with the android tools as described on the documentation page:

    I could mange to install FDroid from a download and then Yalp Store within FDroid. Running Yalp Store seems to be to abitious. Yalp Store crashes while logging into the Play Store. So, in general Anbox is working on my Fairphone.

    Sometimes the interaction with Android apps is liettle bit tricky because of the missing back navigation button on the system level. Alien Davlik adds a navigation bar with a back button. Maybe this could be an approach for Anbox either. The disadvantage would be a smaller screen.

  • I payed around with Google apps to check the system integration. It seems, that Anbox is completely isolated.

    Does someone know, where I can find the storage for Anbox? I try to import an adressbook export in the related Android App.

  • @pawlinski try to use test image (anbox-boot-$CODENAME-test.img)

  • Hiya i just wanted to leave a link here. I accidentally started another thread. If you read into this link you'll find the instructions on how i installed Anbox on an OPO. So far successful. I just need some time to 'play' with it now to see where it is at and what can be done with it:

  • @marc_aurel Storage is in ~/anbox-data/data/media/0/

  • @bodow Thanks for the clear advice. Unfortunately I'm struggling with accessing the storage for Anbox.

    I tried to copy my address-book to the Anbox container:

    adb push contacts.vcf /home/phablet/anbox-data/data/media/0/
    adb: error: failed to copy 'contacts.vcf' to '/home/phablet/anbox-data/data/media/0/': remote Permission denied
    contacts.vcf: 0 files pushed. 142.5 MB/s (720808 bytes in 0.005s)

    I also can't access the media directory. I only can list the content of the data directory, but I can't switch to a subordinated directory.

    phablet@ubuntu-phablet:~/anbox-data/data$ sudo ls -l
    [sudo] password for phablet: 
    total 5136
    drwx------  2 root   root             4096 Dec 13 18:20 adb
    drwxrwxr-x  2 system system           4096 Dec 13 18:20 anr
    drwxrwx---  4   1023          1023    4096 Dec 13 18:20 media
    phablet@ubuntu-phablet:~/anbox-data/data$ cd media
    bash: cd: media: Permission denied
    phablet@ubuntu-phablet:~/anbox-data/data$ sudo cd media
    sudo: cd: command not found

    I have a similar problem if I use the file manage on the device. But I also tried an adb push command within the device without success.

    phablet@ubuntu-phablet:~/Downloads$ adb push contacts.vcf /data/sdcard/Download
    failed to copy 'contacts.vcf' to '/data/sdcard/Download': secure_mkdirs failed: Permission denied

    Some idea?

  • @marc_aurel just my 2 cents here. Did you try, before to navigate into the anbox folder, to type sudo su and gaining the root access?
    Second hint: you could try to move first your contacts file to an accessible folder, as for example Documents or Downloads, with adb push from your PC and then, from the terminal on your PC, you could type phablet-shell instead of adb shell, since I found out the latter has some limitations in writing on the phone partition. In the end, you could just copy your file, maybe better with root privilege, to /home/phablet/anbox-data/data/media/0/ using the cp or mv command.

  • Someone suggested the following somewhere

    mkdir -p /home/phablet/AnboxHome
    sudo chmod -R 777 /home/phablet/anbox-data/data/media/0
    sudo mount --bind /home/phablet/anbox-data/data/media/0 /home/phablet/AnboxHome

    But with the clear hint that making things 777 generally is not a good idea.
    Of course the minimal way would be just the second line. The other are just there to have an easier/shorter path.

  • @marc_aurel You're right. Sorry, I didn't have a shell open when I was writing my response and didn't remember that you had to "sudo su" or "sudo -i" first (as @matteo mentioned). I'd prefer this way as I would have a bad feeling about 777ing a directory permanently.
    Besides that: Does it work now?

  • @bodow Thanks for the advice. The following approach works:

    sudo su
    cp contacts.vcf /home/phablet/anbox-data/data/media/0/contacts.vcf

    I resume. The system integration of Anbox seems to be very limited. The apps are shown in the app scope and the apps have hardware access with network and storage. I think, that's it.

    It's possible to copy files with adb shell, but this is not for an average consumer.

    It seems there is not service or data sharing. I haven't tested notifications, yet.

  • hi, i was trying use anbox on my nexus 5 device, and got /bin/bash: pm: command not found error, do you know this?

    # install command
    ➜  Downloads adb install MobileAssistant_1.apk
    [100%] /data/local/tmp/MobileAssistant_1.apk
    /bin/bash: pm: command not found
    # adb shell infos
    root@ubuntu-phablet:~# dpkg -l | grep anbox
    ii  anbox                                                8+0~20180916133012.39~1.gbpe34b59                            armhf        Container-based approach to boot a full Android system on a regular GNU/Linux system
    ii  anbox-common                                         8+0~20180916133012.39~1.gbpe34b59                            all          Common files necessary for Anbox
    ii  anbox-ubuntu-touch                                   8+0~20180916133012.39~1.gbpe34b59                            all          Files necessary for Ubuntu touch
    root@ubuntu-phablet:~# dpkg -l | grep android-tools-adb
    ii  android-tools-adb                                    5.1.1r36+git20160323+ubports1+0~20181125103222.6~1.gbpc708bb armhf        Android Debug Bridge CLI tool
    ii  android-tools-adbd                                   5.1.1r36+git20160323+ubports1+0~20181125103222.6~1.gbpc708bb armhf        Android Debug Bridge Phone Daemon
    root@ubuntu-phablet:~# anbox-tool status
    Kernel: OK
    System: OK
    Enabled: YES
    Running: YES

  • Are you executing adb install MobileAssistant_1.apk on your PC? That would explain the pm: command not found.
    You have to transfer the apk to the phone and do adb install ... there (assuming you have installed adb on the phone first; which by the output of dpkg is the case).
    Basically this:

Log in to reply