Development testers for Anbox

  • @mariogrip Excuse me. Can you share your local anbox project to build android-armhf-64binder.img ?
    when i use to build , There are a few 、anboxd 、 netd

  • I want to test some of the applications we rely on. like : qq、weixin、etc.

  • for my building , network cat not work

  • I case anyone wants to run the Anbox AppManager by tapping on an icon, here is my .desktop file to do that:

    [Desktop Entry]
    Name=Anbox AppManager
    Exec=/usr/bin/anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity

    Save this as /home/phablet/.local/share/applications/anbox_appmgr.desktop

    The logo is this one:
    I saved it as anbox_logo.png on the phone in /home/phablet/.local/share/applications/

  • On my OnePlus One test phone, FDroid cannot find the network connection so cannot download its repositories. Has anyone with a OpO gotten it to work?

  • Have time to test anbox on Nexus5. Have lots of time after career as engineer, but am Newbie on Development testing!

  • @Frank great, with your expertise you'll get the hang of it in no time 🙂

  • @advocatux Thanks man! 🙂

  • @Frank you're welcome!

  • oh guys i face two problem

    Rotate App not in full screen please check the link below :


  • @baddea hi, just in case you don't know it, you can drag&drop an image on this forum 😉

  • @advocatux

    Also how to switch from headphone to speaker sound in ubports ?

  • @baddea you can only do it by plugging or unplugging the headphones jack afaik

  • @baddea Wow! Kodi produces a display in Anbox. Cool!

  • I think Anbox project is a great idea and I also would like to contribute, but I have only a BQ Aquaris E4.5. Will Anbox be supported also on this device in the future or will it be limited to the currently supported devices?

  • @jumpy88 IMO it doesn't make sense to try to run Android on any 1GB RAM device.

  • @advocatux I've no knowledge to answer, I don't know which are the requisites to run android services (but it would be very useful at this stage for Ubuntu Touch appealing to have access to the full play store for all the devices, while the community works to create native applications).

  • Yesterday I tried to activate the Accessibility Services of Android on OPO to get some apps to work which enable a software navigation bar for having a back button for apps with a lack of such. After having activated this service the screen went black for my apps. So now it's not possible to see my installed app UI and also the android settings UI can't be made visible to reset that behavior. Superficial search in the code of Anbox let me assume, that there is intended only one Layer for the UI. Maybe that's ok for the PC desktop solution but for the smartphone solution too?
    For now I only found a workaround for step back to a former activity of top app on the stack with 'adb shell input keyevent 4'. Are there better solutions for that?
    For another try I now installed an app with f-droid for a navigation bar and enabled it. Even if the softkeys, are not visible it seems that they work anyway. When I swipe up from the lower edge of the screen as if I would make visible the navigation bar and tap on the screen where the back button should be, the app steps back. Can someone confirm that on another phone?

    In SailfishOS the Android apps are opened with a return button underneath. Is something like this possible in Ubuntu Touch? Even the android settings app delivered with anbox need a return button for some setting menus.

  • Is there a chance one can use the LXC container technique Anbox uses to get a custom ROM like LineageOS or any other, which was build for OPO for instance to run with Ubuntu Touch? This shouldn't have the limitations of the current Anbox android.img? How tight is Anbox coupled to Ubuntu Touch on the kernel level? Or does the enhanced kernel of Ubuntu Touch for Anbox only brings the support for the SquashFS of the android image?

  • I tried some things with the powerful adb command which gives wide control over the apps installed on the anbox image. There are some commands for example which control the permissions of an app. The command 'adb install -g apkfilename' grants the requested permissions of an app at installation. With adb pm grant package_name android.permission.WRITE_EXTERNAL_STORAGE or
    android.permission.READ_EXTERNAL_STORAGE it's possible to enhance permissions of an app. But for the latter the output of 'adb logcat' tells that that permissions weren't granted at runtime because they weren't granted at the installation time. Is it possible to set that permissions on installation time? The solution to uninstall it with 'adb shell pm' and reinstall the app with adb didn't help for that.
    I even tried to install the the apk file directly with the Android package installer without further success. The command for that was 'adb shell am -a android.intent.action.INSTALL_PACKAGE -d "file://path to apk file" -n'.
    One app worked after using LuckyPatcher on it.

Log in to reply