Development testers for Anbox

  • @advocatux

    Also how to switch from headphone to speaker sound in ubports ?

  • @baddea you can only do it by plugging or unplugging the headphones jack afaik

  • @baddea Wow! Kodi produces a display in Anbox. Cool!

  • I think Anbox project is a great idea and I also would like to contribute, but I have only a BQ Aquaris E4.5. Will Anbox be supported also on this device in the future or will it be limited to the currently supported devices?

  • @jumpy88 IMO it doesn't make sense to try to run Android on any 1GB RAM device.

  • @advocatux I've no knowledge to answer, I don't know which are the requisites to run android services (but it would be very useful at this stage for Ubuntu Touch appealing to have access to the full play store for all the devices, while the community works to create native applications).

  • Yesterday I tried to activate the Accessibility Services of Android on OPO to get some apps to work which enable a software navigation bar for having a back button for apps with a lack of such. After having activated this service the screen went black for my apps. So now it's not possible to see my installed app UI and also the android settings UI can't be made visible to reset that behavior. Superficial search in the code of Anbox let me assume, that there is intended only one Layer for the UI. Maybe that's ok for the PC desktop solution but for the smartphone solution too?
    For now I only found a workaround for step back to a former activity of top app on the stack with 'adb shell input keyevent 4'. Are there better solutions for that?
    For another try I now installed an app with f-droid for a navigation bar and enabled it. Even if the softkeys, are not visible it seems that they work anyway. When I swipe up from the lower edge of the screen as if I would make visible the navigation bar and tap on the screen where the back button should be, the app steps back. Can someone confirm that on another phone?

    In SailfishOS the Android apps are opened with a return button underneath. Is something like this possible in Ubuntu Touch? Even the android settings app delivered with anbox need a return button for some setting menus.

  • Is there a chance one can use the LXC container technique Anbox uses to get a custom ROM like LineageOS or any other, which was build for OPO for instance to run with Ubuntu Touch? This shouldn't have the limitations of the current Anbox android.img? How tight is Anbox coupled to Ubuntu Touch on the kernel level? Or does the enhanced kernel of Ubuntu Touch for Anbox only brings the support for the SquashFS of the android image?

  • I tried some things with the powerful adb command which gives wide control over the apps installed on the anbox image. There are some commands for example which control the permissions of an app. The command 'adb install -g apkfilename' grants the requested permissions of an app at installation. With adb pm grant package_name android.permission.WRITE_EXTERNAL_STORAGE or
    android.permission.READ_EXTERNAL_STORAGE it's possible to enhance permissions of an app. But for the latter the output of 'adb logcat' tells that that permissions weren't granted at runtime because they weren't granted at the installation time. Is it possible to set that permissions on installation time? The solution to uninstall it with 'adb shell pm' and reinstall the app with adb didn't help for that.
    I even tried to install the the apk file directly with the Android package installer without further success. The command for that was 'adb shell am -a android.intent.action.INSTALL_PACKAGE -d "file://path to apk file" -n'.
    One app worked after using LuckyPatcher on it.

  • Hi,
    Does anyone have any problems with Anbox on his BQ M10 HD ?

    I follow instructions ( but when I'm launch "anbox-tool install", Terminal answer "Anbox kernel is not installed".

  • @pawlinski
    If you took the image from "" maybe you've installed an OS update afterwards. In my experience this resets the former installed boot image, so it has to be reinstalled.

  • will the support for the nexus 4 come?

  • @baddea No idea why it will be
    Will it be by x11?

  • @ursfan with the commands anbox-Tool disable and anbox-tool enable afterwards the offline listed device normally gets active...

  • @ursfan After having added the file NotoColorEmoji.ttf to the image under /system/fonts and rebuild the android.img with mksquashfs it works...

  • any news on the native keyboard? @mariogrip
    or any workaround to get lag-free input from the android keyboard?
    (already tried disabling autocorrect, spellchecker, etc and other keyboard apps without success)

  • Hi @mariogrip I assume that the boot images for mako & UBPorts stable devices are not available because of the lack of power but can you point to resources for building a anbox boot image for mako and other devices not mentioned here for experimenting with it?

  • hi
    on my 1+1 can t install apk, emu in adb devices is listed but show up as "offline"
    also wwe wanted to check the status of ad in android developper options, but once i clic on it, app close (fc)
    hope it can help, if you have anything /logs you want me to share, let me know, here to help

  • @indiandraogn said in Development testers for Anbox:

    Hi @mariogrip I assume that the boot images for mako & UBPorts stable devices are not available because of the lack of power but can you point to resources for building a anbox boot image for mako and other devices not mentioned here for experimenting with it?

    Yeah. I would like that too. I would like to test Anbox on my Aquaris E4.5 (Krillin).

  • Coming from here:

    Do I have to build the Anbox boot image for myself?
    Do I need to modify the anbox-tool package?

    And in general: Are there any tips on getting started with Anobx development for UT?

    Thanks, Jan-Luca

Log in to reply