Nexus 5 Flash Time

  • I am trying to install Ubuntu touch on my Nexus 5 and have gotten as far as pushing the files to the device with the device in Ubuntu Touch Recovery mode. It seems to be taking a long time to push the file "ubuntuimages/pool/ubuntu-d8d097dfc125dc91455594656762421ba6ac8fbf19524bfa07db1a879d0adee1.tar.xz" to the phone. I know that this file is significantly larger than the other ones (300MB or so) but should it really take over 16 hours? There isn't any progress indication so I thought I would ask.


  • Community

    Hi there,

    Could you possibly try using MDT to flash your phone? It's a more robust option, though it will wipe your device.

  • This post is deleted!

  • @UniSuperBox Same issue. Left it running all night. This time it only pushed 4 files. Also the ubuntuimages folder is empty.

  • After several attempts using VirtualBox on my PC I finally tried using VirtualBox on my MBP and was successful. Still don't know what the nature of the issue was with the PC. I set up several virtual Ubuntu systems and had the same issue so it wasn't just that installation. Anyway, if anyone else has this issue, move on and use a different computer.

  • Community

    Sometimes USB-cables or outlets loose the connection during the installation. It can help to just try a different cable or outlet.

  • @NeoTheThird yeah seems like VirtualBox has problems with USB connections even though I did add the filters. I tried another install using VB on my MBP and it kept dropping while sending the user userdata. I had to manually re-install Android on the device from OSX.

  • @NeoTheThird

    dont know if that is the right thread...but i was flashing a my new nexus 5 with the magic-device-tool to Ubuntu.
    Boot loader enabled .. all was going fine. But by reboot the nexus 5 starts in Android-Mode again.
    I was starting the same way with exactly the same points the magic-device-tool.. same result = its says " success"
    After this second try/attempt...Hurray! Ubports says "hello" by boot of nexus 5.
    Is there a reason why i have to fire-up the whole "Magic-device-tool" two-times ?
    Its not really a bug (in the end its runs very well)

    PS: i was very positive surprised about the nice and complex possibilities/options inside the magic-device-tool.

  • Community

    @mike Computers are weird, aren't they? Just be happy it works now. Maybe the phone lost the connection to the pc on the first flash, maybe the cable was wonky, who knows. If you want to know more, you would have to look at the log file.

    Have fun with your N5 with ubports anyways ;)

  • @NeoTheThird
    ok now i am searching the log file.... :)

Log in to reply

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.