Port to Oneplus 2



  • @SGCMarkus Those builds are not stable. I'd recommend using the 15.04 rootfs.



  • @UniSuperBox

    found https://hastebin.com/wegibubuqu.go this today in the lxc config of the 15.04 rootfs, if i understand that correctly, it tries to load the LXC container, which is ARM64 for the Oneplus 2, as a armhf, which ofcourse doesnt work... maybe thats the problem? (or one of those)



  • @SGCMarkus It's possible that it's the problem, but I'm not really sure how you'd fix it. ADB not starting would indicate a much different problem, in any case.



  • im back from the "dead" 🙂
    didnt have that much free time, but now i can work on it again lol
    have set up a "new" machine, this time ubuntu native installed on my PC, instead of running in a VM (instead of ~45min build time its only 16 min now 😄 )

    Also noticed a few updates in the wiki, for example how to build for bullhead, and it says to use the Yakkety image, instead of the Vivid one. Does anyone have that backed up somewhere, everything i find about the Yakkety image is down, either sents me to Zesty (and idk how stable that one is). Or should i (try to use) Xenial?

    Or maybe theres "in general" any news on this whole topic that i migth have missed?



  • Hi why not use hybris for the port? you can fork my sources for adapted kernel

    https://wiki.ubports.com/wiki/Building-libhybris

    You can find my sources here:
    https://github.com/nyl



  • @SGCMarkus Welcome back!

    You've missed a lot since you were last here. And by a lot, I mean a lot. Canonical dropped Ubuntu Touch about two months ago and we have taken over the OS. If you'd like a quick summary of what's happened since then, you might want to check out the blog starting on April 8th.



  • damn, its been a looong time since i was last here, had more to do than i thought i had.

    But.. Im back at working on this 🙂
    I switched to the Halium 7.1 base atm, as I saw someone got it running for the Nexus 7.
    I can say, it fully compiles without errors. The recovery hybris-boot image (bootmode=debug) works too, i have access via telnet, but otherwise... it just reboot after i think it tries to load something... cant say that, dont have a last_kmsg... for some reason thats nowhere found, on any ROM I've tried so far.

    @nyl sorry for the late reply about this (also saw your SailfishOS project on xda a while ago).
    I tried to follow those instructions for the libhybris. Appearantly the autogen script works without problems, but afterwards the instructions say i should run make in that folder, but make says theres nothing for it to do.



  • I managed to create a Ubuntu Zesty rootfs (actually supported arm64 instead of xenial), and now im having a really really weird behavior

    if i flash the hybris-boot.img i get this in the console

    markus@markus-pc:~$ lsusb -vd 0fce: | grep -i serial
    iSerial 3 1ee3fc01

    but, also sometimes a "charging ??/100" flashes up on the screen (rest is always black), and sometimes the LED starts to light green.
    The USB Tethering seems to not fire up completly though, atleast i dont get any connection via anything to it.
    The debug mode works still though.



  • could be permissions related issue on the compiled files



  • WOW! I'm really glad there are some people not only continuing the amazing Ubuntu touch OS but are also developing it for the OnePlus 2!!! Keep up with the good work! As soon as it works I want to be the first to try!!!


Log in to reply