Need Help to fix GPU adreno 305



  • @Flohack Hi thank you very much sir
    When i aded symlink to vendor/lib/egl folder in root i got this when run test_hwcomposer

    [email protected]:/# test_hwcomposer
    width: 720 height: 1280
    library "/vendor/lib/egl/libGLESv2S3D_adreno.so" not found
    OpenGL ES 2.0 (OpenGL ES 3.0 [email protected] [email protected] (CL@))
    test_hwcomposer: hwcomposer_window.cpp:186: virtual int HWComposerNativeWindow::dequeueBuffer(BaseNativeWindowBuffer, int): Assertion `fbnb!=__null' failed.***
    Aborted (core dumped)

    [email protected]:/# test_egl
    Segmentation fault (core dumped)
    [email protected]:/# test_glesv2
    Segmentation fault (core dumped)


  • Infrastructure

    @walidham Yes you are missing more than just one file. You need to also find libGLESv2S3D_adreno.so somewhere. The /vendor/lib prefix is strange.



  • @Flohack YESSSSS i do it, now Ubuntu Touch start
    I will fix RIL for the first urgent feature and after camera.
    Do i need patch kernel for apparmor ?


  • Infrastructure

    @walidham Please send SCREENSHOT! :)

    apparmor you will need for click apps yes, but there is a description somewhere about how to disable apparmor for testing. You find it in Google, just look for Ubuntu Touch apparmor howto or such a thing.



  • @Flohack this is first image Ubuntu Touch in Moto G 2014

    ![0_1494788418495_UBT-Moto-G-2014.png](Uploading 100%)
    I will change kernel with kernel used in SailfishOS (its work fine in moto g 2014 sailfishos) , hope this will resolve many pbs


  • Infrastructure

    @walidham Beautiful! You are really skilled then, not many people can port in the first go so that they get a usable screen.

    You can follow these items roughly to see if you got all things covered:

    AppArmor
    Bluetooth
    Boot
    Camera
    Cellular Radio
    GPS
    Graphics
    Resume
    Rotation
    Sound
    Touch

    BR Florian ;)



  • @Flohack said in Need Help to fix GPU adreno 305:

    @walidham Beautiful! You are really skilled then, not many people can port in the first go so that they get a usable screen.

    You can follow these items roughly to see if you got all things covered:

    AppArmor
    Bluetooth
    Boot
    Camera
    Cellular Radio
    GPS
    Graphics
    Resume
    Rotation
    Sound
    Touch

    BR Florian ;)

    Why is touch at the bottom? I'd consider that somewhat more important.



  • @Leppa
    I think from a quick look that it is just posted in alphabetical order ;-P


  • Infrastructure

    @Leppa Please, this is NOT ordered by importance :)



  • @Flohack Hi can you help me to understant this error :

    E/adsprpc ( 0): vendor/qcom/proprietary/adsprpc/src/apps_std_imp.c:33:apps_std fopen failed: ./oemconfig.so No such file or directory
    E/adsprpc ( 0): vendor/qcom/proprietary/adsprpc/src/apps_std_imp.c:33:apps_std fopen failed: /system/lib/rfsa/adsp/./oemconfig.so No such file or directory

    btw camera(photo) , power buton, rotaion work.
    what no work : ril, audio, wifi,....

    full logs logcat


  • Infrastructure

    @walidham Hello, sorry no...

    You might want to take a look at CM/Lineage sources if they somewhere include a file called oemconfig.so - which source does your vendor tree come from? TheMuppets?

    BR



  • @Flohack Hi, wifi fixed, amazon & ebay application work, but browser, facebook and twiter crash .

    For vendor, yes i used TheMuppets, cm-12.1 device tree and cm12.1 kernel with small modification in 4 files (fix boot.img size, compilation errors...)
    I think RIL not work due to this error of file oemconfig.so.
    I think need more debug for it


  • Infrastructure

    @walidham Crashing Apps can be an indication that your apparmor does not work... Did you apply those patches already?

    BR



  • @Flohack in wiki ubuntu guide its not clear how to patch apparmor, i will try to do it.
    The audio is not working, is it related to apparmor ?
    Also i found that RIL is related to audio, i think fix audio will fix RIL, right ?


  • Infrastructure

    @walidham I was never so far that I could see if audio or RIL works. But maybe yes.

    Which kernel version do you have? I just replaced the apparmor folder completly with the backport version. Dunno if this will be enough but it looked so far ok ;)

    BR



  • @Flohack i used motorola kernel msm8226 v 3.42.
    Can u give me the link the backport version.
    Also many thanks for reply
    Best Regards


  • Infrastructure

    @walidham See https://developer.ubuntu.com/en/phone/devices/porting-new-device/ => Scroll down to "Device-specific changes" => Scroll further down to "AppArmor" and you see a list of links for that. Found it? =)

    linux-maguro (3.0.0)
    linux-grouper (3.1.10)
    linux-mako (3.4.0)
    linux-manta (3.4.0)
    

    BR



  • @Flohack yes thanks



  • @Flohack OMG, its work now, many thanks, apparmor work, i tested by open browser.
    Also its more fast now

    My big problem now is pulseaudio and ril.


  • Infrastructure

    @walidham Wow good job man! The critical point is if we ever find a kernel that is not already ported. AppArmor backporting is real pain. Keep on going, send screenshots etc ;)

    BR


Log in to reply
 

Looks like your connection to UBports was lost, please wait while we try to reconnect.