Oneplus 3/3T

  • Hi!
    I suspect that there are many owners of OP3 here.
    I have a few questions about installing Ubuntu Touch regarding the ability to return to the stock state:

    1. When installing Ubuntu on OP3, I have to install TWRP, so where can I download the stock recovery for Oxygen OS 9.0.6 (preferably from some reliable sources)
    2. Could you tell me how to deal with encryption, I mean when installing stock firmware. I've heard that there are problems with it.
      Thanks in advance for any help.

  • @Kyrylo Hi the stock rom you can download here

  • @Xray2000 Hi! Stock Rom is already downloaded, but where I can get stock RECOVERY img to replace TWRP img? I found some on the web but I'm not sure for which version of stock rom.
    So... Any help?

  • @Xray2000 Thank You very much. Could you tell me how i can know for which version of stock image this recovery is, or whether it does metter? And maybe someone has exprience in returning to stock condition and can give me some advices and valid links.
    I found a lot of outdated tutorials and broken links so l prefer to ask You help to be sure I'll be able to do everything right.
    I will appreciate a lot.

  • @Xray2000 By the way, I've downloaded recovery from other source than your link earlier. That was recovery for Oxygen OS 4. But sha256sums of both images are the same.
    So I don't know if I can trust this recovery and where I can get recovery for OxygenOS 9.0.6 available now.
    Any suggestions?

  • @Kyrylo
    You should try XDA dev forums, there are some high knowledge for each androïd devices, including stock softwares.

  • @Kyrylo I think you should read carefully the oneplus forum for the correct version to download, i dont have play with recovery mostly when i one go back to stock condition i just flash the rom from the oneplus website....

  • @Keneda Yes, You are right. XDA is the place to ask this kind of questions, but most of their topics is outdated 2016-17.
    I hoped to find living help hoped to find living help from living people herep from living people here.
    Nevertheless thanks a lot.

  • @Kyrylo
    Here you will find outstanding living help for UBports ^^
    Outdated topics doesn't mean people who did them are dead.
    And like said @Kyrylo there is also Oneplus forums.

    Here just a few people come back to androïd so very few know or did it.

  • Hi, I solved the "caller is to quite" issue on my 3t. I had simply to much dirt in the small net in front of the speaker.
    Sadly it's not easy to clean. Either open the phone to clean it or take a neel and push a small hole through the left side of the net (quick but rough).

  • Is volte calls working because my network requires volte to make calls

  • Hello!
    Trying to install!
    Wiped all paritions. Everyone is ext4.
    Start ubport-installer
    Got error
    error: Error: systemimage: Error: Error: {"error":{"killed":false,"code":1,"signal":null,"cmd":"/opt/ubports-installer/resources/app.asar.unpacked/platform-tools/linux/adb -P 5037 shell mount -a"},"stdout":"","stderr":"mount: mounting /dev/block/bootdevice/by-name/userdata on /data failed: Invalid argument"}

    Any suggestions?

  • Still trying to do smth with it.
    So may I know where is the destination of files downloaded by ubports-installer (on Ubuntu 20.04)?
    Thanks in advance for respond.

  • Hi there!
    Still trying...
    When I tried to install with bootstrap checked I've got error like this.
    stack trace: Error: Error: {"error":{"killed":false,"code":1,"signal":null,"cmd":"/opt/ubports-installer/resources/app.asar.unpacked/platform-tools/linux/adb -P 5037 shell mount -a"},"stdout":"","stderr":"mount: mounting /dev/block/bootdevice/by-name/userdata on /data failed: Invalid argument"}

    when with bootstrap unchecked - cycled probleb with cable - "connection to device lost"

    when I just

    1. flash recovery using fastboot
    2. reboot to recovery
    3. adb push all that files to /cache/recovery
      )and adb reboot recovery
      nothing happens
      in recovery log file error cannot mount /cache/recovery/ubuntu_commandoneplus39554

    Can anyone help me with problem?

  • @Kyrylo looks like that not all partitons are ext4. May be a clean start with the device can help you. It gives you best chance to do it.

    • start with twrp (fastboot boot twrp)
    • set twrp to adb sideload mode
    • adb sideload the latest oxygenos 9.0.6 from oneplus support page
    • start the phone and make initial setup of the os
    • after that 'fastboot boot twrp' again
    • 1st. wipe all partitions
    • 2nd select wipe advanced 'change filesystem' of cache, system and data and set it to ext4
    • 3rd wipe format data
    • check with twrp terminal command 'mount' that all partitions are ext4. If not change filesystem again.
    • connect device to usb (still in twrp) and start ubport-installer

    But this is not an op3 specific question!

  • @gischpelino Thank You for your respond.
    Already did that all a couple of times.
    Wiped all partitions, formatted to ext4, checked if formatted in ext4,
    (If I am not mistaken no need to install Oxygen OS to wipe all partitions in TWRP once more)
    1.Tried to install with BOOTSTRAP ckeckbox enabled and disabled.
    Without results.
    2.Pushed all that files to /cache/recovery/ (I am not sure if it is right place).
    Rebooted to recovery and ... nothing happens.
    Any help will be appreciated.

  • @Kyrylo may be a firmware problem, thats what the step with oxygenos 9.0.6 is for. As far as I can read you did not do all steps.

  • Do you mean twrp problem?
    Or you mean that I should install OOS9.0.6 then to flash again in twrp?

  • Can anyone please make a video about current progress of this device as i want to buy a new oneplus 3t i just wanna know its worth it or not?

Log in to reply