Reverting to Android does not work



  • hi there,

    I wanted to switch back (temporaly) to Android - I did everything like decribed in the "how to´s", but Nexus 7 (flo) gets caught in a reboot loop...

    Installing went fine, but installer complains about missing some images (vendor.img and a few more)

    I DL the original image from google page, so I assume it will be ok. tried different ones as well (4.x to 6.x) but the do not run at all.

    Maybe ubuntu touch installer tool does some stuff (partitioning?!) to the Nexus, so that you can not refit android anymore?

    Do you guys experienced the same, when trying to re-install android after you went ubports?

    Cheers



  • The installer does not change partitioning on devices.

    If you download the last OEM image for your device and run the flash_all.sh script for it, while device is in fastboot mode, it should work. This will delete all UT data though.



  • @dobey yeah this was the plan... but thing is, even when using original ROM image and latest android tools, device turn into booting loop, after install is finished

    after 4 times rebooting into Google screen, I reinstalled UT again



  • Maybe I should try flashing an "Full OTA" package to my Nexus, instead of a factory image?

    Like I said, I tried from lowest and highest number of Android version, which is 4.3 (lowest)
    and 6.0.1 for latest ROM - both produced a "boot-loop" on my device, after flash-script
    finished.

    I think I had to switch to "Recovery mode", instead of "Start" for installing an OTA?

    Can somebody help me out a bit, please?



  • Same device as OP. Followed exactly the same steps as OP (just by chance. Had not read this thread until today). Same experience exactly in trying to re-flash Android.

    Re-installed UT. The re-install of UT worked perfectly.

    I can live without Android on this device, but I use it as a test device, and would like to be able to get back to Android if possible.



  • @SnowyMtnWeb Hi, I was able to re-install Android OS (more specific: LinageOS with nano Gapps)

    The thing was (I assume) the difference in "bootloader".
    I had to flash TWRP onto my Nexus first, so that ubuntu "recovery" gets overwritten (sorry, don´t know how to explain)

    After that, I was able to install Android ROMs again. Before, I did not flash TWRP recovery on my nexus and I think this caused my attempts of re-fitting Stock ROM to fail! (not 100% sure, but possible)



  • @Elowan A while ago when I removed Ubuntu Touch and installed LineageOS in its place, I found that the Ubuntu Touch bootloader still remained, even though I had installed TWRP Recovery.
    I currently have Ubuntu Touch on my phone. But, if I were to choose to replace it with LineageOS, I wonder if there's a way to completely replace Ubuntu Touch with LineageOS, which means also replacing the bootloader. I have a Nexus 5.



  • @MarkG_108
    I have had this ,it usually changes after a couple of reboots
    Pro 5 and m10 fhd



  • I have recently tried flashing LineageOS on a Nexus 5.

    As @MarkG_108 said I still happen to have the UT bootloader I think (as a picture comes up on booting that Nexus 5 is powered by Ubports or something like that).

    I ran in to multiple issues reinstalling stock Android (to test that first) but finally it worked fine, I downloaded the .img files from here and flashed each .img file individually with fastboot (like "fastboot flash bootloader bootloader.img" or "fastboot flash system system.img" etc. I think from the folder that contained the images). I think I got the idea from this guide. This booted to normal Android I think with no issues (?). I had some issues connecting to fastboot and adb and I don't remember what I did to fix it but I just kept looking up what to do (like searching "how to fix fastboot devices not showing anything").

    So, I don't know how different Nexus 7 is from Nexus 5, and am not sure if you tried to flash all the .img files (or if that is needed) since @Elowan said "installer complains about missing some images".

    I'm thinking you should be able to do something to get things working though so I hope you can keep trying and talking with us and something works out!


Log in to reply