Call for testing: Google/Huawei Nexus 6P (angler) owners



  • @Rondarius @rocket2nfinity can you please do a dmesg | grep tooth after a reboot (to captrue all relevant lines from kernel log) ?



  • @Flohack phablet@ubuntu-phablet:~$ dmesg | grep tooth
    [ 0.619319] Bluetooth: Core ver 2.20
    [ 0.619343] Bluetooth: HCI device and connection manager initialized
    [ 0.619355] Bluetooth: HCI socket layer initialized
    [ 0.619364] Bluetooth: L2CAP socket layer initialized
    [ 0.619383] Bluetooth: SCO socket layer initialized
    [ 4.723382] Bluetooth: RFCOMM TTY layer initialized
    [ 4.723401] Bluetooth: RFCOMM socket layer initialized
    [ 4.723414] Bluetooth: RFCOMM ver 1.11
    [ 4.723425] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 4.723432] Bluetooth: BNEP filters: protocol multicast
    [ 4.723441] Bluetooth: BNEP socket layer initialized
    [ 4.723448] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [ 4.723458] Bluetooth: HIDP socket layer initialized
    [ 4.723465] Bluetooth: HCI UART driver ver 2.3
    [ 4.723472] Bluetooth: HCI UART protocol H4 registered
    [ 4.723478] Bluetooth: HCI UART protocol BCM registered
    [ 4.830132] Bluetooth: bluesleep_init: BlueSleep Mode Driver Ver 1.2
    [ 4.830449] Bluetooth: bt_host_wake 9, bt_ext_wake 8
    [ 4.830481] Bluetooth: host_wake_irq 606, polarity 0



  • @Flohack I have exactly the same output as @rocket2nfinity.



  • can i use this in my 4cores angler ?
    because i can't find 4 cores boot / system images in the link provided



  • @HMZ47 Sorry, I removed 4 cores some days ago since I got a feeling that nobody here has the issue. If you are experiencing bootloops with the 8-core version I can build a 4-core again. Not that the change is only in halium-boot.img which contains a locked-down kernel. All other files are the same.



  • @Flohack

    Thanks u sir.
    my angler suffers from BLOD, so it won't work for me, i already flashed regular twrp and it did not boot .

    apparently i'm the only user here with 4 cores LoL.

    appreciate your work, Thanks



  • @HMZ47 said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    ly i'm the only user here with 4 cores LoL.

    Ok there is a 4-core TWRP, you need this first, to confirm its this bug. Can you get hand on it?



  • Guys re WiFi: This is the error I get frequently. The WiFi driver shuts down, and I have to disable/enable WiFi again to get it working:
    a7ac4b7c-068a-4718-8189-49a51c61a513-grafik.png
    If you ever encounter this please tell me, thanks!



  • @Flohack yes i flashed it, and it worked for me.

    update: I used boot image in the angler zip file (halium_angler.tar.xz) and it worked also.
    runing lscpu shows that only 4 cores are runing, so i think it worked.



  • @Flohack The only time i've had to turn WiFi off and back on again to get WiFi back is after my network went down and it didn't automatically re-negotiate the connection after network came back up. I'll look at the dmesg you used next time it happens.



  • @Flohack do you have problems with the sound on incomming calls? It drops the sound and suddenly it comes back again. It almost feels like screen rotation interfers with the sound.



  • It is the screen lock that makes the sound drop on incomming calls. Press the power button during an incomming call and it mutes the sound, not to zero you are able to here the ring tone.



  • @Rondarius Hmm maybe thats intentional? I never press power during an incoming call, because I want to answer it ๐Ÿ˜‰
    But I will try it. Its nothing that should be connected with the port, this must be a general Ubuntu Touch feature ๐Ÿ™‚



  • @Flohack โ˜บ, I've had the sound dropouts when the phone have been in my pocket. I'm not able to reproduce the issue. Maybe you fixed it with the latest image. I had this issue during the week, at work.



  • @Flohack the problem with the sound persist. It effects clockalarm, incomming call and reminder alarm from the note app. It accuars when the phone has been hibernating for a while. Should someone call me now or an alarm would start when I am using the phone, the sound would work without any problems. Should I reflash the system.img?



  • @Rondarius No, that wonยดt help. Lemme try this out, I will leave the phone sleeping and then let someone call me resp put a few alarms inside.

    Note I am on holiday now for 2 weeks, so I will not actively work on anything xD



  • This post is deleted!


  • So back from holiday ๐Ÿ™‚

    One thing I noticed is that when using the phone actively it kinda sucks out hte battery quickly - probably due to all 8 cores getting enabled. I would expect that Android does not fire up all cores everytime the phone is unlocked. Does anyone of you have experience with the power management under Android on this device?



  • @Flohack hope you enjoy your holiday.
    i guess for android only ARM Cortex A53 cores workes when you use non-performance apps.

    for me i use only 4 cores due to BLOD i can confirm that the experience in term of battery is almost the same as android. so i think you are right, 8 cores working at the same time consumes the battery .



  • @Flohack That is the way it worked on android with the N6P. Four cores on all the time, + four additional cores when needed. I thought it would work the same way naturally with UT on top the android stack, but I guess not. I haven't taken mine out anywhere because of covid, so I haven't used it enough to notice.


Log in to reply