Call for testing: Google/Huawei Nexus 6P (angler) owners



  • @Flohack I'm a hardware guy. I'd be happy to help you troubleshoot your 6P if it wasn't something catastrophic



  • @rocket2nfinity Well I changed battery, and that went fine, though one of the connectors became loose, so I planned another investigation for the next day.

    On the next day, while being able to remove the parts which need to be warmed up with a hairdryer worked well, I could not get the cover off, and I used too much force and accidentially came between the screen and the PCB, instead between PCB and case. So the screen broke, and I have a full length of damaged area plus a crack in the screen.

    I´m an idiot, I did not take out my contact lenses this eve, and so I couldnßt really see what I was doing 😉

    I wanted to get this as a daily driver, when I see that the porting status is well enough, but with that screen I cannot use it anymore. Instead I will look for a used one in medium condition, max € 100,-

    It would be possible to change a screen (but then this unit also has the CPU bug and cannot run on all 8 cores, so I would not invest in it further) but I dont feel like doing this, or paying for that.



  • @Flohack Not an idiot. These things are getting harder to service everyday. I especially hate the ones with locking latches. They are designed to break, thus rendering the device unserviceable (unless you get crazy with the glue).

    I agree, not really worth it for a device with the cores disabled. However, ebay has plenty in your price range, and if you go on xda-developers and tell the community what you're doing with Ubuntu touch, I'm betting you'll get donations. I'd donate here if there was a button to, and I certainly will there if you do.

    There are a lot of us with Nexus 6Ps who would love to get Ubuntu Touch, or any of the other halium based ports on it.



  • @rocket2nfinity said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    Nexus 6Ps who would love to get Ubuntu Touch, or any of the other halium based ports on it.

    Great motivation, thanks. I am already chasing 2 devices. So sad that it might not be here for FOSDEM. I wanted to show it off on the conference 🙂 but lets see

    I am not really active on XDA, do you think it makes sense for UT people to hook up there with the "real" Android community?

    BR Florian



  • @Flohack very sad, but still exciting.

    I do think it's worth putting up UT ports up at xda-developers - for the devices that are known mostly working, on their specific device page. It might encourage the curious among the greater Android developer community to give UT a try. I myself have tried several OSes I wouldn't have (or even known about) if it hadn't been posted on XDA.

    But if you don't, then add a donate button on ubports so we can encourage developers who are having successes with some monetary incentive. I have a few devices lying around that I would gladly put a port bounty on. For those of us who know enough to follow along and install a successful build but nothing more, this is how we can contribute to the project.



  • @phillip-walters Can you boot into recovery right after it locks up with PWR + VolUp, and then get the contents of /sys/fs/pstore/console_ramoops? We might try this



  • Good News! Tomorrow I should get a new device 😛



  • The new device has arrived. Unfortunately I somehow lost a few updates, so now I am back to a state where modem and network does not work...



  • @Flohack Sorry for taking so long to reply. I will give that a try.



  • I just found out that I linked the wrong halium-install release, in case you dont want to clone. Please use only this: https://github.com/JBBgameich/halium-install/releases



  • I don't know how to colaborate with your color coded word document, but I have successfully booted Ubuntu Touch on my Nexus 6P!

    It took me many many hours of trying combinations to find out the only 7.12 Google images I could boot was the OTA. Factory would not install, lineage 14.1 builds would install but not boot. As soon as I loaded the last 7.1 OTA, and ran the halium script, it came right up. Someone more knowledgeable than I will have to figure out why the others did not work.

    Quick rundown of what works:
    -gui
    -WiFi and cell 4G LTE
    -audio
    -video

    What does not work:
    -camera (it crashes the OS hard requiring power + volume to reboot)

    Don't know if it works:
    -dialer and sms (I have a data only sim in it. will test again after I swap it out)

    This is awesome!



  • Bluetooth is not working 😞

    And random UI freezing requiring reboot. So do I start filing bug reports or do I collaborate with your alpha testers document since you said this isn't linked to a standard build yet?

    I really like how it performs though - fast and smooth....



  • @rocket2nfinity Oh cool thanks for your test so far.
    No please do not file bugs on the official tracker, as this is not an official port right now. You can do it here for example for the time being.

    I am having issues with my new device now, and it seems it could be also a problem of the vendor partition. Could you please therefore give me the exact download link for the factory image you have used? My readio does not start, so I do not get any broadband...
    Camera is clear, that I did not look into, so no bug filing needed until now.
    I am a bit worried about lockups, I dont see them here so far, the only thing that I can see is that WiFi does loose DNS resolver or network connection from time to time.



  • https://dl.google.com/dl/android/aosp/angler-ota-n2g48c-b004b71e.zip

    From this page:
    https://developers.google.com/android/ota#angler

    I read that the other factory images could only be installed with fastboot, but when I tried, it threw lots of errors - missing files. But it's the factory image from Google so I don't understand why things are missing.

    The 7.1.2 OTA installs with TWRP just fine



  • Just to clarify, I first thought maybe there was a problem with TWRP being too new. I've had problems like that before. So I tried 3.2 and 3.1 from that time frame. Made no difference. I can install Lineage 15 just fine. But 14 errors like it's missing something even though I get no errors installing with TWRP. I can see system files in TWRP on the device, but it hangs at the Google logo when you try to boot. The factory images as I said throw errors - missing files. Yes, I did check MD5SUM. They matched each time.

    I did successfully flash the matching boot loader and radio from the file. The OTA reflashed them from its own copy

    And I did manually wipe everything and format data first. I enabled USB debugging each time by flashing back to lineage 15 then wiping everything and installing 14 or factory images after with TWRP or fastboot



  • I also noticed something - factory images and OTA images are different for 7.1.2 and earlier. Android 8 and later it's the same file on both pages. So something is being done differently pre Android 8. That might help you figure out where the hang up is.



  • Just remembered - Just before device crashes, after clicking camera, it shows a message saying you don't have permission to access camera. Bluetooth also shows on, just doesn't show any devices to connect to



  • @rocket2nfinity Yes both Bluetooth and camera a known not to work. I got BLuetooth to work already on my now broken device. But, first I must get radio working again.

    Regarding the hangup, is it just an intermittent stop of response, and the phone would continue working, did you wait a few seconds? Because that is already fixed in my current setup.



  • @Flohack Mostly. If I wait, it often recovers. But sometimes it does not. May be related to camera and Bluetooth somehow. It locked up hard after trying to use both of those, and once or twice it locked up after the screen went dark and I couldn't get it back until I rebooted.

    I'm actually surprised so much works out of the box.



  • @Flohack I also used your latest build from the post above


Log in to reply