NordVPN on Ubuntu Touch



  • Here are the screenshots:
    General settings.png
    Note that on this second one the file in the ~/.cert/nm-openvpn directory was initially of .pem type rather than .crt type. I renamed the end of the file to .crt to see if that would help, but alas, still nothing.
    screenshot20200725_003749786.png
    screenshot20200725_003753306.png screenshot20200725_003801018.png screenshot20200725_003808815.png screenshot20200725_003902292.png screenshot20200725_003914693.png

    If it would help, I could also include screenshots of the OpenVPN settings on Ubuntu 18.04 for a 1:1 comparison. If anyone would like to see them, please ask.



  • perhaps you can test the ovpn out via the command line, i forgot the syntax but it should be fairly simple to use. if that works we can figure out what setting is missing in the configs



  • Thanks, I will try tinkering with that as soon as I have a moment. Meanwhile, I would still appreciate it if anyone can spot anything glaringly wrong with the setup I've tried to go with.



  • @TartanSpartan I would help you anyway.

    But as you know I'm not a native speaker of English so I'm sorry for my bad or wrong expressions.

    I have many things I want let you know but it's hard for me to write. So I will upload the pictures of my settings. Wait a minute, please.



  • @Code_Gaug Your English seems fine to me on first glance my friend 🙂

    Thank you for your pictures when they are uploaded. Your help is appreciated.



  • @TartanSpartan Here's my settings

    vpn_settings.png

    Certification files are just text files.
    I used files which created by Network Manager Gnome and files which I myself copied and pasted from OVPN file and both worked fine.

    If you give settings to VPN like above and it does't work ask me again.
    I hope it works fine.



  • This post is deleted!


  • @TartanSpartan Oh no, now I found Premiumize VPN's OVPN file includes CA certification but no tls-auth certification. I missed that.
    So maybe you made settings by following this tutorial.

    https://www.premiumize.me/plugins?os=ubuntu&tool=openvpn

    Making VPN settings with Network Manager Gnome on Ubuntu Desktop, setting file is created in '/etc/NetworkManager/system-connections' directory as well as with VPN Tool on UT.

    If connection succeed on Ubuntu Desktop and fail on UT you'd better compare both files. Something might be different from each other.

    Would you show me what is different between two setting files?



  • @TartanSpartan Hello

    I'm sorry.
    Your VPN provider doesn't use tsl-auth certification.
    So my settings wouldn't be help for you.

    If connection results in failure on UT I still recommend you to compare setting files but you can test the ovpn out via the command line as Fuseteam said. Because it shows the reason of failure immediately.

    sudo openvpn [ovpnfile name]
    

    Password for sudo command is required first then usename & password for VPN are required.
    (Note that password phrase may not be shown even if you input)

    If it works massages end with like following.

    Sun Jul 26 09:05:55 2020 Initialization Sequence Completed
    

    Thank you.



  • Sorry I went quiet for a while. Thank you for your advice. I've seen a couple of drawbacks with Premiumize in the VPN and otherwise, such as lack of tsl-auth certification as you say, so I might consider moving to Nord when my subscription runs out. But for now I will continue to use Premiumize. Thankfully I was finally able to achieve a VPN connection on my Pro 5 by using nmcli to take the .ovpn file as input along with my username and password, and this also added the connection to the GUI elements so I can turn it on and off with the button. Just what I wanted. I had to do an apt install of the network-manager-openvpn-gnome package for this to work; as VPN editor cannot take .ovpn files at this time, I am looking into raising an issue with Ubports to see if it would be worth including this package in the system image by default. In case this this approach is of interest to anyone else struggling to add a VPN to Ubuntu Touch, the full command used was sudo nmcli connection import type openvpn file "yourfilename.ovpn". I think I had to run it twice for online IP checkers to actually confirm the phone as (supposedly) being in Montreal as was to be expected.

    However, unfortunately now I have another problem. For personal reasons I have decided to keep my M10 on Vivid OTA-3 until such time as I feel the Xenial build is mature enough to upgrade to. But this does mean it may be vulnerable to bugs which Xenial doesn't have. I wonder if I have discovered one in attempting to apply the VPN to the M10 in the same fashion as for my Pro 5. Here, after running the aforementioned command, it responds Error: failed to load VPN plugin: missing "plugin" setting. Is anyone familiar with this error? I have searched for it online but can't find the string really anywhere except in the Network Manager source code itself, and there, the code doesn't really help explain what the problem may be at least not to my eyes. It does seem that whether this is a bug or something that can be fixed by installing a package or similar, this situation changed from Vivid 15.04 to Xenial 16.04. Can anyone shed some light? Perhaps it might help if you happen to have your own UT device still on 15.04, or a livecd image of 15.04 to test this on x86 architecture. I had considered just copying the VPN connection file from /etc/NetworkManager/system-connections from the Pro 5 to the M10, but I thought this wouldn't really make sense because for example if they shared the same uuid (which I presume is generated during VPN configuration) as a consequence, then they can't both be on the same WIFI connection simultaneously.



  • @TartanSpartan Congratulations!

    Anyway I'm very happy to know you can achieve a VPN connection. 👍



  • @TartanSpartan Last night I was too sleepy to read English writtings. Now I 'm fully awake. 😁

    I didn't know .ovpn file can be specified as mncli command's argument or doing so mncli can create VPN setting file which is available for network-manager-openvpn-gnome or VPN tool.
    I always use 'ip' command for network settings or getting information of network but now I know 'nmcli' is very useful, too.

    Thank you for letting me know it. I'll learn much more about NetworkManager. 😉



  • 36 posts on how to set up a "simple" vpn connection. Something is so wrong here 🙂 Reminds me of when I looked for Spotify solutions for the first time, before Futify was a reality. Do this, do that, make this, make that and nothing works hahaha!


Log in to reply