Call for testing: Updated Pulseaudio & better Bluetooth headset support



  • @peat_psuwit said in Call for testing: Updated Pulseaudio & better Bluetooth headset support:

    @aribk The issue that the playing streams won't switch to the headset after a re-connect is issue #1045. However, the rest of the issues is not known to me. If you care enough, could you please check if it's a regression or not. If it is, or it's inconvenient to test with the previous version, please follow the instructions for collecting the log.

    Thank you!

    I read this only now, sorry! I will see if I can get round to it within the next couple of days.



  • @peat_psuwit said in Call for testing: Updated Pulseaudio & better Bluetooth headset support:

    @aribk The issue that the playing streams won't switch to the headset after a re-connect is issue #1045. However, the rest of the issues is not known to me. If you care enough, could you please check if it's a regression or not. If it is, or it's inconvenient to test with the previous version, please follow the instructions for collecting the log.

    OK. Today I resumed testing on my N5. I reinstalled devel with the UBports installer and repeated your steps above.

    I tried out a wired headset and this works well.

    Then I followed some of canonical's steps that you linked to. I have the output of all the 'pactl list sink' tests if you're interested. They all give the expected media.role output, except when playing a ringtone. In this case I got 'media.role = "multimedia" ' But I played the ringtone from settings > sound > ringtones . Just thought it might be worth mentioning in case this gives a different result from an actual call.

    I hope to secure a bluetooth headset during the course of the day to be able to test this. Will follow up and send you the logs if I run into trouble.



  • Unfortunately, the bluetooth headset I secured was not registered by my N5. So I tested once more with my JBL bluetooth speakers. I got a connection between the device and the speakers, but the sound was not routed to the BT speakers. Instead, sound came from the device itself. After rebooting the device connected automatically to the BT speakers and I was able to play music on them. But when I disconnected the speakers from the bluetooth menu and then reconnected them, the sound once again came only from the device itself.

    I have collected logs using the script you pointed out and will send them to you.



  • There was an update on the rc channel that landed this morning so, ufter the update, I followed the instructions in the first post. I then connected my Nokia J bluetooth headset to my Pro5 (turbo). There is a crackling noise that comes out of the phone speaker (the bottom loud speaker, not the small top speaker used for phonecalls). The calls don't go through the bluetooth headset, neither is the music. Actually the music app doesn't even show any progress in playing the music. After disconnecting the bluetooth headset and restarting the music app, songs do play throught the loudspeaker of the phone. Also, after disconnecting the bluetooth headset, the phonecalls work.

    Another thing is that, even without connecting the bluetooth headset, ofonod uses 100% of one core of the cpu, so I had to stop it with kill.



  • @mihael Please follow the debugging instruction and send the log to me.



  • @peat_psuwit said in Call for testing: Updated Pulseaudio & better Bluetooth headset support:

    Since the update from yesterday in the dev channel, media-hub audio stops when locking the device. Is it related to this? Is better to tet this as well?



  • Hello,

    I've pushed an update to the repository to fix an issue with the Bluetooth headsets without high-quality audio mode. If you have such a headset, I encourage you to test this new version.

    Thank you to everyone for testing this out.



  • I tried this on my Pro5 rc channel with Nokia J headset - without high quality audio mode. The headset finally has call audio and both speaker and microphone work but there is so much noise that it makes it unusable. I sent you the logs.

    Needless to say, a very big thank you for all your work!!! I am amazed that this is finally going somewhere... I was waiting this moment for maybe 4 years...



  • @mihael Could you please test if the noise problem is a regression from the current version in the system image? You may do so by running ubports-qa remove xenial_-_pulseaudio-updates-to-0ubuntu3.10 or by re-flashing the phone.

    If it's not a regression, I'll consider the test successful and proceed to merge this into the main branch.



  • I'm using Meizu 5 as a daily driver. I can confirm there has been a progress. Before the update I could listen to music flawlessly but making phone calls was impossible. After following instructions and installed the update, phone call won't cut off anymore after few secs but the quality of voice of the caller still needs work. It was cutting up a lot. I just tried to listen to my voicemail messages and I could barely understand what the caller was telling me. Too much cutting up. Pleasant surprise was when I finally hung up music player resumed playing where it left off. Nice one !

    So yeah I could see the progress but the quality of voice transmitted needs extra work.



  • @peat_psuwit I believe that I reverted to the current version following your instructions (even tough I got an error regarding some dependencies for repowerd-data). The situation now is not better and by that I mean that during a phone call through not-high quality audio mode Nokia J bluetooth headset there is an initial noise and then the sound is muted. While, with your new version installed, the call would not be muted although still very noisy.

    Unfortunately I cannot update again to your new version because of the same dependency error as described above. I delayed my answer hoping that a new rc version would land this morning but it was not the case.

    Again thank you for all your work and I hope this noise issue will be solved...



  • @peat_psuwit When this will be merged unto the main branch, will it appear in devel and, respectively, rc version?



  • @mihael yeah sure all things that are pretty close to finalization will be in devel first to be tested and then QAed before OTA release in RC


Log in to reply