x86 / x86_64 tablet (or qemu) support?

  • AH sorry misread your post. I prefer unity 7 on my 2-in-1 HP. Unity 8 is excellent for touch (install through yunit or 17.04) but a lot of apps just don't work well enough there for it to be viable. KDE is really bad at touch for me, and gnome was mediocre at best - large parts of those interfaces don't work well for me. Of course if anyone has tips I'd be happy to try!

    I'm really unsure what to run on 17.10 myself ...

  • So, as I understand it, one must:

  • @Osndok said in x86 / x86_64 tablet (or qemu) support?:

    I'm sure there are some (or even... most?) like that, but mine is more like a microsoft surface pro... it has a conventional bios (american megatrends), usb-ports, etc... and I regularly use linux on it (installed like any other computer, no special flashing routine)... it's just that linux is not very useful without a mouse & keyboard....


    I have a hp pavilion x2 12. Screen and keyboard are detachable leaving you with a 12 inch tablet. Hardware wise basically just a tablet and driver wise fully supported out of the box by recent linux distributions, but neither K nor G environments and applications provide a great touch experience.

    @Osndok said in x86 / x86_64 tablet (or qemu) support?:

    So, as I understand it, one must:

    Have you tried?

    • (somehow) set com.canonical.Unity8.usageMode to "Staged"

    I'm pretty sure this is a non-issue. Unity 8 offers a simple toggle since long and should do "the right thing" anyway when (un-)plugging mouse and keyboard.

  • @doniks I only found those instructions today, at rogier's hint, so I haven't tried the yet, but I'm going to as soon as I get the chance (hurricane notwithstanding).

  • Please let me know how it works out with Unity 8 for you! I'm running 17.04 which means I have Canonical's version preinstalled.

    By the way, what kind of browser / mail client do you guys use with touch?

  • @rogier.oudshoorn said in x86 / x86_64 tablet (or qemu) support?:

    what kind of browser / mail client do you guys use with touch?

    as a browser: Firefox with ScrollAnywhere Addon. Works ok. Previously I had used Grab and Drag addon. also ok.

    as a mail client: Well, back to Thunderbird, without any touch support. Toyed around with Geary before, which does have touch support but it just had too many glitches otherwise.

    Apart from touch support, the screenresolution is a challenge for me. I'm using gnome now, which, with some tweaking of font and UI scaling is ... usable. But there are still some applications which show up with comically giant or tiny fonts/uis 😞

  • I'll check out scrollanywhere; didn't really like grab and drag. So far i'm using Chromium (because that scrolls so much nicer) and the snap beta version of Dekko for email.

  • @rogier.oudshoorn said in x86 / x86_64 tablet (or qemu) support?:

    the snap beta version of Dekko for email.

    I have to try that again. Couldn't get it to work in the past.

  • @Osndok @doniks @rogier-oudshoorn

    I've tried to test Ubuntu 16.04.3 + Yunit on a Chuwi Hi10 Pro (Intel Cherry Trail) and havent't really gotten it to work (but the error lies in this specific device, i would not recommend on buying it!!) however i have a few tipps and experiences in a VM i can share:


    • Using the steps from the yunit homepage (https://yunit.io/yunit-packages-for-ubuntu-16-04-lts-xenial/) will not work within a Live-Cd-System but will spill out some problems with dependencies, you have to really install ubuntu to successfully install yunit from the deb repos.
    • Installing snaps (tested: krita, openspades) works (somewhat, krita started and worked well, however openspades loads for ever and i stopped it after having waited ~15 minutes) BUT they will only appear in the dash after a reboot
    • Starting installed apps from the terminal app does NOT work, it never knew i had something installed already (e.g. for krita using $ krita from the terminal app says it is not installed but available from the repos)
    • The libertine-scope (accessible from the system settings) seems to have some issue with correctly showing containers, i didn't investigate any further yet (and with snaps, libertine is deprecated IIRC)
    • Theoretically, there are two ways trying to install click packages:
    pkcon install-local --allow-untrusted openstore.openstore-team_1.01_armhf.click

    (and the second one which "worked" for me in the VM)

    sudo click install --user <username> openstore.openstore-team_1.01_armhf.click

    HOWEVER: all clicks need the ubuntu-sdk-15.04.(6) framework which is not available for 16.04 and i didn't find it anywhere to install it. Compiling the openstore for x86 from source also failed for me so no phone apps available right now


    • Respin your iso with isorespin.sh by Ian Morrison (http://linuxiumcomau.blogspot.de/) and** include the latest kernel** as well as his intel device enhancements (especially usefull for Bay Trail or Cherry Trail devices, many things like WiFi, Bluetooth will work then most of the time)... You can also include the debs directly with this tool, however i don't see any adventage in this. My Touchscreen didn't work even after doing all this fyi.
    • Expect more BUGs (e.g. mute from the indicator doesn't work, battery indicator seems to be unreliable, touchscreen has some problems, many drivers have problems with Mir/yunit e.g. proprietary Nvidia AFAIK)
    • It might work somehow to set up an LXC container with 15.04 inside your set up and then install the phone apps inside and use them this way, however this needs a lot of work. I don't have time right now but i will post some links and ideas in the following days that i gathered concerning this topic.

  • By the way, not 100% this topic but related to it i have posted an idea/effort to bring the phone apps to 16.04 + Yunit so we might some day actually enjoy the work on convergence on x86 hardware. (Spoiler, it does not work so far, sorry) so head over to https://forums.ubports.com/topic/514/simulating-a-ubports-16-04-on-x86-hardware-or-vm-work-in-progress if you are interested!

Log in to reply