Porting to Samsung Galaxy Note 4 SM-N910P

  • @tigerpro said in Porting to Samsung Galaxy Note 4 SM-N910P:

    @doniks I have some mostly good news, I did the first few things in the link you provided, I now get the Ubuntu Touch boot screen with the scrolling dots, I have yet to get it to go any further than that though. I can ssh in so I dont fully know if this is the spinner that is referred to or if it a different screen all together.

    That's great! And yes, that is the "spinner" (I had the same question:) ).

    I think what I had to do at that point was the stuff about /run/user/32011 - it's in the FAQ. You should see something about it in the logs: http://docs.ubports.com/en/latest/porting/common-problems-run.html#getting-more-mir-logs

  • @doniks I was thinking that could be part of the issue but the part in the parenthesis indicates it was fixed 10/28/18 and I'm using edge roots from 12/6/18 however I could try that, if that doesn't resolve it then I'll try getting the logs and see if those shed any light on the matter. I have to stop for a little bit today, but I'll look at it later.

  • @tigerpro said in Porting to Samsung Galaxy Note 4 SM-N910P:

    @doniks I was thinking that could be part of the issue but the part in the parenthesis indicates it was fixed 10/28/18

    yeah, saw that. seems it wasn't really fixed ... I guess ... I had to do it and I also had a newer rootfs

  • @doniks OK, I will try that as soon as I can. I wanna keep going now that I'm so close I can practically taste it, lol. I know I will have more to do once I get the GUI, for example I expect BT to not work cause I had to disable BT in the defconfig to get halium to compile successfully, but once I have a working boot I can at least go from there with it. I am thinking I'll focus on getting the device stuff that doesn't work (like BT) working then I can go from there to start working on the network based stuff (like WiFi and LTE) if needed. I am also working on a plan for a DIY dock to utilize the desktop GUI but that is a different topic for a different time.

  • @doniks so trying that didn't work, when I tried to get the logs following the FAQ my device rebooted after I issued the last command so I'm kinda stuck at this point (tried 3 times to no avail) I have a gut feeling that something isn't configured right for my device but figuring that out is gonna be very time consuming. I'll try it again tomorrow with a fresh rootfs (the merge list for edge is quite big so there may be a fix in place for that) and if it still doesn't let me do what I need I'll see what my options are.

  • @doniks I have News, I finally got the device to go past the spinner, it was a combo of my udev rules and the 32011 stuff, I now have a fully working GUI, working touchscreen, and working file access, thats about it though, the wifi is detected but it isnt finding the wifi network for some reason, Ill have to play with it in terminal I guess, as for the rest, any idea where I could start with getting the rest to work?

  • So I have been trying to get my ofono stack working, as of now it seems like the android stuff can't access its own stuff in the /proc folder.
    The list of what isn't working as of this writing is:

    Cellular (Ofono sees the cellular modem but can't access its own folder in /proc)

    Bluetooth (completely untested)

    Rotation (sensors are found but no values generated)

    GPS (test_gps segfaults in halium-boot but not in hybris-boot)

    Audio (untested)

    S-Pen (kernel sees it as a input device but disables it for some reason)

    If anyone reading this has a note 4 and wants to take on any of these tests let me know your findings and I will update the list as issues are resolved. I also welcome any advice anyone may have if they read this and are not in telegram but have an idea of what's going on.

  • So I have an update for anyone following this that isn't on telegram or IRC, there are now a couple people working with me on the Note 4 port, the devices are the Sprint, the T-Mobile, and the Trltexx. We have managed to get audio somewhat working, all the hardware as far as we can tell is seen by the kernel, and we are now just trying to get everything working on the GUI side. I have switched to telegram as the primary communication method so dont expect many updates on here, if you have a galaxy note 4 and would like to contribute, you can find me on telegram in the UBPorts group, the UBPorts porting group, and the halium group.

  • Dear @tigerpro,

    Which exactly Note 4 version should I buy to support you?

    Is "SM-N910P" the only that you support ?
    I can see that there are different models called N4: SM-N910S, SM-N910C, SM-N910H, SM-N910L, SM-N910K.

    Kind regards and good luck, Piotr.

  • @pe3noATo2DOTpl i currently own a 910P and a 910V, they both have a CDMA modem in them, theres also a 910T port which is GSM and a 910F, in theory any of the variants should be able to boot the port, but without all the variants to test I cant confirm, whichever you get, let me know on telegram and I will add you into the note 4 ubports chat and we can see if we get more features working

Log in to reply