Meizu pro 5 without any os.

  • I have only just looked at this post and after reading Stefano comments, my thoughts were that it would install a clean version of UBPorts on your phone. If that is the case you could hook up your phone to a pc via a USB cable

  • Hi,firstly, yes luckily the fastboot is unlocked.
    But now i want to be very careful(it is the second time i do stupid things), so when you say flash the TWRP and later the recovery, do you mean this command: fastboot flash partition [filename]?
    And if yes, with partition should i flash?(or twrp is also a patition?)
    Thank you for the help.

  • @bontemps
    Yes, flash with: sudo fastboot flash recovery TWRP_3.0.2_m86.img

    It's just a recovery and there is no need to be afraid to flash it. I have done it like hundred times on Pro 5.

    Later when everything is done, in order to receive OTA, you need to flash the Ubuntu recovery the same way.

    Let me know if any problem.

  • @bontemps btw. i have wiped my Pro 5 with fastboot -w previously a handfull of times when I was trying some Android ROMS.
    From there I was getting an error when attempting to flash with ubuntu-device-flash.
    I found a way back by flashing a Flyme with unlocked bootloader, then boot it, enabled developer mode, usb debugging, then reboot to recovery (TWRP)
    Wiped it in recovery, reboot to fastboot, flashed the Ubuntu recovery and then flashed it with ubuntu-device-flash

    But then I got tired of doing all that, and made myself a TWRP backup of Ubuntu-Touch and everytime I just restored it with TWRP and flashed the Ubuntu recovery afterwards.

    There might be other way how to restore your phone, but this is how I did and succeeded. (also I have done manual install as per here:)lintext

  • So, i have done the three first steps.
    I'm in TWRP and able to use adb shell (i verify with adb shell ls).
    But there are a few things that i don't understand:

    Firstly, for the two second steps. Should i put an SD card on the phone?
    Secondly, can i do those steps by using adb shell(without SD then)?
    And finally, in the other topics of the link they say to wipe only cache, system and data partitions.
    But are they not already by the fastboot -w command?

    And to ask all the questions at the same time, is it normal that TWRP is just a screen whitout any menu for actions on the phone(whitout SD card on it)?

  • @bontemps
    OK, so here we go.
    As you say that you booted to TWRP already and there is no MENU?
    Flash it again, there has to be this:0_1508342150707_TWRP-Recovery.png

  • @bontemps
    there is no need to put SD card inside, I just mentioned it that you don't wipe your data, photos, etc... so yes keep it out.
    Yes you can push the backup with adb push, but if you don't already have a backup folder in TWRP folder on SDcard (internal) the TWRP recovery won't find the backup you want to restore.
    The formating with TWRP formats all partitions for you to restore the backup as they might not be there at all after fastboot -w
    so do it anyway, it takes seconds ( it might gives an errors, but ignore that)

  • @bontemps
    are you here???

  • Strange, i have flash it again with the same result.
    I have haven done it one more time with a newly downloaded version to be sure there had been no network error(which give again the same result ).
    On the page that i get there is the inscription TEAMWIN and Recovery Project 3.0.2-0 with a logo.
    The screen blink all the 1 or 0.5 seconds.

  • @bontemps try this recovery:

  • Yes, this one work but i can't mount the data partition in order to wipe it.

  • @bontemps ok, just wipe it then without selecting data partition

  • @bontemps because there is no such a partition

  • @bontemps after wipe, reboot the recovery

  • So, i wiped but there is no TWRP/ Backup(i use adb shell ls).

  • @bontemps you need to attempt to Create the backup first. Just tap on backup and let it run. Then it will fail as there is nothing to backup yet, but you'll have a folder created and there you put the Backup I provided and restore it.

  • Sorry i was confuse, i wanted to write : So, i wiped and then i made a backup but there is no TWRP folder at all.

  • @bontemps there is Mount field, click on it, unmout then mount all partitions that you can sellect. If connected to your PC, you should see the Folder TWRP, inside is BACKUPS, then strange number and the backup inside

  • @bontemps unplug the phone and plug it back to PC

  • I made it, but when looking with the file manager i see no TWRP folder (on the phone).
    And no more when looking with adb (with the pc).
    I have a twres folder but it didn't contain any backups.

Log in to reply