Meizu pro 5 without any os.

  • I don't know if i am in the right category but i don't know where to put it.
    Actually, i have a meizu pro 5 on the last ota of ubuntu os before they stop supporting it.
    And i changed the passcode to an 8 caracters one using the passwd command (in the terminal emulator) . But the phone take only 4 caracters when unlocking.
    So, i was unable to unlock it any more.
    There, i tried to hard reset it with the recovery mode. But it didn't work, so thinking that it will clear the users
    data i used the fastboot -w command (in the fastboot mode of course).
    And now, when i try to boot it, the meizu logo just appear than stay a few seconds and disepair. Befor starting again the same way and it continue like this booting and exiting.
    So have you any ideas of what is going on and what to do to make it work again (on ubport of other)?
    Sorry for the anglish quality.

  • If it may help, here is a screen-shot of the last operation.

  • @bontemps hi, NOT to worry, first thing to do is check if your bootloader is unlocked.
    Power + volume down, see the bottom left corner what it says.
    If unlocked then all is ok.
    Download TWRP recovery from here:

    Flash the TWRP with fastboot.

    Reboot to recovery : power + volume up.

    Mount all partitions apart from ExternalSD

    Wipe all apart from Your ExternalSD

    Download a Backup of Ubports_ota1from here.

    In Recovery, make a backup (I know it will fail, but you'll have a TWRP Backup folder where you copy the downloaded file)

    Copy the downloaded file to TWRP/ Backup

    Restore the backup with TWRP.

    Download the Ubuntu Touch recovery from here:

    Flash this recovery with fastboot.

    Reboot and enjoy.

    It should work.
    Let me know if you succeed.

  • @bontemps you completely wiped it, no data left on device, no files, no OS at the moment.

  • I have only just looked at this post and after reading Stefano comments, my thoughts were that it would install a clean version of UBPorts on your phone. If that is the case you could hook up your phone to a pc via a USB cable

  • Hi,firstly, yes luckily the fastboot is unlocked.
    But now i want to be very careful(it is the second time i do stupid things), so when you say flash the TWRP and later the recovery, do you mean this command: fastboot flash partition [filename]?
    And if yes, with partition should i flash?(or twrp is also a patition?)
    Thank you for the help.

  • @bontemps
    Yes, flash with: sudo fastboot flash recovery TWRP_3.0.2_m86.img

    It's just a recovery and there is no need to be afraid to flash it. I have done it like hundred times on Pro 5.

    Later when everything is done, in order to receive OTA, you need to flash the Ubuntu recovery the same way.

    Let me know if any problem.

  • @bontemps btw. i have wiped my Pro 5 with fastboot -w previously a handfull of times when I was trying some Android ROMS.
    From there I was getting an error when attempting to flash with ubuntu-device-flash.
    I found a way back by flashing a Flyme with unlocked bootloader, then boot it, enabled developer mode, usb debugging, then reboot to recovery (TWRP)
    Wiped it in recovery, reboot to fastboot, flashed the Ubuntu recovery and then flashed it with ubuntu-device-flash

    But then I got tired of doing all that, and made myself a TWRP backup of Ubuntu-Touch and everytime I just restored it with TWRP and flashed the Ubuntu recovery afterwards.

    There might be other way how to restore your phone, but this is how I did and succeeded. (also I have done manual install as per here:)lintext

  • So, i have done the three first steps.
    I'm in TWRP and able to use adb shell (i verify with adb shell ls).
    But there are a few things that i don't understand:

    Firstly, for the two second steps. Should i put an SD card on the phone?
    Secondly, can i do those steps by using adb shell(without SD then)?
    And finally, in the other topics of the link they say to wipe only cache, system and data partitions.
    But are they not already by the fastboot -w command?

    And to ask all the questions at the same time, is it normal that TWRP is just a screen whitout any menu for actions on the phone(whitout SD card on it)?

  • @bontemps
    OK, so here we go.
    As you say that you booted to TWRP already and there is no MENU?
    Flash it again, there has to be this:0_1508342150707_TWRP-Recovery.png

  • @bontemps
    there is no need to put SD card inside, I just mentioned it that you don't wipe your data, photos, etc... so yes keep it out.
    Yes you can push the backup with adb push, but if you don't already have a backup folder in TWRP folder on SDcard (internal) the TWRP recovery won't find the backup you want to restore.
    The formating with TWRP formats all partitions for you to restore the backup as they might not be there at all after fastboot -w
    so do it anyway, it takes seconds ( it might gives an errors, but ignore that)

  • @bontemps
    are you here???

  • Strange, i have flash it again with the same result.
    I have haven done it one more time with a newly downloaded version to be sure there had been no network error(which give again the same result ).
    On the page that i get there is the inscription TEAMWIN and Recovery Project 3.0.2-0 with a logo.
    The screen blink all the 1 or 0.5 seconds.

  • @bontemps try this recovery:

  • Yes, this one work but i can't mount the data partition in order to wipe it.

  • @bontemps ok, just wipe it then without selecting data partition

  • @bontemps because there is no such a partition

  • @bontemps after wipe, reboot the recovery

  • So, i wiped but there is no TWRP/ Backup(i use adb shell ls).

  • @bontemps you need to attempt to Create the backup first. Just tap on backup and let it run. Then it will fail as there is nothing to backup yet, but you'll have a folder created and there you put the Backup I provided and restore it.

Log in to reply