Meizu Pro5 fastboot mode locked



  • @matteo When using android ~ did you get a wifi called "NVRAM error+ 10"
    It can be caused by using flash tool. and wiping / formating the nvram
    This happens with BQ devices.
    Is it possible you wiped yours thru TWRP. ???

    Can you restore from backups,everyone makes before installing Roms.

    Xxxxx://forum.xda-developers.com/meizu-pro-5/development/multirom-v33-meizu-pro5-t3522660

    This guy has a lot of pro5 files linked from here
    Just put the http in



  • @matteo That's strange, I never had a problem with wifi, nor gps on 15.04.
    Regarding the Flyme Global, if you unpack the update.zip and remove the file called ''bootloader'' , repack the files to ''update.zip'' again , you'll get the Flyme update zip, that don't need the unlocking the bootloader again. Also you can always wipe the phone with TWRP and flash the update.zip with it as well. I just thought that original Flyme recovery might do a better job to properly wipe and upgrade the phone base.
    Maybe there are some other Pro 5 users that could help as I'm unable to help in this case.



  • @matteo I don't know if this will help but there is a method to update just the baseband on a Pro5.
    Update Meizu Pro 5 Baseband



  • @matteo Duknow ab the GPS side but the Wifi connections are apparently stored in files at /etc/NetworkManager/system-connections/<AP Name>

    Check if this accessible and writable:
    drwxr-xr-x 2 root root 4096 May 27 16:36 system-connections

    It looks like mounted to userdata somehow:
    phablet@ubuntu-phablet:/etc/NetworkManager/system-connections$ df -h .
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk/by-partlabel/userdata 54G 32G 22G 59% /etc/NetworkManager/system-connections



  • I am curious
    I am using pro5 16.04 as a daily driver,( i am retired,so just playing really), I find that i get a wifi password screen on top of the,login screen, all i do is cancel the Wifi screen, then login. If my wifi does not login,( and i will be using cell data) i pull up the wifi screen,and press once on my wifi,and it signs me in.

    ( without reentering my password).

    I am not aware that Gps,is working yet,

    Any similarities ???



  • @marathon2422 I didn't notice that wrong wi-fi name when I was on Flyme, no. However, also the GPS seems wrong. I followed all the steps to resize the file system and I didn't get any error. Thanks for the link, I'll have a look at it!



  • @halucigenia thank you for the link. Reading that post updating the baseband it seems didn't improve the connectivity though. Anyway, I also have issue with the GPS which seems dead.



  • @tera tera this is the screen-shot after following what you suggested:

    0_1528876513787_39b543f4-ae37-4575-a754-40f45a7096fa-image.png

    As you can see the AP Name "FASTWEB-1-AB8961" is written there, but the issue is that when the system reboots, it doesn't read automatically from there, so I always have to re-assign the password in order to make it work and a new AP Name is filed with the name for instance "FASTWEB-1-AB8961-1"; after an other re-boot, if I insert again the password I will get a new "FASTWEB-1-AB8961-2" and so on.
    I read in the Update Meizu Pro 5 Baseband that you said the Pro5 is not usable as a daily driver. May I ask you why so? Did you have same experience with the wi-fi? And what about the GPS? Does it properly work for you?



  • Hi @matteo

    After reboot, do you see "FASTWEB-1-AB8961" in the Previous Networks?

    Just made a quick test, removing a file from /etc/NetworkManager/system-connections and after Reboot, the matching AP disappeared from the Previous Networks on mine.

    Also, check the content of the file, it carries your wireless details.

    So it would look like either your NetworkManager is reading files from somewhere else but still store it there... not sure how to help/investigate more on my end.

    About my comment on Pro5, i travel a lot for my job and unfortunately not able to rely on the Pro5 to get a strong 4G signal, even sometimes simply to make calls.
    I have now switched to a Fairphone2 for data/phone calls, but still use my Pro5 connected via Hotspot for GPS and other activities.

    Hope that helps,
    Tera



  • @tera I confirm all the connectivity data regarding the "FASTWEB-1-AB8961" are correctly stored there, but it doesn't seem the phone actually read it after a re-boot. Thanks anyways.



  • @matteo Maybe nmcli can provide you further clues, try commands like:
    nmcli connection show
    nmcli connection reload



  • @tera I got this error:

    0_1528995421651_4bbb3d22-f422-4269-923b-8de474f55678-image.png
    I also tried other commands and for instance the wi-fi AP seems to be set in auto-connection mode, even if doesn't work:

    0_1528995663026_464295de-2d8b-4e85-86f7-6c553c69005a-image.png



  • @matteo Try with sudo, just confirmed on FP2.



  • @tera nope, also with sudo it throws me errors....maybe, I was thinking I could try to flash the Canonical Ubuntu Touch version and then switch to UBPorts and see what happens...do you guys by the chance have the Canonical image to be flashed? Any OTA up to 15 would be good, I guess. Thank you.



  • @matteo
    https://system-image.ubuntu.com/ubuntu-touch/stable/meizu-pd.en/

    ubuntu-device-flash touch --device=turbo --channel=ubuntu-touch/stable/meizu-pd.en



  • This post is deleted!


  • @stefano Stefano, in the end it doesn't work with the CLI method, it pushes all the files but then just after starting the recovery boot it crashes...now, what I would like to do is the following:

    1. Flashing back the Flyme version with the unlocked bootloader;
    2. Flashing the UT Canonical version with TWRP but I don't know if this is possible, since I don't see any .img file in the folder you @Stefano pointed to me and when I tried from TWRP to restore from that folder it didn't work (confirmation needed, pleeeeaaassseeeeee);
    3. Checking if with the Canonical version the wi-fi and GPS are working as expected;
    4. If confirmed, I'll proceed by flashing the 15.04 UBPorts version with the UBPorts installer, checking if the working wi-fi and GPS are retained;
    5. If confirmed, I'll proceed by flashing the 16.04 UBPorts version with the UBPorts installer, checking if the working wi-fi and GPS are retained.
    6. If GPS and wi-fi will not work, I'm going to give up this time.

    Thank you guys for the patience.

    Cheers.

    Matteo



  • @matteo You can't flash Canonical, nor Ubports version with TWRP, it doesn't work that way.

    So have you tried to wipe the phone, flash Ubuntu Touch recovery, reboot to bootloader, then reboot to recovery, then flash the Canonical image from terminal?:

    sudo ubuntu-device-flash touch --device=turbo --channel=ubuntu-touch/stable/meizu-pd.en

    If the Canonical image on your phone has trouble with wifi and GPS, then I don't know what's the culprit.



  • @stefano it doesn't work flashing to the Canonical version following your procedure. The error thrown after pushing the files is always the same:

    0_1529336967839_834d8195-baa9-4feb-b86a-bf0b4b6682c3-image.png



  • @matteo Yeah, I was strugling with that as well, to be honest, I don't know how I managed to fix that. Maybe restoring the Canonical imagr from a .zip backup would be helpfull. I will provide one, but need to create one first, so wait a while.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.