Meizu Pro5 fastboot mode locked

  • @halucigenia I thought you had to flash old ubuntu touch,to get partitions sized correcly,then flash ubports, ( updates by flyme,put on the root of internal drive ,and flyme recovery can find them and go to work). Recovery install from fastboot= sudo fastboot flash recovery ~then your recovery location,drag n drop or or

  • @matteo try to flash recovery again,: sudo fastboot flash recovery recovery-turbo.img

    And if it won't work, unplug the phone and :
    sudo adb kill-server

    sudo adb start-server

    plug in the phone and try again

  • @stefano thanks ,i was trying to throw some ideas in.
    i am waiting for 16.04 to be released for my pro 5.
    my sim no good for ubuntu/ubports.
    most likley need help then ,cant remember my flyme login ,and on a different cell number,should be fun

  • @marathon2422 No, I did not have to re-partition, although I did think that I might have to. However, it looks like for 16.04 it needs more room on your cache partition than 15.04, see

  • @stefano you know what Stefano? Reading again this post from the beginning, I found out something that I missed before, i.e. you sent a link to an file. I downloaded that and saved in the phone in order to upgrade the phone. Once started the process, it came out the "Firmware corrupt" issue. Why is so? My phone is now supposed to be fixed as international, weird....

    Going to your suggestion regarding the flash recovery thing, I didn't do any flash recovery before nor I know how to proceed with this procedure. Should I exploit the Ubports installer to do so?

  • @matteo did you mean the " "

    This is the one which you are suppose to flash after you change the ID to I (global or international)
    This version can have the bootloader unlocked, no other firmware version of Flyme is known to work.
    Be careful, if you flash again any A firmware ( Chinese ) you will need to unlock the bootloader again.

    So, If you flashed firmware Flyme OS first, then changed the ID and followed the steps, you should have now International (global)version of FLYME and the next thing is to flash that, start the phone, enable developer options, usb debugging, then rebooting to FASTBOOT and unlock the bootloader.
    After that reboot to fastboot and check the screen down, is small print and shoud say "FASTBOOT MODE (unlocked, rooted )

    If this is true, you can then flash UT, otherwise it won't do nothing.

  • @stefano yes exacly, the " ". If I try to flash it, it gives me the "Firmware corrupt" message.
    I already flashed back Flyme OS (before reading your warning though). I gained root mode again by accessing the Flyme account and then I wanted to check again the international name and it seems all good so far:


    It should work! I'm out of ideas...

  • @matteo just to be sure,type in:
    sudo fastboot oem unlock

  • @matteo download this recovery:

    move to your Home folder on PC

    Start terminal and type in with phone rebooted to bootloader mode:

    sudo fastboot flash recovery TWRP_3.0_m86.img

    it should flash you phone with custom TWRP recovery, then you reboot to recovery and flash International version of FLyme, boot in the FLYME and enable developer mode, usb debugging.

  • @matteo SORRY man, I probably forgot to mention that you need to rename the Unlocked bootloader zip to " "
    And flash it, I only renamed it for recognition while downloading, the FLYME recovery won't flash any other zip. While selecting to update it, you need to select the WIPE option as well ,on original FLYME recovery. Otherwise you might loose IMEI. ( But you probably know that, as I hope you read tutorials on Flyme forum ,how to upgrade the FLYME )

  • @stefano thanks, I already renamed that, you mentioned to do so already in this post when you attached the file. Anyhow, I'm still getting the "Corrupt" message....I try out your other tips and see what the meantime...thank you very much, you are sooooo kind to help me!

    P.S. what's the numbering of your firmware? Is it by the chance the Flyme OS I'm telling you, because that's the one I downloaded according to this post, from the MediaFire or Mega servers and this version worked so far for me, but not enough to get the device be recognized in fastboot mode.

  • @matteo Yes, that's the version I uploaded as well.
    Maybe the file itself be corrupted by downloading.
    Anyway, if you have trouble to have detected phone in fastboot, try:
    sudo fastboot devices
    or try to plug it to a different usb port, reboot the PC, update it...

  • @stefano ok, then there is a problem with your file, maybe as you said I got it corrupted during the download. Anyhow, I again downloaded the version of Flyme OS daily (I expected a suffix like G but it says only "daily"), and tried again to plug it to the PC to be stays put with the message <waiting for device>, forever displayed.
    I also tried an other version, this time from the official Flyme site (ver. Flyme because "G" stands for the global device) but again no detection in fastboot mode...nothing seems to work.
    I tried different usb ports but it always ends with no detection. I enabled the "USB debugging", I have the doubt that I missed something else to be accomplished before going in fastboot mode.

  • @matteo sorry to ask again ,but have you used : sudo fastboot devices

  • @stefano you mean if I tried typing that when the Pro 5 is in fastboot mode? Yes, and the output is nothing, the device isn't recognized. I tried with all the usb ports my laptop has got but no change. I would like just to mention that on my laptop I installed the Ubuntu 16.04 OS.

  • @matteo That's strange. Try to reinstall fastboot and adb on your laptop.

  • @matteo Maybe try this:

    Create a bootable usb disk (at least 6gb usb key)
    from your laptop. ( Usb startup disk creator)
    Boot from that usb,
    In terminal install adb tools, install fastboot and try if it list your Pro 5. If yes, then you can try installation of UT.

  • @stefano I know for sure that fastboot detection works with my Ubuntu 16.04 desktop because I tried it with my other phone BQ Aquaris E5 UBports edition, which is detected without any issue. The difference between the BQ E5 and the Meizu Pro 5 is that the E5 is unlocked while the Pro 5 isn't yet.

  • @stefano I will try also this way, thank you for not giving up....

  • I just realized something....if I go in "About phone" and scroll to the bottom I see that the Serial number is missing ("unknown") and I got two IMEI numbers which are the same. Could it be related to the fact my Ubuntu desktop doesn't detect the device? If so, how to retrieve the serial number and why was deleted since the first access I made when I got my phone?


Log in to reply