Meizu Pro5 fastboot mode locked

  • @matteo did you mean the " "

    This is the one which you are suppose to flash after you change the ID to I (global or international)
    This version can have the bootloader unlocked, no other firmware version of Flyme is known to work.
    Be careful, if you flash again any A firmware ( Chinese ) you will need to unlock the bootloader again.

    So, If you flashed firmware Flyme OS first, then changed the ID and followed the steps, you should have now International (global)version of FLYME and the next thing is to flash that, start the phone, enable developer options, usb debugging, then rebooting to FASTBOOT and unlock the bootloader.
    After that reboot to fastboot and check the screen down, is small print and shoud say "FASTBOOT MODE (unlocked, rooted )

    If this is true, you can then flash UT, otherwise it won't do nothing.

  • @stefano yes exacly, the " ". If I try to flash it, it gives me the "Firmware corrupt" message.
    I already flashed back Flyme OS (before reading your warning though). I gained root mode again by accessing the Flyme account and then I wanted to check again the international name and it seems all good so far:


    It should work! I'm out of ideas...

  • @matteo just to be sure,type in:
    sudo fastboot oem unlock

  • @matteo download this recovery:

    move to your Home folder on PC

    Start terminal and type in with phone rebooted to bootloader mode:

    sudo fastboot flash recovery TWRP_3.0_m86.img

    it should flash you phone with custom TWRP recovery, then you reboot to recovery and flash International version of FLyme, boot in the FLYME and enable developer mode, usb debugging.

  • @matteo SORRY man, I probably forgot to mention that you need to rename the Unlocked bootloader zip to " "
    And flash it, I only renamed it for recognition while downloading, the FLYME recovery won't flash any other zip. While selecting to update it, you need to select the WIPE option as well ,on original FLYME recovery. Otherwise you might loose IMEI. ( But you probably know that, as I hope you read tutorials on Flyme forum ,how to upgrade the FLYME )

  • @stefano thanks, I already renamed that, you mentioned to do so already in this post when you attached the file. Anyhow, I'm still getting the "Corrupt" message....I try out your other tips and see what the meantime...thank you very much, you are sooooo kind to help me!

    P.S. what's the numbering of your firmware? Is it by the chance the Flyme OS I'm telling you, because that's the one I downloaded according to this post, from the MediaFire or Mega servers and this version worked so far for me, but not enough to get the device be recognized in fastboot mode.

  • @matteo Yes, that's the version I uploaded as well.
    Maybe the file itself be corrupted by downloading.
    Anyway, if you have trouble to have detected phone in fastboot, try:
    sudo fastboot devices
    or try to plug it to a different usb port, reboot the PC, update it...

  • @stefano ok, then there is a problem with your file, maybe as you said I got it corrupted during the download. Anyhow, I again downloaded the version of Flyme OS daily (I expected a suffix like G but it says only "daily"), and tried again to plug it to the PC to be stays put with the message <waiting for device>, forever displayed.
    I also tried an other version, this time from the official Flyme site (ver. Flyme because "G" stands for the global device) but again no detection in fastboot mode...nothing seems to work.
    I tried different usb ports but it always ends with no detection. I enabled the "USB debugging", I have the doubt that I missed something else to be accomplished before going in fastboot mode.

  • @matteo sorry to ask again ,but have you used : sudo fastboot devices

  • @stefano you mean if I tried typing that when the Pro 5 is in fastboot mode? Yes, and the output is nothing, the device isn't recognized. I tried with all the usb ports my laptop has got but no change. I would like just to mention that on my laptop I installed the Ubuntu 16.04 OS.

  • @matteo That's strange. Try to reinstall fastboot and adb on your laptop.

  • @matteo Maybe try this:

    Create a bootable usb disk (at least 6gb usb key)
    from your laptop. ( Usb startup disk creator)
    Boot from that usb,
    In terminal install adb tools, install fastboot and try if it list your Pro 5. If yes, then you can try installation of UT.

  • @stefano I know for sure that fastboot detection works with my Ubuntu 16.04 desktop because I tried it with my other phone BQ Aquaris E5 UBports edition, which is detected without any issue. The difference between the BQ E5 and the Meizu Pro 5 is that the E5 is unlocked while the Pro 5 isn't yet.

  • @stefano I will try also this way, thank you for not giving up....

  • I just realized something....if I go in "About phone" and scroll to the bottom I see that the Serial number is missing ("unknown") and I got two IMEI numbers which are the same. Could it be related to the fact my Ubuntu desktop doesn't detect the device? If so, how to retrieve the serial number and why was deleted since the first access I made when I got my phone?


  • @matteo It shouldn't matter if it recognize the imei or serial no.
    I'm baffled, don't really know what's wrong with it. If you managed to change the id to international, then flashed 5.1...daily, it shouldn't be any problem to unlock the bootloader, nor it should be any problem with recognizing the device in fastboot. Especially if you have other UT device and is detected just fine. It's a mystery to me. Maybe someone else could help?

    I would give it one more shot.
    Go back and flash that 5.1.... daily Flyme, but while doinig so, there is an option to wipe the device and update(Flyme recovery)
    Make sure you tick both fields and update it.
    Then again enable usb debbuging, developer options, reboot the phone to bootloader and try: sudo ubuntu devices

    Let me know.
    I had 3 Pro5 phones and never had such a problem.

  • @matteo The one I used had null, for the imie,numbers and a lot of other stuff missing,all you need is the unlocked fastboot,.
    When you have flashed the unlocked fast boot,re flash TWRP go and wipe every thing, or it with stop at ubports recovery and not spin the little wheels.

    I couldn't resist following along,I had RR 5.8.5. On my pro5,
    Thanks to Stefano,I tried 16.04, looking good,then switched back to 15.04 dev full install.

  • Guys thank you for the help, really....I'm happy to tell you that finally I did it! I unlocked my Pro 5.
    I did it only using a different laptop, I installed Lubuntu 18.04 on it and, after installing adb and fastboot, it just worked in fastboot mode, detecting immediately the Pro 5, Yay! I suspect there is some trouble with Ubuntu 16.04, but I don't know why.
    Now, my next step will be to install Ubports but I'm struggling also there, because the Ubports Installer recognize my phone but it throw out a message saying that my phone isn't supported...odd!

    I have to digest the @Marathon2422 hint before moving any further, by the way.

    For now, I'm happy as I am, I will think about it in the next days 😜

    Good night!


  • @matteo most likely not finding adb .

    my pro5 has not been recognised yet by the installer fyi

    sudo ubuntu-device-flash --server= touch
    --device=[DEVICE-CODENAME] --channel=ubports-touch/16.04/devel --bootstrap --wipe
    you could try this making the needed changes
    or do what Stefano gave you,
    you have unlocked fastboot now, so
    Flash TWRP, then wipe all ,then run backup ,to get the folders in backup,then put in backup the folder from Stefano (15.04) then run restore in TWRP.
    when it is working, go into the folder (15.04) find the recovery and flash it with TWRP to get full install.

    you will still get the black screen with miezu on it, until you have upgrade/dated a couple of times.
    if you get stuck on the ubports recovery screen,and nothing is moving, go back to TWRP and wipe again ( not external sd, but everything else.
    you will need to unzip Stefano`s folder to use it

    I had mine on RR 5.8.5. for a while ,it was a struggle to get it to reinstall UB.

    i am playing with a BQM10fhd. and Pro5 TD-LTE 32g
    good luck

  • @Marathon2422 @Stefano I followed your tips, from the step needing the TWRP installation, and finally I have Ubports 15.04 on my Pro 5, hurray! Thank you very much! I also have the "Meizu powered by Ubuntu" splashscreen.
    Now, I would like to switch to Ubuntu 16.04 but I'm struggling with that and still I'm not succeeding. Here following what I did:

    1. Typed "sudo ubuntu-device-flash --server= touch
      --device=turbo --channel=ubports-touch/16.04/devel --bootstrap --wipe" from inside phablet-shell but it doesn't recognize the command ubuntu-device-flash: the output states 'command not found'.
    2. When I was on 15.04 stable I ran both the ubports-installer 0.1.12 and 0.1.13. Both didn't detect my Pro 5 so I went in manual mode and the result was the following (P.S. I tried to run both either in terminal with sudo or without sudo):
    • 0.1.13: it stops really soon with an error, without starting the pushing file step;
    • 0.1.12: it works, it goes pushing all the 13 of 13 files and then I got the 'Success' window; but, once rebooted the phone I step into this:
      rebooting the phone I'm still stuck in the 15.04 version.
    1. Then I switched to 15.04 Release Candidate. I used again both the ubports-installer 0.1.12 and 0.1.13 and here below the results:
    • 0.1.13: it detects the phone automatically now, but, once rebooted, it stucks on the splashscreen doing nothing, without achieving the pushing files step;
    • 0.1.12: it detects the phone automatically now, but, once rebooted, it stucks on the splashscreen doing nothing, without achieving the pushing files step.
    1. I tried the other command 'sudo system-image-cli -vvvv --switch ubports-touch/16.04/devel' to update from terminal within the phablet-shell and it seems to work until to get this:
      Now I'm out of ideas......any hint is always welcome 😜


    EDIT: I forgot to mention that I finally succeeded because I decided to try to change the USB cable with a brand new one nearly purchased and it worked like a charme! So, the message is: never trust USB cables!

Log in to reply