Meizu Pro5 fastboot mode locked

  • @matteo Maybe try this:

    Create a bootable usb disk (at least 6gb usb key)
    from your laptop. ( Usb startup disk creator)
    Boot from that usb,
    In terminal install adb tools, install fastboot and try if it list your Pro 5. If yes, then you can try installation of UT.

  • @stefano I know for sure that fastboot detection works with my Ubuntu 16.04 desktop because I tried it with my other phone BQ Aquaris E5 UBports edition, which is detected without any issue. The difference between the BQ E5 and the Meizu Pro 5 is that the E5 is unlocked while the Pro 5 isn't yet.

  • @stefano I will try also this way, thank you for not giving up....

  • I just realized something....if I go in "About phone" and scroll to the bottom I see that the Serial number is missing ("unknown") and I got two IMEI numbers which are the same. Could it be related to the fact my Ubuntu desktop doesn't detect the device? If so, how to retrieve the serial number and why was deleted since the first access I made when I got my phone?


  • @matteo It shouldn't matter if it recognize the imei or serial no.
    I'm baffled, don't really know what's wrong with it. If you managed to change the id to international, then flashed 5.1...daily, it shouldn't be any problem to unlock the bootloader, nor it should be any problem with recognizing the device in fastboot. Especially if you have other UT device and is detected just fine. It's a mystery to me. Maybe someone else could help?

    I would give it one more shot.
    Go back and flash that 5.1.... daily Flyme, but while doinig so, there is an option to wipe the device and update(Flyme recovery)
    Make sure you tick both fields and update it.
    Then again enable usb debbuging, developer options, reboot the phone to bootloader and try: sudo ubuntu devices

    Let me know.
    I had 3 Pro5 phones and never had such a problem.

  • @matteo The one I used had null, for the imie,numbers and a lot of other stuff missing,all you need is the unlocked fastboot,.
    When you have flashed the unlocked fast boot,re flash TWRP go and wipe every thing, or it with stop at ubports recovery and not spin the little wheels.

    I couldn't resist following along,I had RR 5.8.5. On my pro5,
    Thanks to Stefano,I tried 16.04, looking good,then switched back to 15.04 dev full install.

  • Guys thank you for the help, really....I'm happy to tell you that finally I did it! I unlocked my Pro 5.
    I did it only using a different laptop, I installed Lubuntu 18.04 on it and, after installing adb and fastboot, it just worked in fastboot mode, detecting immediately the Pro 5, Yay! I suspect there is some trouble with Ubuntu 16.04, but I don't know why.
    Now, my next step will be to install Ubports but I'm struggling also there, because the Ubports Installer recognize my phone but it throw out a message saying that my phone isn't supported...odd!

    I have to digest the @Marathon2422 hint before moving any further, by the way.

    For now, I'm happy as I am, I will think about it in the next days 😜

    Good night!


  • @matteo most likely not finding adb .

    my pro5 has not been recognised yet by the installer fyi

    sudo ubuntu-device-flash --server= touch
    --device=[DEVICE-CODENAME] --channel=ubports-touch/16.04/devel --bootstrap --wipe
    you could try this making the needed changes
    or do what Stefano gave you,
    you have unlocked fastboot now, so
    Flash TWRP, then wipe all ,then run backup ,to get the folders in backup,then put in backup the folder from Stefano (15.04) then run restore in TWRP.
    when it is working, go into the folder (15.04) find the recovery and flash it with TWRP to get full install.

    you will still get the black screen with miezu on it, until you have upgrade/dated a couple of times.
    if you get stuck on the ubports recovery screen,and nothing is moving, go back to TWRP and wipe again ( not external sd, but everything else.
    you will need to unzip Stefano`s folder to use it

    I had mine on RR 5.8.5. for a while ,it was a struggle to get it to reinstall UB.

    i am playing with a BQM10fhd. and Pro5 TD-LTE 32g
    good luck

  • @Marathon2422 @Stefano I followed your tips, from the step needing the TWRP installation, and finally I have Ubports 15.04 on my Pro 5, hurray! Thank you very much! I also have the "Meizu powered by Ubuntu" splashscreen.
    Now, I would like to switch to Ubuntu 16.04 but I'm struggling with that and still I'm not succeeding. Here following what I did:

    1. Typed "sudo ubuntu-device-flash --server= touch
      --device=turbo --channel=ubports-touch/16.04/devel --bootstrap --wipe" from inside phablet-shell but it doesn't recognize the command ubuntu-device-flash: the output states 'command not found'.
    2. When I was on 15.04 stable I ran both the ubports-installer 0.1.12 and 0.1.13. Both didn't detect my Pro 5 so I went in manual mode and the result was the following (P.S. I tried to run both either in terminal with sudo or without sudo):
    • 0.1.13: it stops really soon with an error, without starting the pushing file step;
    • 0.1.12: it works, it goes pushing all the 13 of 13 files and then I got the 'Success' window; but, once rebooted the phone I step into this:
      rebooting the phone I'm still stuck in the 15.04 version.
    1. Then I switched to 15.04 Release Candidate. I used again both the ubports-installer 0.1.12 and 0.1.13 and here below the results:
    • 0.1.13: it detects the phone automatically now, but, once rebooted, it stucks on the splashscreen doing nothing, without achieving the pushing files step;
    • 0.1.12: it detects the phone automatically now, but, once rebooted, it stucks on the splashscreen doing nothing, without achieving the pushing files step.
    1. I tried the other command 'sudo system-image-cli -vvvv --switch ubports-touch/16.04/devel' to update from terminal within the phablet-shell and it seems to work until to get this:
      Now I'm out of ideas......any hint is always welcome 😜


    EDIT: I forgot to mention that I finally succeeded because I decided to try to change the USB cable with a brand new one nearly purchased and it worked like a charme! So, the message is: never trust USB cables!

  • @matteo Firstly, flash back TWRP recovery, make a TWRP backup of your current 15.04 to ExternalSD card, can copy to your PC as well.
    In order to flash anything you need to have ubuntu-device-flash installed. Try: sudo apt install ubuntu-device-flash

    In TWRP then wipe whole phone (NO ExternalSD)

    In order to flash the 15.04 or 16.04 with ubuntu -device-flash, you need to have ubuntu recovery flashed.
    Download it and flash it with fastboot.
    Reboot to recovery and type: sudo adb devices

    Should recognize the device.
    If not, try flash it again.
    Also try unplug the phone from PC and in terminal type:
    sudo adb kill-server
    sudo adb start-server

    Plug in the phone ( rebooted to recovery)
    sudo adb devices

    It should list the device in recovery.
    Yiu can proceed to flashing.

    The flashing will fail if there is not enough space in the cache partition (15.04)
    And will fail (probably) in 16.04 because Xenial image is larger and needs bigger cache partition.

    In that case just follow the guide to increase the size of cache partition on Pro 5.

  • @stefano I flashed TWRP,
    made backup of 15.04,
    moved it off of device,
    used TWRP,wiped device
    ,then flashed Stefano's copy/folder for UT 16.04.
    Then played for a while,
    then flashed recovery,( from the 15.04 folder),giving me working 16.04 that updates

  • @matteo Btw,
    There is a TWRP backup of 16.04 (Pro5 ) to play with if you wish.
    link text

  • @stefano thanks Stefano. I think I have the same problems than yours with the cache size; the guide to increase the size of cache is this, right? Well, me too I have this situation after a df -h:

    /dev/disk/by-partlabel/cache 496M 2,8M 483M 1% /android/cache

    And, after installing the ubuntu-device-flash the following command worked:

    sudo ubuntu-device-flash --server= touch --device=turbo --channel=ubports-touch/16.04/devel --bootstrap --wipe

    But it stalled after rebooting into the Ubuntu recovery, like you said in that post. I would like to proceed with the mihael procedure to resize the cache but it is not very straightforward... I'm not sure for example where to type the lines listed at the very beginning:

    mount /dev/block/sda41 /system
    mount -t proc proc /system/proc
    mount -t sysfs sys /system/sys
    mount -o bind /dev /system/dev
    chroot /system /bin/bash


  • @matteo follow this guide: link text

  • @stefano uuuuuuuu thanks, will do! I completely missed that!

  • @stefano
    very stressful for a retired truck driver like me .
    nearly tripped up on the name for 43 , got there in the end ,now i need a drink.
    maybe i need to buy you a drink Thanks Stefano.

    /dev/block/sda32 45568 50687 5120 20M Microsoft basic data
    /dev/block/sda33 50688 55807 5120 20M Microsoft basic data
    /dev/block/sda41 65536 720895 655360 2.5G Microsoft basic data
    /dev/block/sda42 720896 790000 69105 270M Microsoft basic data
    /dev/block/sda43 790016 1031167 241152 942M Microsoft basic data
    /dev/block/sda44 1031168 7633914 6602747 25.2G Microsoft basic data

  • @stefano UPDATE: I wiped the phone completely and the situation of my Pro5 partitions is the following:


    Now I'm stuck at the first step:

    mount /dev/block/sda41 /system -----------> OK!
    mount -t proc proc /system/proc -------------> ERROR!
    mount -t sysfs sys /system/sys -------------> ERROR!
    mount -o bind /dev /system/dev -------------> ERROR!


    BTW how to get rid of the tmpfs partitions, if possible? And why there are 2 partitions named sda44?

  • @matteo If you wiped the phone completely, you lost a tool to change the partitions. You'll need Gparted or flash back Ubuntu Touch and follow the guide. Ubuntu Touch itself is Linux distro and has a tool to do it within the system (fdisk)
    The partition you see are Android partitions as you formated with TWRP ( I presume)
    No need to remove tmpfs, actually I wouldn't touch it at all. Same for partition 44.

  • @stefano Right Stefano, I just realized....Actually I had to wipe it with TWRP because I tried to go back to 15.04 Stable channel but I got a big error at the end of the update and my phone just didn't boot anymore. I noticed I had some issue with the 15.04, for example the wi-fi lost the password at every boot.

  • @matteo one hint from @Marathon2422 ( I was doing that automatically)

    If there is trouble to have your phone recognize with adb, then reboot the phone to Ubuntu Touch and unplug it from PC. In terminal (on PC) type:
    sudo adb kill-server
    sudo adb start-server

    Plug in the phone, on the screen should appear a small window to allow adb usb debuggingusb, click on to allow.

    Your phone (curent installation of Ubuntu Touch will remeber your PC and will allow the adb usb debugging)

    Reboot again to recovery and try Ubports installer or ubuntu-device-flash

Log in to reply