Meizu Pro5 fastboot mode locked

  • @stefano I don't have any idea on how to flash the Meizu Original recovery starting from the files you uploaded, since it doesn't seem to be in the recovery folder an .img, would you please be so kind to give me any hint on how to proceed? I tryed to find on the internet the answer but without any luck, up to now. Thank you.

  • @matteo Download it from this site: link text is the file you're looking for. In TWRP flash the zip.
    I might have a look on my PC for recovery.img file when I get home.

  • @matteo here you go: FLYME RECOVERY

    Flash it with : sudo fastboot flash recovery recovery.img

  • Guys, below my latest attempts.
    I installed the latest Flyme Global version and the wi-fi worked good, remembering the credentials at each re-boot. However I had to install the older Flyme version with the unlocked OS, since this version seemed locked even extracting the recovery.img file as per Stefano suggestion. Also for this Flyme version the wi-fi worked as expected.
    Then, I flashed back TWRP in order to flash the UBPorts 15.04 OS OTA 1 following all the steps I knew already.
    The installation went flawlessly but I noticed the wi-fi losing the password at each re-boot and that the GPS wasn't working at all (checked against installation of SensorStatus and the weather default app).
    I then decided to update to OTA 3 to see if the behaviour was the same or not: same, wi-fi lost the password at every re-boot and GPS was just dead.
    After that, this time, instead than exploiting TWRP to flash the 16.04 image, I wanted to try a different route using the ubports-installer-0.1.12-beta-x86_64.AppImage installer; except for the manual initial triggering, then it worked great and I succeeded to flash the 16.04 OS.
    Now I have the 16.04 OS installed but still wonky: wi-fi doesn't keep the password and GPS is not working.
    I don't know what could be and why the behavior is so different from Flyme to UT but this is it.
    The only reason that comes to my mind is that I probably messed-up with the file system resizing in view of the 16.04 installation, but how? It's a pity because I really like the OS but in this condition it's just not possible for me to be used as a daily driver, not even with the 15.04 version 😞

  • @matteo When using android ~ did you get a wifi called "NVRAM error+ 10"
    It can be caused by using flash tool. and wiping / formating the nvram
    This happens with BQ devices.
    Is it possible you wiped yours thru TWRP. ???

    Can you restore from backups,everyone makes before installing Roms.


    This guy has a lot of pro5 files linked from here
    Just put the http in

  • @matteo That's strange, I never had a problem with wifi, nor gps on 15.04.
    Regarding the Flyme Global, if you unpack the and remove the file called ''bootloader'' , repack the files to '''' again , you'll get the Flyme update zip, that don't need the unlocking the bootloader again. Also you can always wipe the phone with TWRP and flash the with it as well. I just thought that original Flyme recovery might do a better job to properly wipe and upgrade the phone base.
    Maybe there are some other Pro 5 users that could help as I'm unable to help in this case.

  • @matteo I don't know if this will help but there is a method to update just the baseband on a Pro5.
    Update Meizu Pro 5 Baseband

  • @matteo Duknow ab the GPS side but the Wifi connections are apparently stored in files at /etc/NetworkManager/system-connections/<AP Name>

    Check if this accessible and writable:
    drwxr-xr-x 2 root root 4096 May 27 16:36 system-connections

    It looks like mounted to userdata somehow:
    phablet@ubuntu-phablet:/etc/NetworkManager/system-connections$ df -h .
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk/by-partlabel/userdata 54G 32G 22G 59% /etc/NetworkManager/system-connections

  • I am curious
    I am using pro5 16.04 as a daily driver,( i am retired,so just playing really), I find that i get a wifi password screen on top of the,login screen, all i do is cancel the Wifi screen, then login. If my wifi does not login,( and i will be using cell data) i pull up the wifi screen,and press once on my wifi,and it signs me in.

    ( without reentering my password).

    I am not aware that Gps,is working yet,

    Any similarities ???

  • @marathon2422 I didn't notice that wrong wi-fi name when I was on Flyme, no. However, also the GPS seems wrong. I followed all the steps to resize the file system and I didn't get any error. Thanks for the link, I'll have a look at it!

  • @halucigenia thank you for the link. Reading that post updating the baseband it seems didn't improve the connectivity though. Anyway, I also have issue with the GPS which seems dead.

  • @tera tera this is the screen-shot after following what you suggested:


    As you can see the AP Name "FASTWEB-1-AB8961" is written there, but the issue is that when the system reboots, it doesn't read automatically from there, so I always have to re-assign the password in order to make it work and a new AP Name is filed with the name for instance "FASTWEB-1-AB8961-1"; after an other re-boot, if I insert again the password I will get a new "FASTWEB-1-AB8961-2" and so on.
    I read in the Update Meizu Pro 5 Baseband that you said the Pro5 is not usable as a daily driver. May I ask you why so? Did you have same experience with the wi-fi? And what about the GPS? Does it properly work for you?

  • Hi @matteo

    After reboot, do you see "FASTWEB-1-AB8961" in the Previous Networks?

    Just made a quick test, removing a file from /etc/NetworkManager/system-connections and after Reboot, the matching AP disappeared from the Previous Networks on mine.

    Also, check the content of the file, it carries your wireless details.

    So it would look like either your NetworkManager is reading files from somewhere else but still store it there... not sure how to help/investigate more on my end.

    About my comment on Pro5, i travel a lot for my job and unfortunately not able to rely on the Pro5 to get a strong 4G signal, even sometimes simply to make calls.
    I have now switched to a Fairphone2 for data/phone calls, but still use my Pro5 connected via Hotspot for GPS and other activities.

    Hope that helps,

  • @tera I confirm all the connectivity data regarding the "FASTWEB-1-AB8961" are correctly stored there, but it doesn't seem the phone actually read it after a re-boot. Thanks anyways.

  • @matteo Maybe nmcli can provide you further clues, try commands like:
    nmcli connection show
    nmcli connection reload

  • @tera I got this error:

    I also tried other commands and for instance the wi-fi AP seems to be set in auto-connection mode, even if doesn't work:


  • @matteo Try with sudo, just confirmed on FP2.

  • @tera nope, also with sudo it throws me errors....maybe, I was thinking I could try to flash the Canonical Ubuntu Touch version and then switch to UBPorts and see what you guys by the chance have the Canonical image to be flashed? Any OTA up to 15 would be good, I guess. Thank you.

  • @matteo

    ubuntu-device-flash touch --device=turbo --channel=ubuntu-touch/stable/meizu-pd.en

  • This post is deleted!

Log in to reply