Right combination of sources for Fairphone 2



  • Hi,

    for quite some time now I try to compile UBPorts for the Fairphone 2, but I don't seem to be smart enought ;-)

    There were some syncing errors last days, probably related to server problems at Ubuntu's, but this seemed to work now.

    Here's what I did:

    1. Sync the UBP-Repo as described here: https://wiki.ubports.com/wiki/Building-ubports-source
    2. Clone the Fairphone Device-Description from https://github.com/ubports/android_device_fairphone_fp2.git into device/fairphone-devices7FP2

    So far, so good. What's obviously missing now is the kernel. The sources search for a kernel in kernel/fairphone - I tried with the "official" kernel from the Fairphone Open-Source project at code.fairphone.com, also including the Binary-Blobs from the same site (I put them into vendor/).

    After starting make, it complains about some missing components in device/qcom/common - which are in ubport's git-repo at https://github.com/ubports/android_device_qcom_common.git - but not at the "original" CM-Repo at http://github.com/CyanogenMod/android_device_qcom_common (where this folder is loaded from by Manifest.xml). Make now get's one step further and complains about a missing "dtbToolCM" - which is at the CM-Repo but not at UBPorts'. Ok - annother copy and paste? I gues I took the wrong road quite some time ago now...

    Anyway, compilation seems to work itself through the kernel now, atleast I have a file named "kernel" with about 7MB in "out". Now it's stuck at the shared libraries - I could again try to find some suitable replacement, maybe at code.fairphone.com - however I think I should start over and take the "right" kernel/device/qcom-data etc.
    Somewhere deep in the makefiles theres a statement about the "MSM" kernel - so I also tried with https://github.com/ubports/android_kernel_oneplus_msm8974.git renamed to "fairphone", also no chance of course ;-)

    Does someone around here happen to know which route to follow?

    Thank you very much,

    Alex (21347)

    EDIT: I forgott to mention the exact error, it's: make: *** No rule to make target '/home/alex/phablet/out/target/product/FP2/obj/SHARED_LIBRARIES/libcurl_intermediates/export_includes', needed by '/home/alex/phablet/out/target/product/FP2/obj/EXECUTABLES/hs20-osu-client_intermediates/import_includes'. Stop.

    I did now checkout curl from http://code.fairphone.com/gerrit/fp2-dev/platform/external/curl, I'll see where it ends...

    EDIT 2: Ok, after copying curl and libxml from code.fairphone.com and adding the paths to build/core/main.mk they get compiled, now I have qmi.h missing; there's really something wrong here...



  • Citing sources from Trello; it looks like the team dropped it in Nov, last year \ by @dholbach.



  • @below-freezing said in Right combination of sources for Fairphone 2:

    Citing sources from Trello; it looks like the team dropped it in Nov, last year \ by @dholbach.

    But that citation refers to Canonical dropping an effort to port to FP2. The previous poster is talking about the ubports effort. Marius is still showing off the phone.



  • @doniks said in Right combination of sources for Fairphone 2:

    But that citation refers to Canonical dropping an effort to port to FP2. The previous poster is talking about the ubports effort.

    Correct - however, with support from Canonical or not, the point where I got stuck, I think, is way before a point where one should talk about "supported" or "not supported" - I guess (and it's really only a guess), that the complaints about "qmi.h" are more likely to point to a wrongly setup build environment (to my limited knowledge, this is part of the kernel, and should be created or symlinked to when building it succeeds).

    Missing libraries may point to a wrongly setup build path, too - or problems with the repo (wrong version / source / tag / server-error whatsoever).

    Flashing the image provided by Marius works, Ubuntu boots up and appears to be quite stable at it's current state, although it's of course not complete. I, however, failed to reproduce even that image, and that's probably not linked to support from canonical. If I have some spare time the next days, I can provide a kind of "log" I wrote when setting up my environment, if it is of any use...



  • This post is deleted!


  • @21347 Hi, I deleted my former post because it was out of the topic.

    Regarding your qmi.h issue it seems to come from hardware/qcom/wlan being a different version from fairphone's one. I am trying to get a successful build without resorting to copy-paste (apart from the binary bundle I download from code.fairphone.com) so I modified my .repo/manifests/default.xml to remove the default hardware/qcom/wlan line and replace it by the one you can find in the Fairphone Open Source release. It's still building (and will be for a while) but I am pretty sure I am past the part where it used to block !

    If you want to pm me on FP's official forum so we can coordinate and avoid duplicating efforts, my handle is Arvil (with Batman on LSD as my Avatar ;) )

    EDIT : It actually goes forward until I reach an issue with hardware/qcom/audio-caf, I'm still figuring it out

    EDIT 2 : I removed audio-caf from the manifest and...

    #### make completed successfully (01:03:35 (hh:mm:ss)) ####
    
    arvil@michel:~/fp2-ut/phablet$
    

    YESS ! Now I have to try it, I'll put the manifest in a git repo soon


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.