UBports installer on OnePlus One



  • I am trying to use the installer to install UT on my OnePlus One but I am having troubles doing so. I am using a Mac running High Sierra with the UBports installer 0.1.12. I start the installer and it detects my phone, I have tried all the options: wipe, no wire, stable, dev. I then click the install it reboots my phone into fastboot while at the same time asks me the admin password. When I enter my password the installer says to connect my device to the USB and that is where I am stuck.
    I have check devices to see if the system sees the phone and I do see a android device connected to the USB but the installer doesn't see it. I am able to use adb and I have ran fastboot oem unlock. Any help would be appreciated.

    Thanks



  • I figured it out, i needed to put the Android studio files in the system path. In the terminal I had to add a path to the adb file so I ran the command export PATH=$PATH:/Users/~/Library/Android/sdk/platform-tools . The ~ is whatever your username is. Then I launched the installer and like magic it worked.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.