NVRAM ERROR X 10 or. Device not remembering WiFi password

  • I think i spoke too soon .
    I am back to manually putting in my password again

  • I used TWRP 3.2.1. And WI_FI_Fix files from XDA,
    With UBports installed,I flashed TWRP with MTK sp flash tool.
    I deleted the WI Fi and WI FI custom folders and replaced them
    With the downloaded ones.
    Seems to be working so far,( about five reboots or so)
    No need for root this way,a pain via android.
    Hope it stays like this yippeeeeee

    Well I celebrated too soon !!
    I reflashed , 16.04 dev ,with wipe,to remove TWRP,and start fresh.
    Well that messed up my wifi, again.
    So,I reflashed twrp,fixed the NVRAM (Wifi /wifi custom files).
    Checked it. (then made a twrp backup,moving it to a safe place).
    then flashed ubports recovery with TWRP
    So I have, 16.04 2018-07-05 with working wifi now,
    I will have to see if it will keep working thru updates.

  • @doniks
    This where I got the wifi_fix files, just that and TWRP ,I did not go back to android,to do it, because of the root problem,with m10fhd.
    Not familiar with your device though.

  • @Marathon2422 so on testing does your WiFi seem to be persistent even across changing images? Have you tried this on a device with a SIM card e.g. the Pro 5?

  • @tartanspartan
    i am losing my wifi fix ,if i reflash wipe or no wipe, and updates ,i get stuck at recovery.
    i think its a file read/write , problem
    but why does UB change it / or remove the fix

  • I had my m10 fhd on 16.04 dev version with TWRP and,wi-fi -fix installed and working.
    I tried to install the latest update,by install,from updates page. It rebooted to TWRP. and did not install
    ( as I expected ).
    So I did a no wipe install 16.04 dev with ubports, it hung after the UT spinning wheels,
    The installer was still downloading files,so I rebooted,expecting to get TWRP, but the UT recovery screen came on,and I left it to finish pushing files.
    well it completed the install, and since then,I have been able to shut the device off and on and still keep a working WIFI
    I did some research on NVRAM fixes, and it is expected if you replace the wifi,and wifi custom files in nvram,you will have to redo it,every ota update or flash of a rom
    If you know to keep a copy of you nvram.bin. You can reflash it with the mtk tool, and it supposed to be a permanent fix.
    Its a good job I am retired and use a lot of spare time for this

  • Progress report
    Updated to Dev version 116
    And my wifi is still doing a great job,just doing what it is supposed to do.

    This makes using the device so much more pleasant.
    ( not reentering the password all the time ).

  • @marathon2422 would be cool if you could provide a step by step (commands that need to be entered on terminal) instruction here...(?) So that its closest possible to just doing copy and paste and others, also less experienced users can profit from your findings...

  • @hummlbach Just to let you know i have seen this.

  • FWIW, this thread http://www.android.gs/backuprestore-imei-and-nvram-on-any-android-device/ explains a liiittle bit about nvram, so now my theory is that while the "error X 10" is a mediatek-ism, we might have related problems about this nvram not being right. That doesn't give me a solution, but, uhm, not sure what it gives me 🙂

    Also, not sure this is related, but for years I have an expired sim card in it and the device has seen long (months) periods of flight mode and/or never powered on.

    EDIT: Seems, lots of xda and similar sites talk about nvram in relation to IMEI being zero (invalid/forgotten). Mine seems to be ok (at least not zero). How about you? You can see it in settings. Do NOT post you IMEI! Seemingly this is some super secret unique identifier for your device.

  • well i tried to use my m10 ,and ,nothing hapens ,i tried leaving it on charge overnight ,but no ,no a thing, I tried connecting to flash_tool ,all i get is noises plugging in or out ,to show connecting.
    it does not show any emmc settings.
    i checked on the BQ forum ,and this has happened mostley to those that have had 2.6.2 in their devices.
    I somehow got on the spanish Amazon site,and they show a 32g m10fh with 4g at 217 euros.

  • wow I am back again.
    I decided to go in and disconnect the batteries ( fully charged),check them and try the flash_tool.
    It took old Ubuntu Touch no hesitation,but nearly 12 minutes to flash it, nerve wracking.
    It rebooted like nothing ever happened.
    Now to get it back like it was

Log in to reply