Ubuntu Touch on Sony Xperia X



  • @gmelchett Have you tried wiping data, cache and system partitions? Make sure to create a backup before wiping those partitions and flashing the Ubuntu Touch port.



  • @beidl Thanks for a quick reply. No, I didn't wipe data, cache and system partitions.

    I've done that now from twrp, but there seems to be no mobile-side adb running when in twrp. And because I did wiping system, I have no Android to boot.
    Any idea how to progress?



  • @gmelchett could be you're missing udev rules on your Linux host to establish an adb connection. If you're on Ubuntu 18.04 you could try the following command:

    sudo apt install android-sdk-platform-tools-common

    Else I could publish a much bigger version of the udev rules file in a GitHub gist.

    EDIT: on the other hand, adb wouldn't even be able to respond with a "permission denied" error in case the device-side adb daemon wasn't up and running.



  • @beidl adb was running just fine when I tried halium-install before wiping system + data + cache. I tested with adb shell. (Then I couldn't even ls /data without getting permission denied.) On second though, why is halium-install pushing files to /data and not
    /storage/0/emulated (or what the "internal sd" card path's is.)?

    A wild guess is that the system.img that halium-install creates is the provided system.img + the .tar.gz file. Maybe that could be fastboot flash'ed into system? But then, where would rootfs.img go? Hmm.

    I don't know android's file system layout good enough. Have to do some reading up.



  • Success at last! It is apparently very import to unlock at "latest android". I unlocked at Android 6.
    I installed twrp like this:

    sudo fastboot flash boot boot.img
    

    It will then always boot into twrp, but I didn't manage to flashing it to the recovery area to work.
    Once booted into twrp, I had to format system, data & cache since the phone got encrypted by default.

    Btw, ip configurtion from console:

    sudo ip addr add 10.15.19.1/24 dev -your device- 
    

    For those of us that don't have a fancy GUI to help you with.

    ubports on xperia x feels a bit sluggish compared to the nexus 5. A look at top, shows that unity8 consumes quite a lot of cpu when doing some ui interaction. I suspect no hw acceleration enabled?

    edit: Some language corrections.



  • I've been playing around from time to time with Ubuntu Touch on the Xperia X. Over all it works very well, but a few things that are not really working (and not mentioned not to work above):

    • Vibrator
    • GPS
    • Of the sensors, only accelerometer works
    • A fully charged battery is reported to be at 67%.
    • After pressing the power, it takes a few seconds before I can unlock it. Maybe related to the lack of graphic hw acceleration?


  • @beidl Sir any update on ut on xperia X



  • Hi any progress...


  • Community

    @Hsabun, volunteer developers will post their progress on their own terms. Asking for updates may be seen as impolite. Please have patience and we will get there eventually. :)



  • Sorry, i won't be asking again.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.