How to go back to OTA-3?



  • @advocatux said in How to go back to OTA-3?:

    @jezek I've found that tool built for your OS 🙂

    https://repo.ubports.com/pool/bionic/main/g/goget-ubuntu-touch/ubuntu-device-flash_0.35+ubports+0~20181003134221.2~1.gbp4044a0_amd64.deb

    $ sudo dpkg -i ubuntu-device-flash_0.35+ubports+0_20181003134221.2_1.gbp4044a0_amd64.deb 
    [sudo] password for jezek: 
    (Reading database ... 356801 files and directories currently installed.)
    Preparing to unpack ubuntu-device-flash_0.35+ubports+0_20181003134221.2_1.gbp4044a0_amd64.deb ...
    Unpacking ubuntu-device-flash (0.35+ubports+0~20181003134221.2~1.gbp4044a0) over (0.34-0ubuntu1) ...
    dpkg: dependency problems prevent configuration of ubuntu-device-flash:
     ubuntu-device-flash depends on click-ubuntu-policy; however:
      Package click-ubuntu-policy is not installed.
     ubuntu-device-flash depends on debsig-verify; however:
      Package debsig-verify is not installed.
     ubuntu-device-flash depends on kpartx; however:
      Package kpartx is not installed.
     ubuntu-device-flash depends on qemu-user-static; however:
      Package qemu-user-static is not installed.
    
    dpkg: error processing package ubuntu-device-flash (--install):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
    Errors were encountered while processing:
     ubuntu-device-flash
    

    I have to sort out the dependency stuff somehow... anyway thank you



  • @jezek you're welcome. I'm pinging Rodney now, he built that package and he knows the solution for sure 🙂



  • @advocatux it won't install on mine 18.04, it shows installing, shows 100 %, and then nothing. How's that?



  • @jezek You should be able to run sudo apt-get -f install after manually installing a package with dpkg, to resolve the dependencies. If any are uninstallable though, I think it will just remove the package you were trying to install. I'm not sure if all of those dependencies are available in Ubuntu 18.04 though.

    All I did was fix the build so goget-ubuntu-touch would build on bionic. If it's not working/installing, feel free to open an issue or two on https://github.com/ubports/goget-ubuntu-touch about it.



  • Meantime I tried to downgrade via ubports-installer
    Selected 15.04/stable, choose wipe option (for sure) and followed the instructions... result was, that 16.04/stable was installed...

    To summarize: It is NOT possible to downgrade to 15.04 either with ubports-installer, nor with system-image-cli. And on 18.04 I failed to install ubuntu-device-flash tool, so there is no way to downgrade to me for now.

    I will not accept defeat, will try again. Any suggestions?

    Btw, the phone is FP2.



  • @lyovushka Please, help me. How did you hack the ubports-installer to install 15.04/stable - OTA3?



  • @dobey How did you build the goget-ubuntu-touch

    I have tried to clone the repository and followed the README.md, but it was a dead end.

    Then I used the go get -v -u github.com/ubports/goget-ubuntu-touch/ubuntu-device-flash command... result

    github.com/ubports/goget-ubuntu-touch (download)
    github.com/jessevdk/go-flags (download)
    Fetching https://launchpad.net/goget-ubuntu-touch/devices?go-get=1
    Parsing meta tags from https://launchpad.net/goget-ubuntu-touch/devices?go-get=1 (status code 404)
    launchpad.net/goget-ubuntu-touch (download)
    go: missing Bazaar command. See https://golang.org/s/gogetcmd
    package launchpad.net/goget-ubuntu-touch/devices: exec: "bzr": executable file not found in $PATH
    Fetching https://launchpad.net/goget-ubuntu-touch/diskimage?go-get=1
    Parsing meta tags from https://launchpad.net/goget-ubuntu-touch/diskimage?go-get=1 (status code 404)
    package launchpad.net/goget-ubuntu-touch/diskimage: cannot find package "launchpad.net/goget-ubuntu-touch/diskimage" in any of:
    	/usr/local/go/src/launchpad.net/goget-ubuntu-touch/diskimage (from $GOROOT)
    	/home/jezek/.go/src/launchpad.net/goget-ubuntu-touch/diskimage (from $GOPATH)
    Fetching https://launchpad.net/goget-ubuntu-touch/sysutils?go-get=1
    Parsing meta tags from https://launchpad.net/goget-ubuntu-touch/sysutils?go-get=1 (status code 404)
    package launchpad.net/goget-ubuntu-touch/sysutils: cannot find package "launchpad.net/goget-ubuntu-touch/sysutils" in any of:
    	/usr/local/go/src/launchpad.net/goget-ubuntu-touch/sysutils (from $GOROOT)
    	/home/jezek/.go/src/launchpad.net/goget-ubuntu-touch/sysutils (from $GOPATH)
    Fetching https://launchpad.net/goget-ubuntu-touch/ubuntuimage?go-get=1
    Parsing meta tags from https://launchpad.net/goget-ubuntu-touch/ubuntuimage?go-get=1 (status code 404)
    package launchpad.net/goget-ubuntu-touch/ubuntuimage: cannot find package "launchpad.net/goget-ubuntu-touch/ubuntuimage" in any of:
    	/usr/local/go/src/launchpad.net/goget-ubuntu-touch/ubuntuimage (from $GOROOT)
    	/home/jezek/.go/src/launchpad.net/goget-ubuntu-touch/ubuntuimage (from $GOPATH)
    

    so I have fixed all imports in .go files from launchpad.net to github.com/ubports and managed to build the ubuntu-image-flash binary and ran it. But with no success:

    $ ubuntu-device-flash --server=http://system-image.ubports.com touch --device=FP2 --channel=15.04/stable --revision=3
    Unknown command `ubuntu-device-flash'. Please specify one command of: core, personal, query or touch
    

    any suggetions?



  • I just tweaked a few things to get the debian package building in CI. I didn't actually build it locally.

    I didn't run it either. I just presumed if it built, it would work.

    You can however, grab the ubuntu-device-flash package from the official Ubuntu 16.04 repositories, and it does indeed run and work on 18.04. I'm not sure why the build in the ubports repo would not work. It seems there may be some additional issues there.



  • I will not accept defeat, will try again. Any suggestions?

    @jezek my suggestion still is: use a live usb stick running xenial & the necessary tools 🙂



  • So, after I dug out my old netbook from the dust of my stash shelf, which was already equipped with lubuntu 14.04, I successfully installed ubuntu-device-flash utility via apt package manager, and used the utility to downgrade to 15.04.

    Wish, this can be this easy on bionic (18.04).

    I will look into the ubuntu-device-flash utility on ubports github and try to make it work.


Log in to reply