App crash after splashscreen

  • This is my code

    What's wrong?
    Help please!

  • Hi @Giampy,
    if you haven't already done try to:

    • check apparmor file of you App, it should contains the "webview" permission (maybe with the new Morph.Web have a different name) to allow at the App to connect with a URL (
    • if you are running on a device Install logViewer App from Openstore to see log messages of your app
    • check if policy version in apparmor file are correct for your target Ubports version (xenial, vivid)
    • check manifest file of you app if "framework" entry is correct for Ubports version (xenial, vivid)

    Hope are useful suggestions

  • @fulvio Thanks,
    I made the clickable template with last release and after I insert the code. First without the qtwebengine API with the normal code that I used for others app and after with new code with qtwebengine API. Apparmor and manifest are correct, only I have to try the logViewer on the phone.

  • I tried the app on my pc desktop with clickable and this is the result:
    Command '['docker', 'run', '-v', '
    /home/giampy/AppUbuntuTouch/virginradio:/home/giampy/AppUbuntuTouch/virginradio', '-v', '
    /tmp/.X11-unix:/tmp/.X11-unix', '-v', '/tmp/.docker.xauth:/tmp/.docker.xauth', '-v', '
    /tmp/clickable/share:/tmp/.local/share', '-v', '
    /tmp/clickable/cacge:/tmp/.cache', '-v', '
    /tmp/clickable/config:/tmp/.config', '-e', 'XAUTHORITY=/tmp/.docker.xauth', '-e', 'DISPLAY=:0', '-e', '
    QML2_IMPORT_PATH=/home/giampy/AppUbuntuTouch/virginradio/build/tmp/lib/x86_64-linux-gnu:/home/giampy/AppUbuntuTouch/virginradio/build/tmp/lib:/usr/local/nvidia/lib:/usr/local/nvidia/lib64', '-e', '
    LD_LIBRARY_PATH=/home/giampy/AppUbuntuTouch/virginradio/build/tmp/lib/x86_64-linux-gnu:/home/giampy/AppUbuntuTouch/virginradio/build/tmp/lib:/usr/local/nvidia/lib:/usr/local/nvidia/lib64', '-e', '
    PATH=/usr/local/nvidia/bin:/bin:/usr/bin:/home/giampy/AppUbuntuTouch/virginradio/build/tmp/bin:/home/giampy/AppUbuntuTouch/virginradio/build/tmp/lib/x86_64-linux-gnu/bin:/home/giampy/AppUbuntuTouch/virginradio/build/tmp', '-e', '
    HOME=/tmp', '-e', 'OXIDE_NO_SANDBOX=1', '-w', '
    /home/giampy/AppUbuntuTouch/virginradio/build/tmp', '-u', '1000', '--rm', '-i', 'clickable/ubuntu-sdk:16.04-amd64', 'bash', '-c', 'qmlscene qml/Main.qml']' returned non-zero exit status 255.

    What does it made OXIDE_NO_SANDBOX?

    The problem is the header at the line 29, it must be delete. The webapp crash on the nexus5 because there is a bug in UT. Someone solved forcing full screen and disable the gpu but I think it is a bad solution. The command lines from 34 to 42 can be delete, they run only with oxide. After this operations, all run correcly on the pc desktop!

Log in to reply