Network Access problem in new native App

  • Hi there !
    I am currently developing a new app for ubuntu touch.
    It's a native app for retrieving password from the passman app of a nextcloud server.
    The app is still at the very beginnng but on my desktop, using clickable desktop build, the connection to the server works.
    When testing on my N5 phone I have an "Unable to resolve host" from the QNetworkReply in the c++ interface.
    First I though it was a DNS problem, so I tried with the IP. And then I got an Unknow error code from the QNetworkAccessManager.
    Is there a permission to set somewhere or what can possibly go wrong ? On my desktop it's working !
    You can find my git repository at
    Thanks in advance for your time and help !

  • Hey, I sent you a pull request with a fix. Then it should work. 🙂

    The problem is that you need the policy group "networking" but you had "network". To make it work you need to fully wipe the existing app on your phone with UT tweak tool and rebuild it with clickable. 😃 Have fun finishing your great project!

  • Thanks so much ! I'll try this asap.
    I have an other question. I have to link against libcrypto to get the sha256 etc... functions for the decryption process.
    How can I do that ? When I run clickable desktop, the app runs but at the moment to execute openssl functions, it crashes with the undefined symbol error.
    I understand the problem but don't know how to solve it.
    Any clue ?
    More generally, how to use external -yet common- libraries ?
    Thanks very much for your time and help !

  • @krille Your patch works perfectly well !

  • I think you need to add the dependencies in the clickable.json file. But I'm not 100% sure. It should look like this:

    "template": "cmake",
    "kill": "qmlscene",
    "dependencies": [

  • Indeed, something like that may work.
    The one you proposed cannot be found by apt.
    I tried libssl ans some variations but still the same issue.
    Is there a way to "log in" the docker container and run a apt search or find out if the package is availbale ?
    I feel like I'm walking in the dark ^^

    I googled in ubuntu packages to explore libssl/crypto names but without success.
    Exploring other apps, like terminal or gallery-app, I noticed that in dependencies they put the -dev pacakge.
    I tried libssl-dev with no luck. And libcrypto is part of libssl

  • Hey, how is this progressing? For me a native nextcloud passwords app would be very useful, so I'm looking forward for your app 🙂

Log in to reply