Port to Oneplus 2



  • @UniSuperBox disabled exfat now... couldnt get it compiled, at all
    Otherwise i had... atleast it felt like 1000 other errors in mainly the ipv4 and ipv6 files... with the uid and kuid stuff, got that fixed now and managed a successful build with building and building after error and fixing. Making a clean build now to make sure, and then lets see what happens, hopefully it will atleast do "a bit" more than earlier xD



  • So.. everything compiled, no error, flashed everything, now i just see the "wonderful" logo which comes before the boot animation for like... idk 10 min now. Phone gets kinda warm though, but i dont have access via USB.
    Is it normal that the first boot takes a while (even this long)?

    Aborted it though now... saw that it created a few folders in /data, user-data, system-data, android-data and i tried to push the modified adbd from the official guide which appearantly should start the adbd process before GUI is able to run. Didnt work 😕

    so... is it doing something during this process, or (which i kinda believe) did it fuck up somewhere... but atleast it doesnt instantly reboot anymore, which is good i guess xD

    The recovery created "boots", but without any GUI, just a black screen, but adb is running there



  • @SGCMarkus Awesome! You're exactly where I was with the Nexus 5X. There's something wrong with initializing the Android layer, and it seems that dbus is failing as well. Maybe @Flohack would be able to answer what to do from here?



  • Also noticed that the recovery cant mount any of the partitions, as it searches for /dev/block/bootdevice/by-name/ but thats not existing in the recovery it built. Dont know if thats on purpose or not?

    But its "good to know" that im not the only one having this problem xD


  • Infrastructure

    @SGCMarkus welcome to porting hell. We all came this way, sometimes there are solutions, sometimes not. Im on a business trip, reply to you soon. You need to boot, wait fir your warm devuce, boot recovery and try to get /proc/last_kmsg somehow. And plz use pastebin for it, not the forum



  • Cant get a /proc/last_kmsg 😕 doesnt exist ... i guess i gotta find a way to enable it?

    otherwise, i have the kmsg from the recovery, if helpful: link

    have fun/good luck on your business trip though ^^ i gotta survive 5 exams next week xD



  • @SGCMarkus

    You might want to try the information in this wiki article: https://wiki.ubports.com/wiki/How-to-work-around-missing-ADB-functionality



  • @UniSuperBox thanks, will try that too 🙂
    had no time the past few days, exams ^^ 2 left, but those are rather small so i have more time now 😄

    have a few other ideas too that i wanna check, like https://developer.ubuntu.com/en/phone/devices/porting-new-device/ at debugging, appearantly i can set break points, and it should start adb then, if it "breaks" (hopefully) and some other things a friend of mine (hes good with linux in general) told me

    will update here when im done with testing ^^



  • Nice to see someone working on OP2.
    I know Ubuntu Touch does not support MultiRom officially, but now we have it on XDA with kexec workaround!!



  • @Maxximo88 know that, already running on my phone 😛
    kernel does the same thing with and without multirom injection though (after i select the rom to boot, aka ubuntu)

    But, i just remember now, i can save a Kernel Log in Multirom... but i doubt it will give me anything important at that stage yet 😕



  • @UniSuperBox are the 16.04 and/or the 17.04 builds of ubuntu touch "stable" (or atleast do they boot on already working devices)?
    And do you know where the LXC container will be started? Maybe an architecture problem, like an incompatibility between the 64 bit kernel/android image, and the 32 bit vivid image (which i used so far).
    Friend of mine meant it could work with modifying the parameters how the LXC container gets created, if its a architecture problem (and im currently downloading both xenial and zesty builds)



  • @SGCMarkus Those builds are not stable. I'd recommend using the 15.04 rootfs.



  • @UniSuperBox

    found https://hastebin.com/wegibubuqu.go this today in the lxc config of the 15.04 rootfs, if i understand that correctly, it tries to load the LXC container, which is ARM64 for the Oneplus 2, as a armhf, which ofcourse doesnt work... maybe thats the problem? (or one of those)



  • @SGCMarkus It's possible that it's the problem, but I'm not really sure how you'd fix it. ADB not starting would indicate a much different problem, in any case.



  • im back from the "dead" 🙂
    didnt have that much free time, but now i can work on it again lol
    have set up a "new" machine, this time ubuntu native installed on my PC, instead of running in a VM (instead of ~45min build time its only 16 min now 😄 )

    Also noticed a few updates in the wiki, for example how to build for bullhead, and it says to use the Yakkety image, instead of the Vivid one. Does anyone have that backed up somewhere, everything i find about the Yakkety image is down, either sents me to Zesty (and idk how stable that one is). Or should i (try to use) Xenial?

    Or maybe theres "in general" any news on this whole topic that i migth have missed?



  • Hi why not use hybris for the port? you can fork my sources for adapted kernel

    https://wiki.ubports.com/wiki/Building-libhybris

    You can find my sources here:
    https://github.com/nyl



  • @SGCMarkus Welcome back!

    You've missed a lot since you were last here. And by a lot, I mean a lot. Canonical dropped Ubuntu Touch about two months ago and we have taken over the OS. If you'd like a quick summary of what's happened since then, you might want to check out the blog starting on April 8th.



  • damn, its been a looong time since i was last here, had more to do than i thought i had.

    But.. Im back at working on this 🙂
    I switched to the Halium 7.1 base atm, as I saw someone got it running for the Nexus 7.
    I can say, it fully compiles without errors. The recovery hybris-boot image (bootmode=debug) works too, i have access via telnet, but otherwise... it just reboot after i think it tries to load something... cant say that, dont have a last_kmsg... for some reason thats nowhere found, on any ROM I've tried so far.

    @nyl sorry for the late reply about this (also saw your SailfishOS project on xda a while ago).
    I tried to follow those instructions for the libhybris. Appearantly the autogen script works without problems, but afterwards the instructions say i should run make in that folder, but make says theres nothing for it to do.



  • I managed to create a Ubuntu Zesty rootfs (actually supported arm64 instead of xenial), and now im having a really really weird behavior

    if i flash the hybris-boot.img i get this in the console

    markus@markus-pc:~$ lsusb -vd 0fce: | grep -i serial
    iSerial 3 1ee3fc01

    but, also sometimes a "charging ??/100" flashes up on the screen (rest is always black), and sometimes the LED starts to light green.
    The USB Tethering seems to not fire up completly though, atleast i dont get any connection via anything to it.
    The debug mode works still though.



  • could be permissions related issue on the compiled files


Log in to reply