How to install desktop apps for convergence use case?



  • I have sucessfully created a container for desktop apps and deployed libre office. How can I find available packeges for desktop apps, that are prepared for UBports? My intention is, to install professional apps for productivity. It would be grat to have an IDE for UBports like Qt Creator right on my UBports device to simplify developement. I would have everything together and could just connect my mobile device to a screen and keyboard in the office or a device like Mirabook and Superbook while traveling.



  • You should be able to install any of the available "software center" type apps to get a full list of what is available to install. For example, installing gnome-software will let you use that tool to find apps to install.



  • @dobey Thanks for the recommendation. I have installed gnome-center successfully and the icon appears in the app scope for desktop apps. Unfortunately I can't open the app. I'm afraid it is not compatible with UBports. Does someone kow another app store app?



  • I played around wiht package names and guessed "software-center" as a package name for the Ubuntu app store after installing "gnome-software" is not shown up in the app scope.

    The software center seems to be installed and appears in the app scope of my desktop app container. Unforunately the app crashes after startup. Just the startup sceen is shown as you can see in the screenhsot.

    0_1545312982973_20181220_142431_1.jpg

    Has someone successfully installed any app store?



  • Unfortunately both the standard Ubuntu Software Center and Synaptic package managers will not launch in UT via Libertine - however lubuntu-software-center DOES work, even if it is still a little clunky on the phone.



  • @totalsonic Thanks for your suggestion. I can confirm, htat I was able to install lubuntu-software-center.

    Next I tested to install a .deb package, that I have downloaded to evaluate the use case of using the UBports device for my daily produtvie work. In my case, it would be installing an IDE for UBports. I have downloaded the .deb pacjage of Atom and selected this package within my container for desktop apps. Unfortunately nothing hapeens after selecting the said package.

    Does soneone know, which software is supported and not? I expected, that software, that runs on Ubuntu is also runnung on UBports.

    What if I need to install additional libraries and system features like clickable for a working IDE for UBports? I think I can't install them on the system level with adb shell, because the desktop apps are running in a container and have no access to the resources outside of that container, right?



  • Does Atom provide an armhf build for download? Or only x86? You cannot install the i386 or amd64 build on the phone. Also, I think Electron based apps will not work well, as Chromium does not work well under libertine and Xmir, even if you could get it installed.

    As for clickable, surely you can install it, but you may not be able to use it, as I'm not sure if docker would work well on the phone (or in the libertine container), and clickable requires working docker.



  • @dobey Yes, I hae downloaded the arm package. Any alternative for an IDE. Maybe the old Ubuntu skd? I was neither able to install the old sdk on Unbunmtu 16.04 nor on Ubuntu 16.10.



  • @dobey How can I install a package like clickable in the container? I think the container has its own system environment. I think I have to call the following commands:

    adb shell
    libertine-container-manager exec -i CONTAINER-IDENTIFIER -c "/bin/bash"
    

    Then i can use the commands for installing clickable:

    pip3 install git+https://gitlab.com/clickable/clickable.git
    

    Unforutnately my system logs the following errors after the second command:

    groups: cannot find name for group ID 1001
    groups: cannot find name for group ID 1002
    groups: cannot find name for group ID 1003
    groups: cannot find name for group ID 1004
    groups: cannot find name for group ID 1005
    groups: cannot find name for group ID 1013
    groups: cannot find name for group ID 1015
    groups: cannot find name for group ID 1021
    groups: cannot find name for group ID 2001
    groups: cannot find name for group ID 3002
    groups: cannot find name for group ID 3003
    groups: cannot find name for group ID 3004
    groups: cannot find name for group ID 9997
    groups: cannot find name for group ID 32011
    

    But I get another shell. I think, I'm in the shell of the container:

    itot@ubuntu-phablet:/# 
    

    The pip3 command is not known, so I tried the approach for Ubuntu as describedin the documentation (without sudo, because I'm already logged as root. This seem to work.

    Now I will try to find an apprproate IDE. Some idea? I'll try to install "qtcreator" after the installation of Atom failed.



  • I'm not sure if clickable will be usable, even if you can get it installed, as I don't think docker will work well on a phone/tablet running UT. But well, if you install pip3 in a container, then at least you should be able to install clickable. Whether it will work or not, is a different matter though.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.