Lost IMEI and AT command

  • @alainw94 The only way (probably) is install Flyme Global(International) version, the one with possibility to unlock the bootloader, then start the phone normally, grant usb debugging under developer options, cope the very same Flyme version update.zip to phone, reboot to recovery and select to update and wipe as well. This method is proven to work on Android (Flyme ) I have once ( or more times) lost IMEI while playing around with UT and Flyme and RR, anyway, this is how I restored it.
    Then just flash back the ubuntu touch recovery and flash the desired version of UT with Ubports installer or ubuntu-device-flash . Probably backup your files before you do this and DO NOT flash Flyme a (chinese) version, otherwise might expect trouble with changed ID of the phone to Chinese and would require the whole process of changing it again to Global/International and unlocking the bootloader... Anyway, has your Pro5 come as an Ubuntu Touch version, or just you converted the Android version? Mine was Android and can confirm successfully restoring the IMEI that way.

  • @alainw94 I was talking about this version of Flyme

  • @alainw94 I think you misunderstood...when I installed Anbox then my phone lost the IMEI number for some reason. I was just wondering if you made the same but from your answer it is clear you didn't so the reason why you lost the IMEI should be something else. However, try to follow Stefano's suggestion above and flash again Flyme in order to recover your IMEI.

  • @stefano hi! Many thanks for your answer, I will try your solution, the phone was initially running Android, I convert it to Ubuntu 2 days after buying it. I should have the international version somewhere on my computer. I'll keep you informed.

  • @alainw94 Just backup all your files before you do it, otherwise you loose them. If in troubles, let me know

  • @stefano hi ! I tried it. I revert back to flyme os daily. once started, I did it again. I still don't have IMEI. one interresting things is that on one of the update.zip from Flyme OS, I found two files, one is a binary nammed machine_match, it is working like that: machine_match filetoread. The second file is imei.dat so I tryed :

    ./machine_match imei.dat

    and the result was my two IMEI numbers.

    I:IMEI[0]: [8686.........]
    I:IMEI[1]: [8686.........]

    So they are readed from the ROM but now, how can I copy them back to the nvram ?

  • @alainw94 no idea mate, but maybe someone else could help? When updating , have you choose to ''wipe'' as well or not? Because by selecting the ''wipe'' and update after, the IMEI should be restored.

  • @stefano yes I choose the wipe option on the recovery mode and system update ... I will maybe have to buy a new motherboard 😞

  • @alainw94 Strange...

  • @alainw94 Sorry I couldn't help.

  • @stefano I will try to disassemble the smiril library in order to check what part and addresses of the nv_protected.bin are accessed to read the IMEI. I will maybe able to write it again like that.

  • i used the root terminal to write wifi files to nvram.. that worked to solve wifi always asking for password.

  • @simox In my case I wasn't able to recover, I changed the main board for 50$ on AliExpress. It was a Chinese version installed, I changed the proinfo to intl_official and then install ubuntu. The phone is running fine now. By the way, I decompil the libril library and I found 2 interesting entry , one of them is : NvProtectedFile::Unprotect(unsigned char *), I will deeply look at it when I will have time to do that.

  • great... i knew you problem was different.. but while i was looking for a wifi solution, i am sure i saw some infos on how to recover imei too on some kinds of phones..so..

Log in to reply