Redmi Note Dior bootloop. Device keeps restarting.



  • Hello. After updating my sources again and updating my device repo, now i am able to get last_kmsg and dmesg logs. Unfortunately the device doesnt boot yet. But it doesnt die on boot, it keeps restarting. From what i read in last_kmsg (attached below), i think the issue is in 70-$device.rules file. One of errors in the log is that, udev is unable to get device name, which may in turn cause device.rules udev file fail to load. Please help.

    TIA.

    last_kmsg: http://pastebin.com/Hd8YD82a



  • First guess:
    Did you name your udev file '70-dior.rules' ? ;)
    (you also have to change the rootstock-touch-install file to get it copied to the device)



  • yeah i did. The file pushes fine. I still dont know y aint it able to read device name. God this is so frustrating. -_-



  • have you check the /data/system-data/var/log/ if there's any other logs? since you've got systemd-udevd running it should dump logs there. you should be able to pull them from recovery.



  • i dnt think that matters anyway. if /data is nt mounted there wont be no logs in it, right?



  • Since there is few feedback to your question I will write all things that i noticed in your log:

    • You have 'androidboot.hardware=dior' on your cmdline. I saw 'androidboot.hardware=qcom' very often for qualcom devices.

    • Your logs say your device is loading udev rules from /lib/udev/rules.d/ but ubuntu-touch-install is copying the udev file to /usr/lib/lxc-android-config inside the system.img.

    • The log has this line: 'Machine: Qualcomm MSM 8226 (Flattened Device Tree), model: Qualcomm MSM 8926 H3-LTE' but your Xiami Redmi 4G seems to have an MSM8928 SoC. (three different numbers here)



  • Android boot.hardware is cmdline that is used to detect init.{hardware}.rc file which in my case is init.Dior.rc not init.qcom.rc. 2. First udev rules are read from rules.d dir which is inside ramdisk itself. Then afterwards when init mounts data partition then it read rules files inside system partition and overrides the earlier loaded ones. 3. My processor is definitely msm-8926 since in dts directory I have h3lte device tree which is only for 8926 and not 8928. If my device was 8928 and not 8926 the device tree wudnt have loaded in first place.



  • Did you try to boot with the debug option removed from the cmdline?

    I had the same symptom as you (systemd-udevd prints hundreds of messages per second until the phone reboots).
    For some reason this only happens with the debug option set.

    please compare this (with 'debug' and bootloop):
    http://paste.ubuntu.com/14667442/
    with this (no 'debug' and no bootloop):
    http://paste.ubuntu.com/14667455/


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.