WiFi password loss after each and every reboot on MEIZU Pro 5

  • @arubislander now your post is more clear, thank you. Anyhow, you have the international version. I believe the problem resides in the combination chinese version + 64 GB sd card, since, if I'm not wrong, @Stefano has got the chinese version, but with the 32 GB sd card.

  • @matteo Could it then be that something important gets overwritten when converting the Chinese version to an International version before flashing to UTouch?

  • @arubislander I don't think so, I just followed the procedure. Yes, I had to struggle a bit since the beginning when I needed to gain root access but then all went smooth. As said, anytime I flash back FlymeOS, the wi-fi connection starts again to work as expected.

  • @Stefano You said you had 3 different Pro 5. Did anyone of them had 4GB of RAM?

  • @matteo Chinese, but LTE version, not TD-LTE ( the latter one might have different wifi chip revision...)

  • I followed this excellent guide when re-partitioning before installing Ubuntu Touch 16.04:

    All went well except that I had this error message:
    Note: sector size is 4096 (not 512)
    Found valid GPT with protective MBR; using GPT

    and then this message as well:
    GPT PMBR size mismatch (15267840 != 15267839) will be corrected by w(rite).

    I have no idea if this is relevant or not.

  • @ubuntoutou yes, 1 of them, TD-LTE Chinese

  • No one has said if it is possible to install the Ubuntu Desktop packages $ lshw (list hardware) or $ hwinfo (hardware info) on Ubuntu Touch. This could tell us if there is any variation at the hardware level between MEIZU phones with the WiFi password issue and those same phones without this issue.

  • @matteo No disrespect to any Ubports developer, I was just mentioning @mariogrip cos he is known to have this device and have the experience with it. Yeah, anyone with knowledge can fix it.

  • A temporary or permanent fix could be to add a command line to the .profile or .bashrc file. The WiFi password could be automatically re-written by this command line at boot time. But I don't know what file the WiFi password gets written to nor if it has to be encrypted like the login password in /etc/shadow. Does anyone know?

  • @ubuntoutou as @UniSuperBox mentioned, the EFS backup and restore could solve your issue with wifi. You would need to flash TWRP_3.0.2.img from here:http://xep.8800.org/pro5/nougat/ with fastboot, then make a full backup of your UT with TWRP, save it on PC, wipe the phone, install FLYME ( the version with unlocked bootloader), boot and set it up, reboot to fastboot, flash TWRP_3.0.2.img again, reboot to recovery, create backup of ONLY EFS partition, then make a backup of just that EFS partition, copy it to PC, wipe the phone again, reboot recovery, copy the backup of UT and EFS to phone, restore UT ( or you can flash it anew if you prefer), boot and set it up... Reboot to TWRP recovery, restore EFS backup, reboot to fastboot, flash UT recovery. Check it wifi password is remembered. (You might need to delete the wifi profile and create a new one, not sure about that, just try.)

    Only this TWRP_3.0.2 has the option to backup EFS partition, not the other 3.0 version.

  • Thank you @Stefano. I suppose this implies that the Flyme OS image includes the EFS partition, doesn't it?

  • @ubuntoutou yes, it does. Also any ANDROID.

  • The EFS partition is custom to the phone. Since you have Wi-Fi working correctly when you have Android on the device, it is unlikely that the EFS is the problem. It's more likely that your unsupported device has some hardware difference from our supported devices.

  • @UniSuperBox Thank you. Actually, I don't know if the WiFi is working correctly with Android. I removed Android and installed Ubuntu Touch as soon as I got the device. I haven't tested the password issue with Android.

    Do you mean the EFS partition is custom to the serial number of the phone or custom to the Pro 5 in general (identical to all Pro 5s)?

    I could check what hardware I have in my Pro 5 if only I knew how to install lshw or hwinfo. I am a bit worried about installing anything with apt-get. I once installed a package with apt-get and the phone wouldn't boot afterwards. I had to reinstall the whole Ubuntu Touch OS. Should I use a Libertine container to install such a small package as lshw or hwinfo?

  • @ubuntoutou
    I had this on my m10 fhd, i used the fix on xxx.skyneel.com,which is flashed with twrp, it will stay, thru ota updates ,but if you change rc,to stable etc, you need to reflash it.
    I know how annoying it is reentering the passwords !
    it says it is for mtk devices ,worked for me tho.

  • @Stefano just now I realized I have the TD-LTE one...interesting...so, from what you said, this model is the only one with 4 GB?

  • @ubuntoutou it is possible. I just did it: I have both installed on my phone and they work great when launched with the terminal. I used a software called ATU to install the packages but basically it installs those by apt-get command. I also rebooted my phone after that without any issue. I don't see very useful data among the reported ones with both the commands by the way.

  • @matteo No, there is also LTE international 4GB Ram 64GB version as well.

  • Your WiFi worked with Android, but did you get a WiFi service called " nvram error 0x10".
    If you did and you flash UT, it will not show this error, and you will need to re-enter the wifi ,every time you restart it
    Put TWRP on your device, flash the nvram zip, from " xxx.skyneel.com" check it out ,reflashing stock recovery,as needed, ota updates fix usually stays, .

    See if it works for you , while you figure something else out

Log in to reply