Cant receive pictures through mms??



  • @AlainW94 I thought that you have 2 SIM card installed right ?



  • @AlainW94 Yes, Wifi is disabled. I do have only one SIM installed. It's not possible to install 2 SIM Cards to One Plus One. It might be that indeed my mms APN is not properly configured due to missing additional parameters. Maybe i could try to add all parameters manually to config file. I've seen some old topic related to Ubuntu Touch where it was described where apn settings are stored



  • @tricky Yes this is a thing you can try, and you should see if the configuration is fine if you success to ping the geo1 server or you could reach it through morph browser.



  • @AlainW94 That was this thread below:
    https://askubuntu.com/questions/413438/no-mobile-data-on-nexus-4-ubuntu-touch

    In /usr/share/ofono/scripts i found script create-mms-context so i will try to create mms APN first and then add all parameters with set-context-property script.



  • @tricky Very nice, please let us know if that works, and this can maybe be useful for other user that had your provider if you can share the info settings of your working APN



  • I tried to edit mms settings with set-context-property script but either this script doesn't work properly or I'm doing something wrong.
    I'm trying to change authentication method from chap to pap. According to my provider i should use pap method.

    phablet@ubuntu-phablet:/usr/share/ofono/scripts$ ./list-contexts 
    [ /ril_0 ]
        [ /ril_0/context14 ]
            MessageCenter = http://mms.orange.pl
            Username = mms
            MessageProxy = 192.168.6.104:8080
            Name = MMS
            Type = mms
            AccessPointName = mms
            AuthenticationMethod = chap
            Active = 0
            IPv6.Settings = { }
            Password = mms
            Protocol = ip
            Settings = { }
            Preferred = 1
    

    According to the documentation i should use it as it's shown below:
    set-context-property [modem] [context_number] <name> <value>

    phablet@ubuntu-phablet:/usr/share/ofono/scripts$ ./set-context-property /ril_0 14 AuthenticationMethod pap
    Traceback (most recent call last):
      File "./set-context-property", line 62, in <module>
        path = contexts[context_idx][0]
    IndexError: list index out of range
    

    Syntax seems to be correct because if i make typo in modem name or context number i get error message that context doesn't exist or modem name is wrong



  • @tricky I looked in the script file, the strange thing is that it seem that the context id passed through the command line is minored by one in the script :

    context_idx = int(sys.argv[1]) - 1
    

    Can you try the same command you type before but with a context number of 15 please?



  • I was able to get mobile data working with those scripts as well as get MMS to send but never received a, I even went the extra step of removing all the other APNs prior due to the data one not being correctly set when I try to activate the mobile data. I haven't tried changing the AuthenticationMethod yet however next time I play with it I will try that. I know it isn't messing up on my device cause there are only 2 APNs, one for data and one for MMS



  • @AlainW94 Unfortunately i get the same error

    I decided to delete all APNs and create only one APN for internet.
    Interesting that this new APN has been created with number 18. Shouldn't be 0 or 1 ? It might be that remove contexts scripts doesn't delete all related data.

    phablet@ubuntu-phablet:/usr/share/ofono/scripts$ ./list-contexts
    [ /ril_0 ]
        [ /ril_0/context18 ]
            IPv6.Settings = { }
            Password = internet
            Settings = { }
            AccessPointName = internet
            Preferred = 1
            AuthenticationMethod = chap
            Active = 0
            Username = internet
            Protocol = ip
            Name = Internet
            Type = internet
    
    
    ./set-context-property /ril_0 18 AuthenticationMethod pap
    Traceback (most recent call last):
      File "./set-context-property", line 62, in <module>
        path = contexts[context_idx][0]
    IndexError: list index out of range
    


  • @tricky said in Cant receive pictures through mms??:

    ./set-context-property /ril_0 18 AuthenticationMethod pap
    Traceback (most recent call last):
    File "./set-context-property", line 62, in <module>
    path = contexts[context_idx][0]
    IndexError: list index out of range

    Could it be that the context number is irrelevant and what you instead are passing is the index number? So that should be 1 in this case.



  • @arubislander That was it! many thanks for this hint 🙂
    Back to testing. I will keep you updated



  • here is a couple videos i made on the functionality of the nexus 5. first one showing that the phone does send pics, just doesnt receive them.

    https://vimeo.com/327479366

    and this video showing picture information is received from another contact, just not displayed.

    https://vimeo.com/327482143



  • @tricky what do you use to edit the script files. ive tried so many different ways. and still read only??



  • @sk8rdie you have to remount your file system from read only to read-write

    sudo mount -o remount,rw /

    If you find solution to fix mms issue please let us know.
    I spent few hours changing settings in context files via ofono scripts but i didn't manage to get mms working.



  • Hello, I'm writing my experience with MMS on Ubuntu Touch.

    I'm from Slovakia, my mobile carrier is Orange.

    On my previous phone bq E5 HD Ubuntu Edition with original Ubuntu Touch from Canonical, sending & recieving MMS worked out of box.

    On my current phone FP2, on stable & current rc (version 37) channel, it is not possible for me to send an MMS. It allwasys fails, message is red & a retry button appears beside the message. I don't know about receiving, but I never got an MMS, always got info about missing one and instructions, how to view it using web service & pasword.

    Note: Just for sure. Internet through mobile data works for me & during sending an MMS it is switched on.



  • @jezek i use the same mobile carrier as you in Poland.
    I assume that we both cannot properly configure settings that are required by our carrier.
    I'm just wondering if there is any chance to check what has been changed in ofono code since Ubuntu Touch.


Log in to reply