Cant receive pictures through mms??

  • @tricky I looked in the script file, the strange thing is that it seem that the context id passed through the command line is minored by one in the script :

    context_idx = int(sys.argv[1]) - 1

    Can you try the same command you type before but with a context number of 15 please?

  • I was able to get mobile data working with those scripts as well as get MMS to send but never received a, I even went the extra step of removing all the other APNs prior due to the data one not being correctly set when I try to activate the mobile data. I haven't tried changing the AuthenticationMethod yet however next time I play with it I will try that. I know it isn't messing up on my device cause there are only 2 APNs, one for data and one for MMS

  • @AlainW94 Unfortunately i get the same error

    I decided to delete all APNs and create only one APN for internet.
    Interesting that this new APN has been created with number 18. Shouldn't be 0 or 1 ? It might be that remove contexts scripts doesn't delete all related data.

    phablet@ubuntu-phablet:/usr/share/ofono/scripts$ ./list-contexts
    [ /ril_0 ]
        [ /ril_0/context18 ]
            IPv6.Settings = { }
            Password = internet
            Settings = { }
            AccessPointName = internet
            Preferred = 1
            AuthenticationMethod = chap
            Active = 0
            Username = internet
            Protocol = ip
            Name = Internet
            Type = internet
    ./set-context-property /ril_0 18 AuthenticationMethod pap
    Traceback (most recent call last):
      File "./set-context-property", line 62, in <module>
        path = contexts[context_idx][0]
    IndexError: list index out of range

  • @tricky said in Cant receive pictures through mms??:

    ./set-context-property /ril_0 18 AuthenticationMethod pap
    Traceback (most recent call last):
    File "./set-context-property", line 62, in <module>
    path = contexts[context_idx][0]
    IndexError: list index out of range

    Could it be that the context number is irrelevant and what you instead are passing is the index number? So that should be 1 in this case.

  • @arubislander That was it! many thanks for this hint 🙂
    Back to testing. I will keep you updated

  • here is a couple videos i made on the functionality of the nexus 5. first one showing that the phone does send pics, just doesnt receive them.

    and this video showing picture information is received from another contact, just not displayed.

  • @tricky what do you use to edit the script files. ive tried so many different ways. and still read only??

  • @sk8rdie you have to remount your file system from read only to read-write

    sudo mount -o remount,rw /

    If you find solution to fix mms issue please let us know.
    I spent few hours changing settings in context files via ofono scripts but i didn't manage to get mms working.

  • Hello, I'm writing my experience with MMS on Ubuntu Touch.

    I'm from Slovakia, my mobile carrier is Orange.

    On my previous phone bq E5 HD Ubuntu Edition with original Ubuntu Touch from Canonical, sending & recieving MMS worked out of box.

    On my current phone FP2, on stable & current rc (version 37) channel, it is not possible for me to send an MMS. It allwasys fails, message is red & a retry button appears beside the message. I don't know about receiving, but I never got an MMS, always got info about missing one and instructions, how to view it using web service & pasword.

    Note: Just for sure. Internet through mobile data works for me & during sending an MMS it is switched on.

  • @jezek i use the same mobile carrier as you in Poland.
    I assume that we both cannot properly configure settings that are required by our carrier.
    I'm just wondering if there is any chance to check what has been changed in ofono code since Ubuntu Touch.

Log in to reply