Android on UB Touch questions

  • I followed the instructions found here: link text . It appears to me - a complete novice - that everything went well. Still, I have some questions, things I do not understand.

    1. I got the apk file for an email app, and "successfully" installed it. However, when I tap on the icon for that app, it starts, but then immediately shuts down. Why is that? Am I doing something wrong, or is the android functionality on UBTouch still kind of flaky, and I should expect to see apps not work?

    2. I do not see an icon for Anbox. Should I?

    3. I installed two apk files for two apps (the email app referenced above, and a simple notepad app). When I ran the command to see the packages installed, I see a very long list of packages? How and why did they get installed? Why don't I see icons for all those packages?

    4. Is anbox-tools supposed to start automatically when I start the phone? What is supposed to control when it starts? Sometimes I had to manually start it in order for the android container to be "seen".

    5. Once an android app is installed, how do people navigate within it the app after it is started? I installed the notepad app. I have a OnePlus One, which has no buttons. So, when I tapped on "settings" within the notepad app, I had no way of going back to the main view of the app, since there is no "return" arrow. So, I don't get how people use the android apps on UBTouch. What am I missing?

  • A few answers

    1. anbox is very experimental still so personally I would expect more than 50% of all apps to not work (anything that uses Google services like the maps api will not work); and probably less than 10% of apps to work without major issues (for me, of around 12 apps I tried only spotify works without me noticing problems)
    2. as far as I know there is no icon for anbox (it's just software that runs in the background)
    3. I guess these are system apps (on a normal android they are not listed by default in the settings apps)
    4. after you enabled anbox with anbox-tool it is supposed to start automatically on boot, but if I remember correctly I also had situations were some commands didn't work; only after starting an android app those were possible so I guess there is still some difference between something like "ready" and "running" or so (or maybe it's just a bug due to the experimental nature of anbox on UT)
    5. Android apps rely on a back button, so running android apps on a system that doesn't have those just can't be operated fully; there may or not be workarounds like stopping the app and starting it again

Log in to reply