Librem 5 dev-kit



  • @doniks Yeah I already did that. They use a script with vmdebootstrap to build a debian , which is similar to the way the ubuntu-touch image is built. It should probably be possible to modify that script to build ubuntu-touch.

    Image build script: https://source.puri.sm/Librem5/image-builder
    Flash scripts: https://source.puri.sm/Librem5/librem5-devkit-tools/

    The images are a bit different and have the kernel on the image itself and a boot sector from what I can tell.

    I currently struggle more with figuring out how the ubuntu-touch image is built. I know the rootstock-ng is used, but I'm not sure what parameters are used on the Jenkins.

    @UniSuperBox is there somewhere a list of repositories and packages (meta package or a list?) that are used to build the image? I already asked in the UBports_porting channel but got no answer so far.



  • This sort of info would help those of us hoping to find a way of getting it running on the Raspberry Pi as well.



  • Is there a set of instructions describing how to install the port of UBports onto the Librem 5 development board, or is it handled in a generic way using an installer?

    Thanks in advance for any hints. :)


  • Administrators

    @david-boddie right now there is no "good" way of installing on the librem5, we have some basic images working on it, but we have not put too much time into it, and we have halted the development on it as purism wont send us final devices until last. Purism has also failed to meet anything they said on their "partnership" blog post we had with them a while back. We really want to have Ubuntu touch running, but at this point it seems like purism don't want us.

    We have some images built by our ci server: https://ci.ubports.com/job/rootfs/job/rootfs-librem5/
    but this has not been tested in a while so the state of the images are unknown. You can flash this using purism's uuu tool :)



  • @mariogrip Thanks for the link. I'll try and find some time to flash a known working image onto the board. :)


  • Administrators

    @david-boddie for the development board we do have most parts that is working on pureos and the images should be even better after an apt update since we got lots of mainline and wayland fixes in since last image was built :)

    but i'll update jenkins now to build the new ones now since should be quick to get going :)



  • @mariogrip Thanks for updating Jenkins. I'll check back tomorrow or later this week.


  • Administrators

    @david-boddie aaand we got some freshly baked images :D https://ci.ubports.com/job/rootfs/job/rootfs-librem5/

    I have not tried them, so may be broken :upside_down_face:



  • @mariogrip I used the U-Boot image from the Purism Jenkins instance and this UBports image. I adapted a flashing script used for the stock Librem 5 development images to flash both of these onto the devkit.

    uuu_version 1.0.1
    # Using the recovery uboot in ../files/u-boot-devkit-recovery.imx
    # flash a new image ../files/devkit.img
    
    SDP: boot -f /tmp/u-boot-devkit-recovery.imx
    # This command will be run when use SPL
    SDPU: delay 1000
    SDPU: write -f /tmp/u-boot-devkit-recovery.imx -offset 0x57c00
    SDPU: jump
    # This command will be run when ROM support stream mode
    SDPS: boot -f /tmp/u-boot-devkit-recovery.imx
    SDPU: delay 1000
    FB: ucmd mmc dev 0
    FB: ucmd setenv fastboot_dev mmc
    FB: ucmd setenv mmcdev 0
    FB: flash -raw2sparse all /tmp/devkit.img
    FB: Done
    

    Where devkit.img is the ubuntu-touch-librem5-dev.img image file.

    It boots to a login prompt on the screen but doesn't switch to a graphical environment. I'll have to plug in a UART to serial cable to see what needs to be done to set up the phone environment. Any hints about that?



  • I used the UART connection to log in (username: phablet password: phablet) and set up networking.

    I tried to start a graphical session but it looks like a lot of things are already running. I couldn't see anything obviously wrong in the system logs. I'll try to take another look at it later, or tomorrow.


Log in to reply