flash_tool on M10 HD stuck?

  • Hello,

    I am having a problem installing Ubuntu Touch like shown here: https://docs.ubports.com/en/latest/userguide/install.html#install-on-legacy-android-devices

    The flash tool doesn't say anything that I can make sense of and I don't want to remove the M10, in case the tool is actually doing something. Right now it has been stuck for 175 minutes and according to the speed it has shown and the size of the image, it should only take 30 minutes to copy the image to the device.

    It would be nice if someone could tell me what step it is stuck at, and if I can safely remove the device to try again.

    Here is a paste of the terminal output: https://paste.ubuntu.com/p/rhcqMBktmd/
    Also an image of the window:
    1Smart Phone Flash Tool(Runtime Trace Mode)_555.png

  • @MotoFckr9k Ok, all I can tell you is what worked for me. I am NOT a tech expert, and if you try what I told you I did and it causes problems for you, well, it is your decision whether or not to try what worked for me.

    I also have the BQ M10 HD (cooler). It came to me with android installed.

    I too got stuck exactly as your picture shows. I had to disconnect my tablet, and shutdown the flash tool at this point, doing that caused no problems for me. Then, here's what I had to do.

    First, I found the connection with the computer to be very touchy. I had to make sure I was using a USB 2.0 connection. But even then, I could never get it just right on my main Ubuntu computer. I ended up switching to another Ubuntu computer I have and used the USB 2.0 connection on it. That enabled me to get past the red bar problem. But then, I had two other problems.

    On the second computer, when I connected the tablet to the computer, I recall having problems with connecting it "fast enough". I don't recall exactly what that problem was - sorry - but I know I had to try plugging it in several times before I got the timing just right so that the flash tool would recognize my tablet. Then, all the downloads began, except..... I got an error message about a com port not being available, and that stopped everything.

    I ended up finding these instructions from BQ: https://web.archive.org/web/20180118130643/http://www.mibqyyo.com/en-articles/2015/09/16/ubuntu-android-installation-process-for-bq-aquaris-e4-5-and-e5/ . It is for a different device, but it covered my problem. The problem is that there is a package on my Ubuntu computer called modemmanager. It conflicts with a com port that the flash tool needs to use (in my simple terms). On the site I provided, BQ describes (under step #3) that you need to temporarily uninstall that package from the Ubuntu desktop computer, then go through all the steps you are attempting. So, I did that, I uninstalled modemmanager, started the flash tool, connected the tablet, all the downloads worked perfectly, the tablet was flashed with Ubuntu Touch and rebooted itself, I disconnected the tablet, shutdown the flash tool, and then on the Ubuntu desktop computer reinstalled the modemmanager package.

    And now I have a perfectly working BQ M10 HD tablet running the latest stable version of Ubuntu Touch.

  • I think this picture says all. Thank you very much.


  • If you look at the left lower corner of flash_tool pic, it shows no chip info, so you did not have adb connection.
    Glad you got it sorted

  • Yeah, in the end I had to remove modemmanager and just try plugging it in a couple of times. (sometimes it works sometimes it doesn't apparently)
    Also the tablet didn't boot when the flashing was finished. I had to boot it manually.

Log in to reply