Issue installing Anbox on OPO "general error"

  • Greetings all,

    I searched the forum for a few days on this topic and have not found anything overly specific for my issue.

    I am a new user of UBports, and wish to make the full leap in the future. However, I need some Android apps for various reasons. I am attemting to install Anbox onto my OPO, but am getting an error when I attempt to follow the install directions on The error says that it is a general error reading/from

    :general error

    I have been trying to find anything related to a general error while installing anbox on an OPO and have come up empty.

    Is there an updated howto out there or a guide on how to work around general errors?


  • The docs you mentioned are about installing anbox on desktop PCs.
    You need to follow this specific instructions:

  • @Ingo Thanks for the link, mate!

    I am following everything step by step, but I am getting the Fastboot: command not found when I attempt to run the following...

    sudo fastboot flash $PARTITIONNAME anbox-boot-$CODENAME.img

    any advice?


  • @Ingo

    I finally got it! I figured out what the issue was. Now, I am just trying to get a test app to work, which so far anbox seems... odd.

    But, you helped me get it up and running!


  • @Isolated-thinker

    I'm just sharing my experience. I installed Anbox on my OPO about 10 days ago, but it was disappointing. The only Android app I installed that worked was F-droid. None of the apps I was interested in worked (Fedilab, OsmAnd particularly). I also didn't like that it populated the dash with core AOSP apps (Calendar, calculator and so on). Even after reflashing my phone (without wipe) to remove Anbox, the Android apps launchers were still in the Dash, I had to delete them manually from the terminal.

    I wish you a better experience!


  • hello guys, how to give root permission on anbox? are the same way with desktop anbox version, or ubuntu touch anbox have different way?

Log in to reply