Any news about m10hd "cooler" wifi-problem?

  • Hi,
    i bought an new m10hd tablet (android), just to try out UT on tablet... I installed first old UT-image with flash-tool and then ota-10 (cooler) with installer. It's all fine - BUT: After boot or reboot there's is no wifi connection - I have to type the key again... It's a "no-go"!

    It's obviously an old problem... But I don't find any solution... Is there meanwhile any solution?

    Thank you very much!

    Best regards!


  • @1896er
    Did you use the flash tool
    You can wipe the nvram if you use the format option

  • Look here for possible fix ,and explaination

    XXX.skyneel .com
    ,Search for "nvram"
    If you get this fix to work , it will fail if you change from stable to RC , but it should stay with OTA updates

  • I thought I should mention ,that I have been unable to get TWRP to work on my m10fhd
    For a long time ,via terminal or flash-tool ,it will only get to the start screen , sometimes it will get past that ,but fails
    Just fyi

  • First step was to install old UT-firmware with flash-tool. I did it with "firmware upgrade" - not with (format all + download). Well, I'm not a technician, I think, it's too tricky for me, to wipe nvram... I'm unsure!

    Now I'm reinstalling android to the m10. Maybe I can start the steps again...

    How can I wipe the nvram with the format option? I need some help and steps...

    Thank you very much!


  • Back to Android (8.1.0) there are no problems with wifi connection... (after boot or reboot)...

  • Should I install TWRP on android now? And then try to fix the nvram error with the steps from XXX.skyneel .com? And then install UT again? First old version with flash tool, then ota10 stable with installer?

    Or even flash tool with wipe nvram (don't know, how I got it..., need some help)

    This are two different ways? I think about the right (best) way...

    Thank you and best regards!

  • I did first step (without any change) again: Flashed with flash-tool the old UT-image. It ist 15.04 OTA-13. And here's the same problem: Wifi lost after boot or reboot.

  • How can I detect, if there's any hardware broken? In principle I could send the device back to amaz... But make it sense to get a new one? This was already a new one...

  • Seems to be a solution here:

    Can anybody explain me the two "easy steps", please? The two needed files are already on my ubuntu-pc. Need a little step - by - step help for the following to do (in terminal?)...

  • No progress in this case...

    I need little step-by-step help in this questions:

    1. Hardware issue or software bug?
    2. How can I get a solution?

    Sorry, I'm not a technician but only an interested user. I know, this is not the best precondition for using UT, but I like it very much and I want to use it not only on my Nexus 5 but also on M10 HD... (with no wifi problem if possible...)

    Thank you!

  • @1896er You need to put your tablet in rw mode with tweek-tool. From the tablet's terminal you need to become root with the command sudo -i . You move those files from the SD to their folder with the command mv. You change the files permissions with the command chmod 755 .

  • @simox
    I need to fix my nvram,as you describe here. ( wifi / custom wifi folders)
    Could you give a more detailed description,of using terminal.
    I mean how to fill in the gaps between. Sudo -i mv chmod755
    Assuming I put the folders,on root of device,or in the download folder.
    I have used twrp to flash the fix before, but twrp freezes up on me now.

    Is it easier to do this from my PC via " adb shell "

    Thanks Colin

  • @1896er
    The problem is solvable. Please refer to
    At the bottom of the page you will find the text:
    Attached Files
    Wifi Fix Files.rar - [Click for QR Code] (187 Bytes, 339712 views)
    After downloading and unzipping the file Wifi Fix Files.rar you get two files:
    These two files must be in the folder
    be copied (overwrite the existing files)
    In conclusion, do not forget reboot.

  • @emailforfor
    hey, thanks for the reply
    i have difficulty getting the fix to stay
    when coming back to ubports, (even double checked the permisions.)
    i need to learn how to do it via terminal.
    i must be wearing things out going back n forth

  • @emailforfor
    well i found out by accident , that the cause of twrp not working, was an sdcard i left in it. it was locked up trying to read it all the time.
    I guess the times it worked ,i had removed the sdcard. and not put the 2 and 2 together.
    thanks again for your help

  • @Marathon2422 @emailforfor Thanks for sharing these instructions, guys.

    @1896er, I was also searching for exact steps to fix it on my brand new Aquaris BQ M10 HD just flashed from Android 8.1.0 to Ubuntu Touch, and finally got it! It's something @simox told about but these are steps that worked for me.

    1. Download an archive with WIFI and WIFI_CUSTOM files to your tablet. Please note that zip archive rather than rar can be extracted on UT. So I had to repack it on my PC first:

    2. Open Terminal and switch to root user:

      $ sudo -i
    3. Go to Downloads folder:

      $ cd /home/phablet/Downloads
    4. Extract downloaded archive there:

      $ unzip


    5. Go to /data/nvram/APCFG/APRDEB directory:

      $ cd /data/nvram/APCFG/APRDEB
    6. You will probably see WIFI and WIFI_CUSTOM files there. Backup them:

      $ mv WIFI WIFI.backup
      $ mv WIFI_CUSTOM WIFI_CUSTOM.backup
    7. Now copy these files extracted from the archive:

      $ cp /home/phablet/Downloads/WIFI* ./
    8. Change files' permissions:

      $ chmod 660 WIFI*


    9. Now close everything and reboot the system. After reboot go to WI-FI settings, remove all previously used networks <your wi-fi name>, <your wi-fi name 1>, <your wi-fi name 2>, etc... Finally, connect to your WI-FI network again entering a password (hopefully last time).

    10. Go to "System Settings" > "About" and check your device's MAC address. Reboot the tablet. Now it has to connect to your WI-FI automatically on startup and MAC address has to be left unchanged.



  • @ezze
    this is awesome Thank You very much
    (should go on github as a stickie)

  • @ezze
    Of course, we have to be careful when installing files that come from unknown sites. And: It seems to me that all devicesget the same MAC. That does not bother me. I do not do banking with the tablet, I do not mind with google or any "social networks". I would not even look at my e-mails with a tablet.
    Anyway, when I flash cool-6, all the modifications are gone. I get back the files "WIFI" and "WIFI_CUSTOM" that do not run.
    Maybe someone can work up the facts to the extent that CONTROLLED and SAFE files "WIFI" and "WIFI_CUSTOM" are delivered during the installation process of the ubports-installer. Unfortunately I am not able to do that.
    It seems that not only BQ M10 tablets are affected.

  • @emailforfor
    I got an error using the terminal version ( step7,could not find files ).
    So i used twrp ,(file manager) to delete and replace,wifi/ wifi_custom,files checked it worked, YES.
    Then did chmod 660 with twrp.
    Now to reflash regular recovery. (for ota updates)

Log in to reply