[SOLVED] How to install LibreOffice on M10?

  • Sorry for so much asking...

    I've read much time at google but I can't find an answer for me: How can I install desktop apps on M10? I'm not very firm in libertine... I would like to run libreoffice.


    Best regards!

  • @1896er The best way is to use System Settings. Firstly go to battery settings and set lock when idle to never. Then tap on the Libertine Top hat. Then just tap the plus sign next to Manage Libertine Containers. You will then get a popup where you can give the container a name or password. Do that if you want then press OK and wait it can take some time.
    When the container is completed, tap on the container name then the plus sign next top right, Choose Enter Package name and type libreoffice and that should be it. Don't forget to change the battery screen lock settings back.
    How it runs on the M10 not sure as have only installed on my OPO as a test.

  • Thank you very much! I will try it out!

    Best regards!


  • @1896er The latest version of the docs should also explain it a bit better now: http://docs.ubports.com/en/latest/userguide/dailyuse/libertine.html

    @Lakotaubp is that tweak with the battery setting important? What difference does it make? Should it go into the docs? Do you want to contribute it there?

  • @doniks I always found the install seemed to stall and take forever if i didn't do the battery trick. Picked it up from someone on here but can't remember who and it was a couple of years ago.
    Can add to the docs if everyone happy with that. Will also check with someone else in marketing as I think they use that too.

  • @doniks Yes they use that battery "trick" for the same reasons to. So if your happy will look at adding into the docs later on.

  • @doniks Done request made today

  • @doniks Don't know where that went then. Must have done something wrong, Edited page then, clicked yes on PR. Will try again later today if I can't sort.

  • No success here. I typed "libreoffice" in "enter package name", then I wait some minutes, then it's all gone... It appears "No packages are installed".

    With the docs-manual the same. Well, where can I get the correct package name? Searching in the "archive" is also not successful. Or have I to download something before installing process?


  • @1896er Try LibreOffice or Libre Office, it is there somewhere I have it installed. Don't forget to do the lock when idle setting change as well when installing it

  • No success with different "typings" ....

    Any other idea?

  • @1896er said in How to install LibreOffice on M10?:

    No success with different "typings" ....

    Any other idea?

    If you have ubuntu on your desktop you can search for the package name there. It is (most likely) the same. I just tried. i guess it is "libreoffice-writer" or "libreoffice-calc", etc

  • @1896er I just tried entering 'libreoffice' into the top option Enter package name or Debian file which then told me the package was already installed. So not sure what is happening. Going to remove mine and try again

  • Ok That works for me on my OPO.

    • Press plus sign

    • Then press Enter package name or Debian file

    • Type libreoffice

    Then I got blue spinning circle for a couple of mins and job done. will try and find my M10 and check that but the package name should be the same.

    Edit: Yes same process worked on my M10

  • My container is named "Ubuntu 'Xenial Xerus'" - it is the default container, I chosed no special name or a password... And then I do the same as above: I got the blue spinning circle for a couple of mins - then: Nothing... "No packages are installed".

  • @1896er ok what channel are you on. Stable, RC and dev need the you to enable the desktop app scope. The installed apps show up there. If I remember rightly you swipe up on the app scope to do that, but might be wrong. Can't check as not at home and on Edge.

  • I am on stable. Checked the desktop scope app: There are no apps...

  • @1896er Then I'm at a bit of a lose. Use container settings (cog top right corner) manage container, Update container. Let that finish and try again. If you have not installed any apps yet try firefox, or inkscape as a test. If nothing installs try deleting that container, restarting the device and installing a new container from scratch.
    Will be back later on today good luck. Maybe someone else has other ideas and can help but can't think of anything else at present.

  • How would we get a log file? Is it just something like ~/.cache/upstart/*libertine*log ? .... doesn't look like

    @1896er can you try from command line and share the resulting libertine.log e.g. via paste.ubuntu.com ?

    libertine-container-manager -v install-package -p libreoffice-writer | tee libertine.log

  • Problem solved:

    I deleted and installed default container again. I remember, that by installing it first, I interrupted installing process anyway, because I thought, it needs too much time... But after reboot device, container appears in list, so I thought, it's all right - but it wasn't, container wasn't installed right, but no notice appears...

    Correct installing container needs about 10 - 15 minutes. You have to wait till spinning wheel disappears.

    Thank you for help! It was my own mistake, but it is hard to detect it for a "normal" user...

    In this case I'm happy now!

    Edit: Libreoffice is not really usable, isn't it? Connect with keyboard and mouse it is e.g. not possible to save a document... Toolbar works not really... Or have I to do same special settings?

Log in to reply