Oneplus 3/3T



  • Hello guys,
    I installed today ubuntu-touch with official installer (devel and edge checked) on oneplus 3T, and I was unable to connect to phone with ssh. Both ssh and usb-tethering services was stopped. In ssh.overide file is first line manual and in file usb-tethering.conf too. I am suspecting that autoenabling of these services doesn't work.
    And after starting this 2 services with ip a I am getting

    enp0s20f0u3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
        link/ether e2:0a:36:e1:fe:a7 brd ff:ff:ff:ff:ff:ff
        inet6 fe80::5ed9:d70d:7e23:2dda/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    

    and unable to connect because IP assignment didn't worked



  • As per the latest Q&A 83:

    "One effect of this is that devices using Halium 7 will now be able to use the installer and to get updates via the server in the normal way. Xiaomi Redmi 4 and OnePlus3/3T should be immediate beneficiaries of that, along with the little mentioned but nice BQ Uplus. That ease of install should extend the user base of those phones quite considerably."

    Just to be sure:

    1. does this imply that G-droid camera app can be installed and will not (be)affect(ed) when updated?

    2. Is the Halium operation, which used to be a separate action, now included in the installer itself?

    3. What are the immediate beneficiaries for OnePlus 3/3T?

    4. If one is about to would, what would be the best way to do it? preferably a step-by-step instruction, considering the user to be a newbie having a OP with UT already installed and looking to preserve the content and apps currently working.

    5. edit: Will the UT black logo splash screen be included in the OnePlus 3/T installer (replacing the Android one on startup?

    Personally I had quite some troubles getting UT installed initially. Now that I have managed to get my device running UT (without Halium!) I'm kind of reluctant to re-install and no doubt others with the device feel the same. Maybe it's just an easy task, so hopefully someone will be able to reply to the questions above in order to make users more confident in re-installing the whole thing as of September 9th.

    Thanks!



  • @3T_Ed To move to the standard update cycle just change to devel in system settings. That puts you on a more stable footing than being on the edge. Nothing else changes. As for camera I only have the OP3 and that did not change workability on devel, camera worked video didn't, but the OP3t is different. As for the splash screen the installer did not install that last time I tried.
    Using the installer didn't change anything else app wise when I last used it either. Just don't select wipe.



  • I was recently testing ubports GSI for OnePlus 3T, and Camera experience there was great. Much faster switching between cameras, faster recovery after taking photo, video recording worked, even video playback works. I think that are last pieces for this phone to get properly working. Would be possible to take advantage of this for Halium 7.1 port?



  • @Lakotaubp

    Until last Friday I was on dev edit: Release Candidate channel and changed it back to Edge. I will switch back to dev again.

    As the blog post mentioned the OTA-13 would be beneficial for OP 3/T, in combination with Gst-droid, so I was hoping to get the one thing that keeps me from using the phone as my daily driver: the camera app.

    The blog post mentions to use the installer, whereas your advice is to just switch to dev channel. Will OTA-13 include the Gst-droid camera for 3T then? Without having to re-install UT?



  • Anyone else have problems with display auto-rotate since recent (470+ish) updates?



  • Received OTA-13 on stable channel and it is great to have that much faster browser experience. The text handles are very usefull. Thank you all who have been working on the new release.

    As per the latest blog post on OTA-13
    ”Magnetic phone sleep covers will now cause some devices to sleep and wake.”

    I can confirm this works for OnePlus 3/T using Nilkin flipcover



  • Regarding he notification bar and its icons

    1. Is there an option to change the order/position in which they are displayed from left to right?

    2. When pulled down the active icon (green) and its menu seems to be random every time the phone (re)boots. Is there any way we can have a pre-selected icon by default?



    1. I think there was some talk regarding this for the Yolla Phone to avoid the display notch. Might be upcoming.
    2. The pull-down is gesture based. You can try to hit the right icon with your finger directly (so it isn't random, but based on where you place your finger), but otherwise just move the finger left or right to swap the menus.


  • @poVoq said in Oneplus 3/3T:

    1. I think there was some talk regarding this for the Yolla Phone to avoid the display notch. Might be upcoming.
    2. The pull-down is gesture based. You can try to hit the right icon with your finger directly (so it isn't random, but based on where you place your finger), but otherwise just move the finger left or right to swap the menus.

    Thank you for that. I will search for the Yolla Phone comment mentioning that. It would be nice to have the feature be implemented for all devices. Pulling down the top bar needs to be done with pinpoint precision to swap menus. I'm getting the hang of it. Thanks again.



  • Hmm, I seem to have problems installing this on my Oneplus3 coming from a Linage OS 17 😞

    Initially I tried to just use the installer, but had to manually select the OnePus3(T) and it installed the bootloader and went through the installation process resulting in a success message, but the Phone itself ended up in a non bootable state. First it went strait back to the Ubports recovery and after another reboot would show the Linage OS boot logo but not proceed.

    So I reflashed TWRP wiped all the partitions under "advanced wipe", made sure all is in EXT4 (had to reformat one) and then restarted the installer. This time it recogized the device fine and would again say all installed fine. But now I am stuck in a bootloop to the Ubports recovery.

    I will try flashing TWRP again to see if I might have missed something, but I am a bit stuck 😞

    Edit: After reflashing TWRP I also used the "reformat" option on the partitions in TWRP. Then used the installer again. Again it found the OnePlus3 correctly and claimed to have installed correctly.
    Then it rebooted, was stuck on these swirly multicolor rings for a while, then rebooted again and now I seem to have a working Ubuntu Touch πŸ™‚



  • Adjusting display brightness isn't working on OTA-13 with the OnePlus3?
    Edit: working after a restart. Phew, I was starting to worry about my eyesight πŸ˜‰



  • Anyone has a suggestion how to fix the silent mode slider button? It was working on first boot of the system, but now it doesn't seem to register any longer.



  • @poVoq said in Oneplus 3/3T:

    Anyone has a suggestion how to fix the silent mode slider button?

    Do you mean the physical button (top left)?
    When sliding that button the speaker icon in the top bar/toggle is striked through/muted on my 3T

    edit: I'm on stable channel



  • @3T_Ed said in Oneplus 3/3T:

    @poVoq said in Oneplus 3/3T:

    Anyone has a suggestion how to fix the silent mode slider button?

    Do you mean the physical button (top left)?
    When sliding that button the speaker icon in the top bar/toggle is striked through/muted on my 3T

    edit: I'm on stable channel

    Ah a reboot seems to have fixed it. Odd.



  • Any idea what could be causing my OnePlus3 to be partially in Window mode, despite being set to staged?
    See related discussion: https://forums.ubports.com/topic/4998/differences-in-qtwebengine-rendering/13

    I noticed that the BottomEdge is displayed as if there was a mouse connected, and sometimes I shortly see a mouse-pointer on the circle screen appearing.



  • My OP3 runs an edge version from 2020-07-21. I would like to switch to another channel ("dev"), but only "edge" is offered under Updates|Update settings|Channels.



  • @sven You should be able to move to dev iirc and you are upto date with updates. So recheck updates and channels. If not rerun through the installer don't select the wipe option and do it that way.



  • @Lakotaubp Thanks for your suggestions. I checked again: no other channels available (probably the installed one was an early one). Now I am trying the ubuntu installer 0.5.2-beta. My OP3 is running, developer mode is on, but the installer is only showing Waiting for device.

    If I select the model by hand, installation ends with lost connection. I am using the official OP3, red USB cable.



  • @sven Perhaps try dropping down an installer version or two. I must admit to not trying the new beta one yet.
    Edit Or 0.5.3 from here https://forums.ubports.com/topic/5008/testing-request-ubports-installer-0-5-3-beta


Log in to reply