How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port)



  • @peat_psuwit said in How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port):

    UPDATED: This is no longer required. The correct fix is now in the GStreamer.

    So it mean we can come back on the std droid-media and the GStreamer update should be in the latest rootfs ?



  • @Xray2000 Yes it was. I have a problem with my server setup which causes files to be randomly truncated. The file is now fixed and should be 475k (or so) in size.

    @Luksus I know why the file gets that large and I still want to look into it (a large amount of that size is a binary file gets hex-printed). Maybe you could compress it and upload it somewhere (if not here)?

    @ernest The update is in the xenial_-_gst-droid repo mentioned in the instruction. You should get it automatically via apt.



  • @peat_psuwit Thanks!



  • Yes there is an issue with your arm64

    Erreur fatale: /home/phablet/com.ubuntu.camera_3.1.2+gstdroid3_arm64.click failed to install.
    WARNING:root:Signature check failed, but installing anyway as requested
    Traceback (most recent call last):
      File "/usr/bin/click", line 110, in <module>
        sys.exit(main())
      File "/usr/bin/click", line 106, in main
        return mod.run(args)
      File "/usr/lib/python3/dist-packages/click_package/commands/install.py", line 66, in run
        quiet=not options.verbose)
      File "/usr/lib/python3/dist-packages/click_package/install.py", line 463, in install
        path, user=user, all_users=all_users, quiet=quiet)
      File "/usr/lib/python3/dist-packages/click_package/install.py", line 357, in _unpack
        package_name, package_version = self.audit(path, check_arch=True)
      File "/usr/lib/python3/dist-packages/click_package/install.py", line 279, in audit
        for data_name in package.data:
      File "/usr/lib/python3/dist-packages/debian/debfile.py", line 181, in __iter__
        return iter(self.tgz().getnames())
      File "/usr/lib/python3.5/tarfile.py", line 1755, in getnames
        return [tarinfo.name for tarinfo in self.getmembers()]
      File "/usr/lib/python3.5/tarfile.py", line 1747, in getmembers
        self._load()        # all members, we first have to
      File "/usr/lib/python3.5/tarfile.py", line 2340, in _load
        tarinfo = self.next()
      File "/usr/lib/python3.5/tarfile.py", line 2271, in next
        self.fileobj.seek(self.offset - 1)
      File "/usr/lib/python3.5/gzip.py", line 366, in seek
        return self._buffer.seek(offset, whence)
      File "/usr/lib/python3.5/_compression.py", line 143, in seek
        data = self.read(min(io.DEFAULT_BUFFER_SIZE, offset))
      File "/usr/lib/python3.5/gzip.py", line 480, in read
        raise EOFError("Compressed file ended before the "
    EOFError: Compressed file ended before the end-of-stream marker was reached
    
    


  • I've create a bug report to highlight a long boot after the installation of your modification :
    https://github.com/ubports/ubuntu-touch/issues/1396

    On OP3T both cameras works, with your latest setup, thanks !
    I'm using this click : https://gitlab.com/peat-psuwit/camera-app/-/jobs/464890160

    Still pending the video recording.





  • Hi, what do I have to do to get the cameras on a OP3T working? Or will it be repaired with one of the next updates? Thanks a lot.



  • @ma
    Hi. Carefully following the instructions at the top of this thread got the camera working on my OP3T, no video, and the fix didn't survive the daily updates.

    See my post above (20 days ago) for more info...



  • I have trouble installing this on a Fairphone 2 with the new Halium 7.1 port.

    phablet@ubuntu-phablet:~$ sudo umount /lib/udev/rules.d/70-android.rules
    [sudo] password for phablet: 
    phablet@ubuntu-phablet:~$ sudo mount -o remount,rw /
    phablet@ubuntu-phablet:~$ sudo apt-mark hold qtubuntu-android
    qtubuntu-android passé en figé (« hold »).
    phablet@ubuntu-phablet:~$ sudo ubports-qa install xenial_-_gst-droid
    (...)
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 not updated.
    mount: / is busy
    ERROR:ubports-qa:Failed to remount root filesystem read-only.
    ERROR:ubports-qa:Please consider rebooting your device.
    INFO:ubports-qa:You can remove this repository by running 'sudo ubports-qa remove xenial_-_gst-droid'
    

    Here are the complete logs. Can anybody help?

    Edit: it looks like even if I had the errors displayed above, the installation worked.



  • Hello would it be possible to recompile xenial_-_gst-droid with the latest environment ?
    I've tried yesterdat with the latest edge hybris arm64 and it's forcing me to downgrade some package.



  • @ernest It should no longer downgrade any package, even without the pinning. Most of the time the downgrade comes from the meta-packages, as they are updated more frequently than most packages in this repo.



  • @peat_psuwit is the issues already solved what Ernest have posted? I mean with the startup device delay on Oneplus 3T



  • @Xray2000 Unfortunately no. The problem is, I can't reproduce it on my Fairphone 2. Thus, I don't have any insight about the problem, yet.

    BTW, @ernest, maybe you could install bootchart on the phone and send its log?



  • @peat_psuwit I have also a test device here a oneplus 3t i can install bootchart also on it.



  • Installed it on my op3t and can take photos, looks like, it is working. I can start the camera-app from the ubports standard dash.

    Info (maybe OT): But ist is not possible to start it from the modular launcher.



  • Tried on the Nexus 6P, I just get a black camera screen, but no error dialogs, nothing 😉



  • @gischpelino said in How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port):

    Info (maybe OT): But ist is not possible to start it from the modular launcher.

    Did you reboot device? I encountered such behavior with LM whith another apps, rebooted and was solved .



  • @Keneda Reboot? Yes. Solved? No.



  • Hi all.
    Just tried to run the installation of gst-droid as described in the first post. Camera started working when making photos. Attempt to record leads to camera app crash, still better then nothing, amazing job!

    Do I understand correctly that this fix is still no in 'main-stream' and installing any system update on the phone will lead to wiping this app?
    Many thanks!



  • yes, it will be overwritten by every update at the moment, I'm afraid.


Log in to reply