Fairphone 2 (FP2)



  • This is a Halium 7.1 based port for Fairphone 2. The current port is based on Android 5.1 and has quite a few band-aids and workarounds. This port is completely new and isn't based on the current port.

    Sources:
    Kernel: https://github.com/Halium/android_kernel_fairphone_msm8974/tree/halium-7.1
    Device: https://github.com/Halium/android_device_fairphone_FP2/tree/halium-7.1_ubuntu
    Manifest: https://github.com/Halium/halium-devices/blob/halium-7.1/manifests/fairphone_FP2.xml (This manifest doesn't point to the Ubuntu Touch additions. Add revision="refs/heads/halium-7.1_ubuntu" to the device tree tag to retrieve them.)

    Status:

    • Working:
      • Display, Wi-Fi, Audio, Battery indicator, Bluetooth, Video playback, Vibration, GPS, Accelerometer
      • Camera (Needs gst-droid, see the instruction in another post.)
      • Audio (Headphone detection now works correctly.)
      • Cellular (Both SIM slots work. Voice call, SMS, MMS, mobile data works.)
    • Not working:
      • Flashlight (very likely due to gst-droid based camera.)
      • Front LED

    Install:
    No prebuilt image has been made yet. Thus, you're required to build the image from source.



  • I will be happy to test. Do you need testing with the new camera as well? Maybe @nanu-c can help with that.



  • @Flohack @nanu-c Testing the new camera with GStreamer-droid is highly appreciated. I believe that using 7.1 should solve issues with the new camera modules due to no need for any wrapper.



  • @peat_psuwit Pardon for my intrusion. I would like to ask about the working status of sensors in this build. Concretely I mean the accelerometer, compass and front light sensor (am I missing some?). Could you check? Thank you.



  • @jezek Accelerometer works as the screen rotates correctly. LED doesn't work, probably due to the permission issue. SensorStatus doesn't show values from the compass, but I'm not sure if it's due to the port or other problem.



  • @peat_psuwit Thank you for your answer. Compass is not working on current (default) build, that's why I asked, to see if new Halium (7.1) fixes the problem.

    By the "front light sensor" I meant the proximity sensor on the front (near the front camera), that is used to turn off the display while calling (and if not working properly, I always switch to flight mode with my ear during calls). I think, it is used also to automatically regulate brightness.



  • @jezek Normally proximity and brightness are separated. So you can have perfect b rightness regulation but still the display does not switch off during calls.



  • I will gladly test this once images are provided. it's a bit early now as this is my primary phone.



  • So I built the images and flashed my (daily) phone. 🙂
    So far, everything works as exspected. Camera does not, the phone needs a bit longer to awake.

    But I am not completely shure if it is running on Halium now, because my whole data and apps are still there.
    Is there a way to confirm, that it is using Halium now?

    I will test it further and report here.



  • FP2, findings and differences to legacy version:

    • camera does work with gstreamer-droid patch and is superfast
    • after turning flightmode off, it is not needed to enter SIM-pin again
    • waking up from sleep is delayed by some (5?) seconds, what makes it hard sometimes to answer a call, because you have to wait until the swipe is working
    • I can't get a MTP USB connection, when I unplug the device, my pc informs me about using another network connection, lsusb identifies the device as:
    Bus 003 Device 007: ID 0fce:7169 Sony Ericsson Mobile Communications AB FP2
    


  • @Luksus Wakeup from sleep delay affects all Halium 7.1 builds, and the fix is already available, needs just a few lines of config. MTP is a bit tricky to get in, but we will be able to add it, so its also just a known todo than a blocker 😉



  • @Luksus is the data connection toggle enabled after switching off airplane mode? https://github.com/ubports/ubuntu-touch/issues/30 Is the most annoying issue to me currently.

    Also, does the flashlight work ?



  • @Fla the toggle stays enabled but gets inactive when switching flightmode on, and there is also no dataconnection available anymore. After switching flightmode off, the toggle gets enabled again and data connection is also there.

    If you are referring to the bug, where this toggle stays always inactive, regardless of the connection state, then I can say, that I did not encounter this issue so far.

    Sometimes the system isn't aware of the mobiledata connection and I need to toggle mobiledata on and off multiple times, that the system is getting it. This happens for example, when switching WiFi off. As I remember, this did not happen with the legacy port.

    The best Improvement so far is: No more random reboots - yeah!

    I also managed to get rid of the wake up from sleep delay.
    So this build is very usable as daily driver for me.



  • @Fla flashlight does still not work.



  • Update:

    • even, if I not have to re-enter sim pin after turning flightmode off, sometimes the sim locks it self randomly
    • sadly, I encounterd 2 reboots since I flashed it. Both while charging the battery and doing nothing with it
    • to activate a hotspot, I need to turn off WiFi and enable hotspot from within the settings


  • Another Update:

    • Reboots are still much less than on legacy version and happen mostly while charging
    • activating hotspot is a bit fiddly, but works
    • automatic switch between mobile network and WiFi does not always work reliable
    • just encountered that the whole wireless display/aethercast thing is missing 😕

Log in to reply