How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port)

  • @carrabelloy Please remember that you have been informed numerous times about the forum rules. Please provide a translation at the very least or this post will be removed.

  • This post is deleted!

  • @Flohack said in How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port):

    mount | grep android.rules

    Hi. I think i don t have anything for udev rules. Should i put something here ?
    Screenshot from 2020-07-20 17-10-31.png

  • @Stef7773 No, please execute the command as I wrote it mount | grep android.rules

  • @Flohack Hello again. I tried everything and nothing happens. I also did in fastboot mode and adb and nothing happens. I m sorry. Screenshot from 2020-07-21 15-01-17.png

  • You are running this on your host still.
    You need to connect to your phone or use terminal-app.

  • @Flohack Thank you. Can you show me how to connect to my ubuntu touch phone ? Should I use my phone terminal ? or computer terminal ?

    Can you write me nice commands to setup my phone please ? so i can have the camera working.

    Is my first time with ubuntu touch, thanks for your patience.

  • @Stef7773 the best thing is to connect it via a USB cable, and then do an ssh phablet@ and see if that works - password should be your pincode.

  • This post is deleted!

  • @Flohack Hello, i have already connected via USB cable and then i run what you send me but when i put the password it doesn t work, i get a message. Screenshot from 2020-08-04 23-20-18.png

  • Hello @Stef7773 see the documentation about how to enable SSH access on your phone:

  • @Fla Hello, thank you. But i still having problems. this time:
    ~$ ssh phablet@
    ssh: connect to host port 22: Connection refused

    But i check it and everything seems right: ssh service is up etc...
    Why i have a Connection refused ?

  • @Stef7773 add -v to the ssh command to make it verbose and be able to debug. Also, we're pretty off-topic there, maybe you want to join the Telegram group to have real time support and not pollute that topic?

  • Getting this while trying to open camera on Kagura:

  • @konradybcio said in How to: test GStreamer-droid based camera support in Ubuntu Touch (for Halium 7.1 based port):

    Getting this while trying to open camera on Kagura:

    Same output for me on Kagura. Camera loads but all black.

  • Just out of curiosity; what is keeping the xenial_-_gst-droid from being merged for the OnePlus 3T images?

    Because the camera app on the 3T is completely broken. It can't take pictures and it can't record videos. But in order to have that working, one has to give up system-image updates, which is also not desirable.

    There's only an edge channel for the 3T anyway, so it would make sense to me to just merge this at least for that channel.

    For reference, it has also been merged for the PinePhone's development channel. The stock camera app still worked there, although the gstdroid version linked in the OP works better. But on the 3T currently nothing works, other than taking screenshots of the viewfinder.

  • The OnePlus 3(T), among other aarch64 devices, now has an RC channel. After switching to it and re-installing xenial_-_gst-droid with ubports-qa, I found that the camera wasn't working, even though I was still using the 3.1.3+gstdroid Camera app. It just showed the blue spinner infinitely like what happens without using gst-droid.

    After reverting to the Development channel and installing xenial_-_gst-droid again, I was able to take pictures like before.

    The RC channel only seems to be a couple of days behind on Development. Why isn't it possible to use this branch on RC?

    I also read that @Flohack said elsewhere that gst-droid will not be merged in OTA-13, which would be the first stable image for the OnePlus 3(T). If gst-droid doesn't work on RC and then probably also not on Stable, does that mean I have to keep using the Development channel for the next months?

    Like I posted a couple of weeks ago: why don't we merge this branch at least for the devices that have zero working camera support without gst-droid? The OnePlus 3T can't even take pictures on the stock RC, Development and edge images, which is quite limiting.

    When I look at /etc/apt/sources.list.d/ubports.list on my PinePhone, I see the following:

    deb xenial main
    deb xenial_-_edge main
    deb xenial_-_edge_-_pine main
    deb xenial_-_edge_-_wayland main

    This is because the PinePhone needs those branches to function, even though they're not stable and not suitable for all other devices.

    On the 3T it's only

    deb xenial main

    If we'd add

    deb xenial_-_gst-droid main

    on the image overlay, the images could probably just be built with gst-droid support integrated. It's not like we have much to lose on the 3T. Without it the camera doesn't work at all. This is likely true for other Halium 7.1 / aarch64 devices as well.

    I understand that gst-droid may cause regressions on older devices, but now we're shipping images with broken basic functionality for newer devices - that people are more likely to use in the current day - to avoid breaking the older ones. That doesn't seem right to me.

  • @peat_psuwit can you elaborate a bit? Thx!

  • By the way you could install the branch on RC or stable as well, did you try it?

  • @Flohack I tried it on RC and it did not work. It installed, but the camera app didn't take pictures. It just showed the spinner and got stuck.

    That is also what happens without gst-droid.

    There are no Stable images yet for the OnePlus 3T. See here.

    But am I correct that OTA-13 is expected to be the first stable image for all the phones here? I can't speak for all of them, but I do have two OnePlus 3T's, and without gst-droid the camera does not work at all. Not for pictures and not for videos.

    We'd be shipping a "Stable" release with a completely broken basic functionality - the ability to take pictures - without adding the gst-droid branch to at least the op3t images.

Log in to reply