Call for testing: A new way to ignore your problems

  • Hi, everyone!

    I've been tasked with getting some more testing for [real_hwc_wrapper] Do not throw on hwc->set() error or, as I'm calling it, "Ignoring your problems*."

    This fix should reduce or eliminate what people are calling "multiple booting" or similar terms, where you see the clock and a bit of the InfoGraphic on a black background, followed by a black screen, then the Ubuntu Touch loading splash with the colored dots. This symptom is caused by Unity8 crashing, which is caused by the Android graphics composer telling us we did something wrong, which this patch ignores.

    The devices that suffered from this problem the most were the Oneplus One followed by the Nexus 5. I haven't seen it on the Fairphone 2, but I don't deny it could happen. I'm unsure about our Mali or PowerVR (in other words, all the other) devices.

    Please only test this change on a device running the latest images from the devel channel, and test responsibly! In other words, try it on a spare device or when you know you'll be near a computer you can use for reflashing.

    1. Mount a tmpfs so apt can breathe: sudo mount -t tmpfs tmpfs /var/cache/apt/archives
    2. Install the repository: sudo ubports-qa install xenial_-_no-throw-hwcset
    3. Reboot like you've never rebooted before

    Now try rebooting the device and otherwise using it normally. If you previously experienced Unity8 crashing on boot and no longer do, great! If you never experienced the problem and still don't, also great! If you've got a Slimport-compatible device (Nexus 4, 5, or 7) or external display support (BQ M10), please test adding and removing displays to see if it works any better than before. Let me know what you think here.

    To go back to stock, run the UBports Installer again or run sudo system-image-cli -b 0 --progress=dots from a remote shell (see Shell access via adb or Shell access via ssh).

    *In all seriousness, the error that we're ignoring is also ignored by the Android display server, so we believe it's okay for Mir to do so.

  • I think I was having some long boot/unity failing especially while remounting my encrypted home.
    The install went fine, reboot too, restarting unity8 seems faster/smoother.
    Does this install is erased after a system upgrade ?

  • I will test this tomorrow a bit.

    So far I have found a work-around for my OPO. If I reboot Unity8 never starts it just keeps looping as you described, unless...

    I wait for the purple unity splash, then just as it dims the screen (as auto brightness comes online I assume) if I turn off the screen via the power button and wait 20-30sec for the boot to finish, when I turn on the screen I am greeted with a working lockscreen and all is well.

    I have had to do this at most reboots since switching to dev after OTA11. If I don't, the phone eventually boots aftet 5-10mins if looping.

  • Trying this on the Sony Xperia X now. Mostly had reboots when using too much webapps.

  • Installed without complaint this morning and so far 3 boots have gone flawlessly (from the user perspective). Not bad.

  • THANK YOU! success with oneplus one on the latest release of the edge channel

  • Seems it works fine for me on OPO...

  • Tested on BQ E5 running dev with todays update installed before the test.
    Sadly I do still get the SIM pin dialog skipped now on 2 out of 5 reboots.

    I hope I am not mixing up things. This is (too) what this fix is about, isn't it?

  • @danfro, no, not really.

  • I switched to stable and back this weekend to fix an issue of contacts syncing, and when I got back to devel it worked as before with the screen needing to be turned off for unity to boot. I applied this fix and all is well again.

  • Thanks, everyone. We've merged this change and the fix should appear in tomorrow's images.

Log in to reply