Solved: Hammerhead 16.04 Stable Reboot Loop

  • Hello,

    I installed UT 16.04 stable on a Nexus 5 almost a week ago. Everything behaved as expected for several days, but when I turned on the phone one day, it didn't boot into Ubuntu - it didn't get past the black screen, the one that says "Nexus 5" and "Supported by UBPorts". It displayed this for a second or two, then turned off. I wondered if the battery might have somehow got drained (it later turned out that it had plenty of battery life), so I plugged it in to a known good USB wall charger. It immediately showed the same black boot screen for a second, rebooted, showed the screen for a second, and continued to loop in this manner ad infinitum.

    If I hold the volume down button I can reach the bootloader screen, but this also reboots every couple of seconds.

    By fluke, I once managed to get as far as the login screen, but the "Power off" dialogue box (the one with 3 options - power off/restart/cancel) appeared immediately, and then the device restarted. Then it went back to the looping behaviour.

    Is this symptomatic of a hardware issue or a software issue? Any ideas as to what might be causing it? Any help gratefully received.


    Edit 16/11/2019: marking as "solved", not because I have fixed the issue yet, but because the answer gives enough information for users to find a solution.

  • Welcome in the club : power swtich nexus 5

    A simple try is to clean the button and the pad with alcohol soak with it and activate several time the guy.
    I just finished to do it on my wife phone.

  • @ernest Many thanks for your help! Sorry, I should have searched for a hardware issue before posting here.